summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexandre Rostovtsev <tetromino@gentoo.org>2012-03-07 07:18:29 +0000
committerAlexandre Rostovtsev <tetromino@gentoo.org>2012-03-07 07:18:29 +0000
commit3aa4ee3b9f6919337ca992d143339db4c77b8aba (patch)
tree2816980c22908a49cb2e2796f406495b9ec21bcb /dev-libs/btparser
parentUpdate HOMEPAGE. (diff)
downloadgentoo-2-3aa4ee3b9f6919337ca992d143339db4c77b8aba.tar.gz
gentoo-2-3aa4ee3b9f6919337ca992d143339db4c77b8aba.tar.bz2
gentoo-2-3aa4ee3b9f6919337ca992d143339db4c77b8aba.zip
Version bump. Now with python bindings, similarity metrics, and better thread parsing.
(Portage version: 2.2.0_alpha90/cvs/Linux x86_64)
Diffstat (limited to 'dev-libs/btparser')
-rw-r--r--dev-libs/btparser/ChangeLog9
-rw-r--r--dev-libs/btparser/btparser-0.16.ebuild55
2 files changed, 63 insertions, 1 deletions
diff --git a/dev-libs/btparser/ChangeLog b/dev-libs/btparser/ChangeLog
index 867328e0d884..115d8273ab59 100644
--- a/dev-libs/btparser/ChangeLog
+++ b/dev-libs/btparser/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-libs/btparser
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/btparser/ChangeLog,v 1.3 2012/01/14 15:55:32 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/btparser/ChangeLog,v 1.4 2012/03/07 07:18:29 tetromino Exp $
+
+*btparser-0.16 (07 Mar 2012)
+
+ 07 Mar 2012; Alexandre Rostovtsev <tetromino@gentoo.org>
+ +btparser-0.16.ebuild:
+ Version bump. Now with python bindings, similarity metrics, and better thread
+ parsing.
14 Jan 2012; Markus Meier <maekke@gentoo.org> btparser-0.13.ebuild:
x86 stable, bug #393007
diff --git a/dev-libs/btparser/btparser-0.16.ebuild b/dev-libs/btparser/btparser-0.16.ebuild
new file mode 100644
index 000000000000..3eb9986c7b6b
--- /dev/null
+++ b/dev-libs/btparser/btparser-0.16.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/btparser/btparser-0.16.ebuild,v 1.1 2012/03/07 07:18:29 tetromino Exp $
+
+EAPI="4"
+
+PYTHON_DEPEND="2:2.6"
+
+inherit python
+
+DESCRIPTION="Parser and analyzer for backtraces produced by gdb"
+HOMEPAGE="https://fedorahosted.org/btparser/"
+SRC_URI="https://fedorahosted.org/released/${PN}/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="static-libs"
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ app-arch/xz-utils"
+
+pkg_setup() {
+ python_set_active_version 2
+ python_pkg_setup
+}
+
+src_prepare() {
+ python_clean_py-compile_files
+}
+
+src_configure() {
+ # Configure checks for python.pc; our python-2.7 installs python-2.7.pc,
+ # while python-2.6 does not install any pkgconfig file.
+ export PYTHON_CFLAGS=$(python-config --includes)
+ export PYTHON_LIBS=$(python-config --libs)
+
+ econf \
+ $(use_enable static-libs static) \
+ --disable-maintainer-mode
+}
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -exec rm -f {} +
+}
+
+pkg_postinst() {
+ python_mod_optimize btparser
+}
+
+pkg_postrm() {
+ python_mod_cleanup btparser
+}