summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTiziano Müller <dev-zero@gentoo.org>2007-12-24 08:07:44 +0000
committerTiziano Müller <dev-zero@gentoo.org>2007-12-24 08:07:44 +0000
commit39872097d2c158d16d1123083a4ed1abefb173a5 (patch)
tree920ffca114bc96738e6813600dfc1f4887f5d93b /dev-libs/boost
parentVersion bump (bug #202975), only do 'make clean' when tests have been run (bu... (diff)
downloadgentoo-2-39872097d2c158d16d1123083a4ed1abefb173a5.tar.gz
gentoo-2-39872097d2c158d16d1123083a4ed1abefb173a5.tar.bz2
gentoo-2-39872097d2c158d16d1123083a4ed1abefb173a5.zip
Added patch to fix a critical bug in Boost.Function and another one to fix a missing include showing up with gcc-4.3 (both bug #202964). Dropped old version and old revisions.
(Portage version: 2.1.4_rc11)
Diffstat (limited to 'dev-libs/boost')
-rw-r--r--dev-libs/boost/ChangeLog11
-rw-r--r--dev-libs/boost/boost-1.34.0-r1.ebuild265
-rw-r--r--dev-libs/boost/boost-1.34.1-r1.ebuild (renamed from dev-libs/boost/boost-1.34.1.ebuild)12
-rw-r--r--dev-libs/boost/files/boost-1.34.0-gcc42-atomicity.h.patch15
-rw-r--r--dev-libs/boost/files/digest-boost-1.34.0-r13
-rw-r--r--dev-libs/boost/files/digest-boost-1.34.13
-rw-r--r--dev-libs/boost/files/digest-boost-1.34.1-r16
7 files changed, 25 insertions, 290 deletions
diff --git a/dev-libs/boost/ChangeLog b/dev-libs/boost/ChangeLog
index aaaf7054b26d..0878c4069938 100644
--- a/dev-libs/boost/ChangeLog
+++ b/dev-libs/boost/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for dev-libs/boost
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/boost/ChangeLog,v 1.123 2007/11/18 12:15:12 dev-zero Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/boost/ChangeLog,v 1.124 2007/12/24 08:07:43 dev-zero Exp $
+
+*boost-1.34.1-r1 (24 Dec 2007)
+
+ 24 Dec 2007; Tiziano Müller <dev-zero@gentoo.org>
+ -files/boost-1.34.0-gcc42-atomicity.h.patch, -boost-1.34.0-r1.ebuild,
+ -boost-1.34.1.ebuild, +boost-1.34.1-r1.ebuild:
+ Added patch to fix a critical bug in Boost.Function and another one to fix a
+ missing include showing up with gcc-4.3 (both bug #202964). Dropped old
+ version and old revisions.
18 Nov 2007; Tiziano Müller <dev-zero@gentoo.org> boost-1.34.1.ebuild:
Fixed broken links in documentation (bug #194789) and added '-q' to the bjam
diff --git a/dev-libs/boost/boost-1.34.0-r1.ebuild b/dev-libs/boost/boost-1.34.0-r1.ebuild
deleted file mode 100644
index b75ad1888b05..000000000000
--- a/dev-libs/boost/boost-1.34.0-r1.ebuild
+++ /dev/null
@@ -1,265 +0,0 @@
-# Copyright 1999-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/boost/boost-1.34.0-r1.ebuild,v 1.2 2007/07/15 23:28:52 mr_bones_ Exp $
-
-inherit distutils flag-o-matic multilib toolchain-funcs versionator check-reqs
-
-KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
-
-MY_P=${PN}_$(replace_all_version_separators _)
-
-DESCRIPTION="Boost Libraries for C++"
-HOMEPAGE="http://www.boost.org/"
-SRC_URI="mirror://sourceforge/boost/${MY_P}.tar.bz2"
-LICENSE="freedist Boost-1.0"
-SLOT="0"
-IUSE="debug doc icu pyste tools userland_Darwin"
-
-DEPEND="icu? ( >=dev-libs/icu-3.2 )
- sys-libs/zlib
- ~dev-util/boost-build-${PV}"
-RDEPEND="${DEPEND}
- pyste? ( dev-cpp/gccxml dev-python/elementtree )"
-
-S=${WORKDIR}/${MY_P}
-
-# Maintainer Information
-# ToDo:
-# - gccxml needed by pyste is broken with >=gcc-4.1.1 (bug #147976)
-# - write a patch to support /dev/urandom on FreeBSD and OSX (see below)
-
-pkg_setup() {
- if has test ${FEATURES} ; then
- CHECKREQS_DISK_BUILD="1024"
- check_reqs
-
- ewarn "The tests may take several hours on a recent machine"
- ewarn "but they will not fail (unless something weird happens ;-)"
- ewarn "This is because the tests depend on the used compiler/-version"
- ewarn "and the platform and upstream says that this is normal."
- ewarn "If you are interested in the results, please take a look at the"
- ewarn "generated results page:"
- ewarn " ${ROOT}usr/share/doc/${PF}/status/cs-$(uname).html"
- ebeep 5
-
- fi
-}
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
-
- epatch "${FILESDIR}/${P}-gcc42-atomicity.h.patch"
-
- rm boost-build.jam
-
- # This enables building the boost.random library with /dev/urandom support
- if ! use userland_Darwin ; then
- mkdir -p libs/random/build
- cp "${FILESDIR}/random-Jamfile" libs/random/build/Jamfile.v2
- fi
-}
-
-generate_options() {
- LINK_OPTIONS="shared static"
-
- # Maintainer information:
- # The debug-symbols=none and optimization=none
- # are not official upstream flags but a Gentoo
- # specific patch to make sure that all our
- # CXXFLAGS/LDFLAGS are being respected.
- # Using optimization=off would for example add
- # "-O0" and override "-O2" set by the user.
- # Please take a look at the boost-build ebuild
- # for more infomration.
- if ! use debug ; then
- OPTIONS="release debug-symbols=none"
- else
- OPTIONS="debug"
- fi
-
- OPTIONS="${OPTIONS} optimization=none"
-
- use icu && OPTIONS="${OPTIONS} -sHAVE_ICU=1 -sICU_PATH=/usr"
-
- OPTIONS="${OPTIONS} --user-config=${S}/user-config.jam"
-}
-
-generate_userconfig() {
- einfo "Writing new user-config.jam"
- distutils_python_version
-
- local compiler compilerVersion compilerExecutable
- if use userland_Darwin ; then
- compiler=darwin
- compilerExecutable=c++
- append-ldflags -ldl
- else
- compiler=gcc
- compilerVersion=$(gcc-version)
- compilerExecutable=$(tc-getCXX)
- fi
-
- cat > "${S}/user-config.jam" << __EOF__
-import toolset : using ;
-import toolset : flags ;
-using ${compiler} : ${compilerVersion} : ${compilerExecutable} : <cxxflags>"${CXXFLAGS}" <linkflags>"${LDFLAGS}" ;
-using python : ${PYVER} : /usr : /usr/include/python${PYVER} : /usr/lib/python${PYVER} ;
-__EOF__
-
-}
-
-src_compile() {
-
- NUMJOBS=$(sed -e 's/.*\(\-j[ 0-9]\+\) .*/\1/' <<< ${MAKEOPTS})
-
- generate_userconfig
- generate_options
-
- elog "Using the following options to build: "
- elog " ${OPTIONS}"
-
- export BOOST_ROOT=${S}
- export BOOST_BUILD_PATH=/usr/share/boost-build
-
- for linkoption in ${LINK_OPTIONS} ; do
- einfo "Building ${linkoption} libraries"
- bjam ${NUMJOBS} \
- ${OPTIONS} \
- threading=single,multi \
- runtime-link=${linkoption} link=${linkoption} \
- --prefix="${D}/usr" \
- --layout=system \
- || die "building boost failed"
- done
-
- if use pyste; then
- cd "${S}/libs/python/pyste/install"
- distutils_src_compile
- fi
-
- if use tools; then
- cd "${S}/tools/"
- # We have to set optimization to -O0 or -O1 to work around a gcc-bug
- # optimization=off adds -O0 to the compiler call and overwrites our settings.
- bjam ${NUMJOBS} \
- release debug-symbols=none \
- optimization=off \
- --prefix="${D}/usr" \
- --layout=system \
- --user-config="${S}/user-config.jam" \
- || die "building tools failed"
- fi
-
- if has test ${FEATURES} ; then
- cd "${S}/tools/regression/build"
- bjam \
- ${OPTIONS} \
- --prefix="${D}/usr" \
- --layout=system \
- || die "building regression test helpers failed"
- fi
-
-}
-
-src_install () {
-
- generate_options
-
- export BOOST_ROOT=${S}
- export BOOST_BUILD_PATH=/usr/share/boost-build
-
- for linkoption in ${LINK_OPTIONS} ; do
- bjam \
- ${OPTIONS} \
- threading=single,multi \
- runtime-link=${linkoption} link=${linkoption} \
- --prefix="${D}/usr" \
- --includedir="${D}/usr/include" \
- --libdir="${D}/usr/$(get_libdir)" \
- --layout=system \
- install || die "install failed"
- done
-
- dodoc README
-
- if use doc ; then
- dohtml -A pdf,txt \
- *.htm *.gif *.css \
- -r doc libs more people wiki
- fi
-
- cd "${D}/usr/$(get_libdir)"
-
- # If built with debug enabled, all libraries get a 'd' postfix,
- # this breaks linking other apps against boost (bug #181972)
- if use debug ; then
- for lib in $(ls -1 libboost_*) ; do
- dosym ${lib} "/usr/$(get_libdir)/$(sed -e 's/-d\././' -e 's/d\././' <<< ${lib})"
- done
- fi
-
- for lib in $(ls -1 libboost_thread-mt.*) ; do
- dosym ${lib} "/usr/$(get_libdir)/$(sed -e 's/-mt//' <<< ${lib})"
- done
-
- if use pyste; then
- cd "${S}/libs/python/pyste/install"
- distutils_src_install
- fi
-
- if use tools; then
- cd "${S}/dist"
- dobin bin/*
- insinto /usr
- doins -r share
- fi
-
- if has test ${FEATURES} ; then
- cd "${S}/status"
- docinto status
- dohtml *.{html,gif} ../boost.png
- dodoc regress.log
- fi
-}
-
-src_test() {
- generate_options
-
- export BOOST_ROOT=${S}
- export BOOST_BUILD_PATH=/usr/share/boost-build
-
- cd "${S}/status"
-
- # Some of the test-checks seem to rely on regexps
- export LC_ALL="C"
-
- # The following is largely taken from tools/regression/run_tests.sh,
- # but adapted to our needs.
-
- # Run the tests & write them into a file for postprocessing
- bjam \
- ${OPTIONS} \
- --dump-tests 2>&1 | tee regress.log
-
- # Postprocessing
- cat regress.log | "${S}/dist/bin/process_jam_log" --v2
- if test $? != 0 ; then
- die "Postprocessing the build log failed"
- fi
-
- cat > "${S}/status/comment.html" <<- __EOF__
- <p>Tests are run on a <a href="http://www.gentoo.org">Gentoo</a> system.</p>
-__EOF__
-
- # Generate the build log html summary page
- "${S}/dist/bin/compiler_status" --v2 \
- --comment "${S}/status/comment.html" "${S}" \
- cs-$(uname).html cs-$(uname)-links.html
- if test $? != 0 ; then
- die "Generating the build log html summary page failed"
- fi
-
- # And do some cosmetic fixes :)
- sed -i -e 's|../boost.png|boost.png|' *.html
-}
diff --git a/dev-libs/boost/boost-1.34.1.ebuild b/dev-libs/boost/boost-1.34.1-r1.ebuild
index d32c838df55b..08fe603c9469 100644
--- a/dev-libs/boost/boost-1.34.1.ebuild
+++ b/dev-libs/boost/boost-1.34.1-r1.ebuild
@@ -1,16 +1,18 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/boost/boost-1.34.1.ebuild,v 1.6 2007/11/18 12:15:12 dev-zero Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/boost/boost-1.34.1-r1.ebuild,v 1.1 2007/12/24 08:07:43 dev-zero Exp $
inherit distutils flag-o-matic multilib toolchain-funcs versionator check-reqs
KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
MY_P=${PN}_$(replace_all_version_separators _)
+PATCHSET_VERSION="${PV}-1"
DESCRIPTION="Boost Libraries for C++"
HOMEPAGE="http://www.boost.org/"
-SRC_URI="mirror://sourceforge/boost/${MY_P}.tar.bz2"
+SRC_URI="mirror://sourceforge/boost/${MY_P}.tar.bz2
+ mirror://gentoo/boost-patches-${PATCHSET_VERSION}.tbz2"
LICENSE="freedist Boost-1.0"
SLOT="0"
IUSE="debug doc icu pyste tools"
@@ -25,7 +27,6 @@ S=${WORKDIR}/${MY_P}
# Maintainer Information
# ToDo:
-# - gccxml needed by pyste is broken with >=gcc-4.1.1 (bug #147976)
# - write a patch to support /dev/urandom on FreeBSD and OSX (see below)
pkg_setup() {
@@ -47,6 +48,11 @@ pkg_setup() {
src_unpack() {
unpack ${A}
+
+ EPATCH_SOURCE="${WORKDIR}/patches"
+ EPATCH_SUFFIX="patch"
+ epatch
+
cd "${S}"
rm boost-build.jam
diff --git a/dev-libs/boost/files/boost-1.34.0-gcc42-atomicity.h.patch b/dev-libs/boost/files/boost-1.34.0-gcc42-atomicity.h.patch
deleted file mode 100644
index c2ca7f20512b..000000000000
--- a/dev-libs/boost/files/boost-1.34.0-gcc42-atomicity.h.patch
+++ /dev/null
@@ -1,15 +0,0 @@
---- boost_1_34_0/boost/detail/atomic_count_gcc.hpp 2005/04/02 11:37:53 1.5
-+++ boost_1_34_0/boost/detail/atomic_count_gcc.hpp 2007/05/21 01:34:43 1.5.8.1
-@@ -17,7 +17,11 @@
- // http://www.boost.org/LICENSE_1_0.txt)
- //
-
--#include <bits/atomicity.h>
-+#if (__GNUC__ > 4) || ((__GNUC__ == 4) && (__GNUC_MINOR__ >= 2))
-+# include <ext/atomicity.h>
-+#else
-+# include <bits/atomicity.h>
-+#endif
-
- namespace boost
- {
diff --git a/dev-libs/boost/files/digest-boost-1.34.0-r1 b/dev-libs/boost/files/digest-boost-1.34.0-r1
deleted file mode 100644
index 792d3db7556c..000000000000
--- a/dev-libs/boost/files/digest-boost-1.34.0-r1
+++ /dev/null
@@ -1,3 +0,0 @@
-MD5 ed5b9291ffad776f8757a916e1726ad0 boost_1_34_0.tar.bz2 13021700
-RMD160 2297f8093e0b2ecb8d52dd9734f149a073136d8a boost_1_34_0.tar.bz2 13021700
-SHA256 455cb8fa41b759272768257c2e7bdc5c47ec113245dfa533f275e787a855efd2 boost_1_34_0.tar.bz2 13021700
diff --git a/dev-libs/boost/files/digest-boost-1.34.1 b/dev-libs/boost/files/digest-boost-1.34.1
deleted file mode 100644
index 2ec12588df9d..000000000000
--- a/dev-libs/boost/files/digest-boost-1.34.1
+++ /dev/null
@@ -1,3 +0,0 @@
-MD5 2d938467e8a448a2c9763e0a9f8ca7e5 boost_1_34_1.tar.bz2 12986931
-RMD160 303327ff852bc19dd7a94657fdef3c56f5882e06 boost_1_34_1.tar.bz2 12986931
-SHA256 0f866c75b025a4f1340117a106595cc0675f48ba1e5a9b5c221ec7f19e96ec4c boost_1_34_1.tar.bz2 12986931
diff --git a/dev-libs/boost/files/digest-boost-1.34.1-r1 b/dev-libs/boost/files/digest-boost-1.34.1-r1
new file mode 100644
index 000000000000..03c47a2323e6
--- /dev/null
+++ b/dev-libs/boost/files/digest-boost-1.34.1-r1
@@ -0,0 +1,6 @@
+MD5 243f0a062ac112c374fe5035088a8da0 boost-patches-1.34.1-1.tbz2 5031
+RMD160 ff18c94c9fdf6f1c6fe7636bc8c532945ad95a3b boost-patches-1.34.1-1.tbz2 5031
+SHA256 d0753078daab13e47bdf72f249d8fef821688fc93decaccaf7f49e5cae476e01 boost-patches-1.34.1-1.tbz2 5031
+MD5 2d938467e8a448a2c9763e0a9f8ca7e5 boost_1_34_1.tar.bz2 12986931
+RMD160 303327ff852bc19dd7a94657fdef3c56f5882e06 boost_1_34_1.tar.bz2 12986931
+SHA256 0f866c75b025a4f1340117a106595cc0675f48ba1e5a9b5c221ec7f19e96ec4c boost_1_34_1.tar.bz2 12986931