summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergey Popov <pinkbyte@gentoo.org>2013-08-01 18:31:59 +0000
committerSergey Popov <pinkbyte@gentoo.org>2013-08-01 18:31:59 +0000
commit83865719b848b21b94925487e893daef1da8d575 (patch)
treefb7c7fc05d537def115be08b5ad8c71ff7c1fe34 /dev-libs/blitz
parentUpdate HOMEPAGE wrt bug #478906. (diff)
downloadgentoo-2-83865719b848b21b94925487e893daef1da8d575.tar.gz
gentoo-2-83865719b848b21b94925487e893daef1da8d575.tar.bz2
gentoo-2-83865719b848b21b94925487e893daef1da8d575.zip
Drop old versions, wrt bug #478574
(Portage version: 2.2.0_alpha191/cvs/Linux x86_64, signed Manifest commit with key 0x1F357D42)
Diffstat (limited to 'dev-libs/blitz')
-rw-r--r--dev-libs/blitz/ChangeLog6
-rw-r--r--dev-libs/blitz/blitz-0.9-r3.ebuild67
-rw-r--r--dev-libs/blitz/blitz-0.9.ebuild49
-rw-r--r--dev-libs/blitz/files/blitz-0.9-gcc-4.3-missing-includes.patch20
4 files changed, 5 insertions, 137 deletions
diff --git a/dev-libs/blitz/ChangeLog b/dev-libs/blitz/ChangeLog
index 76e5213415c2..abbe12d9ec0a 100644
--- a/dev-libs/blitz/ChangeLog
+++ b/dev-libs/blitz/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-libs/blitz
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/blitz/ChangeLog,v 1.47 2013/08/01 18:30:06 pinkbyte Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/blitz/ChangeLog,v 1.48 2013/08/01 18:31:58 pinkbyte Exp $
+
+ 01 Aug 2013; Sergey Popov <pinkbyte@gentoo.org> -blitz-0.9.ebuild,
+ -blitz-0.9-r3.ebuild, -files/blitz-0.9-gcc-4.3-missing-includes.patch:
+ Drop old versions, wrt bug #478574
*blitz-0.10-r1 (01 Aug 2013)
diff --git a/dev-libs/blitz/blitz-0.9-r3.ebuild b/dev-libs/blitz/blitz-0.9-r3.ebuild
deleted file mode 100644
index 072e72081568..000000000000
--- a/dev-libs/blitz/blitz-0.9-r3.ebuild
+++ /dev/null
@@ -1,67 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/blitz/blitz-0.9-r3.ebuild,v 1.7 2012/10/19 10:33:28 jlec Exp $
-
-EAPI=3
-
-inherit eutils fortran-2
-
-DESCRIPTION="High-performance C++ numeric library"
-SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
-HOMEPAGE="http://www.oonumerics.org/blitz"
-
-SLOT="0"
-LICENSE="|| ( GPL-2 Blitz-Artistic )"
-KEYWORDS="~amd64 ~ppc ~x86 ~ppc-macos ~x86-macos"
-IUSE="debug doc examples"
-
-DEPEND="
- doc? ( app-doc/doxygen )"
-RDEPEND=""
-
-src_prepare() {
- # remove examples compiling
- sed -i \
- -e 's/blitz-uninstalled.pc//' \
- -e 's/examples//g' \
- Makefile.in || die "sed failed"
- epatch "${FILESDIR}"/${P}-gcc-4.3-missing-includes.patch
-}
-
-src_configure() {
- # blas and fortran are only useful for benchmarks
- econf \
- --enable-shared \
- --disable-cxx-flags-preset \
- --disable-fortran \
- --without-blas \
- $(use_enable doc doxygen) \
- $(use_enable doc html-docs) \
- $(use_enable debug)
-}
-
-src_compile() {
- emake \
- LDFLAGS="${LDFLAGS}" \
- lib || die "emake lib failed"
-}
-
-src_test() {
- # exprctor fails if BZ_DEBUG flag is not set
- # CXXFLAGS gets overwritten
- emake AM_CXXFLAGS="-DBZ_DEBUG" check-testsuite || die "selftest failed"
-}
-
-src_install () {
- dodir /usr/share/doc/${PF}/html
- emake \
- DESTDIR="${D}" \
- docdir="${EPREFIX}"/usr/share/doc/${PF}/html \
- install || die "emake install failed"
- dodoc ChangeLog ChangeLog.1 README README.binutils TODO AUTHORS NEWS || die
-
- if use examples; then
- insinto /usr/share/doc/${PF}/examples
- doins examples/*.cpp || die
- fi
-}
diff --git a/dev-libs/blitz/blitz-0.9.ebuild b/dev-libs/blitz/blitz-0.9.ebuild
deleted file mode 100644
index 08572c7df776..000000000000
--- a/dev-libs/blitz/blitz-0.9.ebuild
+++ /dev/null
@@ -1,49 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/blitz/blitz-0.9.ebuild,v 1.15 2012/10/19 10:33:28 jlec Exp $
-
-inherit eutils fortran-2 toolchain-funcs
-
-DESCRIPTION="High-performance C++ numeric library"
-SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
-HOMEPAGE="http://www.oonumerics.org/blitz"
-
-SLOT="0"
-LICENSE="GPL-2"
-KEYWORDS="~amd64 ppc x86"
-IUSE="doc"
-
-DEPEND="
- doc? ( app-doc/doxygen )"
-RDEPEND=""
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
- epatch "${FILESDIR}"/${P}-gcc-4.3-missing-includes.patch
-}
-
-src_compile() {
- local myconf
- # ICC: if we've got it, use it
- [[ $(tc-getCXX) = ic*c ]] && myconf="--with-cxx=icc" || myconf="--with-cxx=gcc"
- #use doc && myconf="$myconf --enable-latex-docs"
- myconf="${myconf} --enable-maintainer-mode --disable-doxygen --disable-dot"
- myconf="${myconf} --enable-shared"
-
- export CC=$(tc-getCC) CXX=$(tc-getCXX) FC=$(tc-getFC)
- econf ${myconf}
-}
-
-src_test() {
- # exprctor fails if BZ_DEBUG flag is not set
- # CXXFLAGS gets overwritten
- emake AM_CXXFLAGS="-DBZ_DEBUG" check-testsuite || die "selftest failed"
-}
-
-src_install () {
- dodir /usr/share/doc/${PF}
- emake DESTDIR="${D}" docdir=/usr/share/doc/${PF} install || die
- dodoc ChangeLog ChangeLog.1 README README.binutils \
- TODO AUTHORS NEWS || die
-}
diff --git a/dev-libs/blitz/files/blitz-0.9-gcc-4.3-missing-includes.patch b/dev-libs/blitz/files/blitz-0.9-gcc-4.3-missing-includes.patch
deleted file mode 100644
index 64ca31c38a7a..000000000000
--- a/dev-libs/blitz/files/blitz-0.9-gcc-4.3-missing-includes.patch
+++ /dev/null
@@ -1,20 +0,0 @@
---- blitz-0.9.orig/blitz/funcs.h
-+++ blitz-0.9/blitz/funcs.h
-@@ -30,6 +30,7 @@
- #include <blitz/blitz.h>
- #include <blitz/promote.h>
- #include <blitz/prettyprint.h>
-+#include <cstdlib>
-
- BZ_NAMESPACE(blitz)
-
---- blitz-0.9.orig/blitz/prettyprint.h
-+++ blitz-0.9/blitz/prettyprint.h
-@@ -27,6 +27,7 @@
-
- #ifndef BZ_PRETTYPRINT_H
- #define BZ_PRETTYPRINT_H
-+#include <cstdlib>
-
- BZ_NAMESPACE(blitz)
-