summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2008-04-26 10:27:37 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2008-04-26 10:27:37 +0000
commit5f980c57eb486645513a2b0327c635ff3c6be57d (patch)
tree051c3b0b42a70ee3e637461dd6ea2df87018f3a5 /dev-libs/blitz
parentRemove old version (diff)
downloadgentoo-2-5f980c57eb486645513a2b0327c635ff3c6be57d.tar.gz
gentoo-2-5f980c57eb486645513a2b0327c635ff3c6be57d.tar.bz2
gentoo-2-5f980c57eb486645513a2b0327c635ff3c6be57d.zip
Removed icc flag, added a revision bump removing fortran stuff (not needed without the benchmarks), and examples building. Propagate user flags and cleanup. See bug #217317
(Portage version: 2.1.5_rc6)
Diffstat (limited to 'dev-libs/blitz')
-rw-r--r--dev-libs/blitz/ChangeLog10
-rw-r--r--dev-libs/blitz/blitz-0.9-r1.ebuild9
-rw-r--r--dev-libs/blitz/blitz-0.9-r2.ebuild60
-rw-r--r--dev-libs/blitz/blitz-0.9.ebuild10
4 files changed, 78 insertions, 11 deletions
diff --git a/dev-libs/blitz/ChangeLog b/dev-libs/blitz/ChangeLog
index 5bbb3b066051..ac9f46d00dea 100644
--- a/dev-libs/blitz/ChangeLog
+++ b/dev-libs/blitz/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for dev-libs/blitz
# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/blitz/ChangeLog,v 1.29 2008/04/01 15:48:32 dragonheart Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/blitz/ChangeLog,v 1.30 2008/04/26 10:27:37 bicatali Exp $
+
+*blitz-0.9-r2 (26 Apr 2008)
+
+ 26 Apr 2008; Sébastien Fabbro <bicatali@gentoo.org> blitz-0.9.ebuild,
+ blitz-0.9-r1.ebuild, +blitz-0.9-r2.ebuild:
+ Removed icc flag, added a revision bump removing fortran stuff (not needed
+ without the benchmarks), and examples building. Propagate user flags and
+ cleanup. See bug #217317.
01 Apr 2008; Daniel Black <dragonheart@gentoo.org>
+files/blitz-0.9-gcc-4.3-missing-includes.patch, blitz-0.9.ebuild,
diff --git a/dev-libs/blitz/blitz-0.9-r1.ebuild b/dev-libs/blitz/blitz-0.9-r1.ebuild
index 143590c6ccf0..5144621f700d 100644
--- a/dev-libs/blitz/blitz-0.9-r1.ebuild
+++ b/dev-libs/blitz/blitz-0.9-r1.ebuild
@@ -1,19 +1,18 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/blitz/blitz-0.9-r1.ebuild,v 1.2 2008/04/01 15:48:32 dragonheart Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/blitz/blitz-0.9-r1.ebuild,v 1.3 2008/04/26 10:27:37 bicatali Exp $
inherit eutils toolchain-funcs fortran
DESCRIPTION="High-performance C++ numeric library"
SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
HOMEPAGE="http://www.oonumerics.org/blitz"
-IUSE="debug doc examples icc"
+IUSE="debug doc examples"
SLOT="0"
KEYWORDS="~amd64 ~ppc ~x86"
LICENSE="|| ( GPL-2 Blitz-Artistic )"
-DEPEND="icc? ( dev-lang/icc )
- doc? ( app-doc/doxygen )"
+DEPEND="doc? ( app-doc/doxygen )"
RDEPEND=""
FORTAN="g77"
@@ -30,7 +29,7 @@ src_unpack() {
src_compile() {
local myconf
# ICC: if we've got it, use it
- use icc && myconf="--with-cxx=icc" || myconf="--with-cxx=gcc"
+ [[ $(tc-getCXX) = ic*c ]] && myconf="--with-cxx=icc" || myconf="--with-cxx=gcc"
export CC=$(tc-getCC) CXX=$(tc-getCXX)
econf \
diff --git a/dev-libs/blitz/blitz-0.9-r2.ebuild b/dev-libs/blitz/blitz-0.9-r2.ebuild
new file mode 100644
index 000000000000..33123cc97e52
--- /dev/null
+++ b/dev-libs/blitz/blitz-0.9-r2.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/blitz/blitz-0.9-r2.ebuild,v 1.1 2008/04/26 10:27:37 bicatali Exp $
+
+inherit eutils
+
+DESCRIPTION="High-performance C++ numeric library"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+HOMEPAGE="http://www.oonumerics.org/blitz"
+IUSE="debug doc examples"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+LICENSE="|| ( GPL-2 Blitz-Artistic )"
+
+DEPEND="doc? ( app-doc/doxygen )"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ # remove examples compiling
+ sed -i \
+ -e 's/blitz-uninstalled.pc//' \
+ -e 's/examples//g' \
+ Makefile.in || die "sed failed"
+ epatch "${FILESDIR}"/${P}-gcc-4.3-missing-includes.patch
+}
+
+src_compile() {
+ # blas and fortran are only useful for benchmarks
+ econf \
+ --enable-shared \
+ --disable-cxx-flags-preset \
+ --disable-fortran \
+ --without-blas \
+ $(use_enable doc doxygen) \
+ $(use_enable doc html-docs) \
+ $(use_enable debug) \
+ || die "econf failed"
+ emake lib || die "emake lib failed"
+}
+
+src_test() {
+ # exprctor fails if BZ_DEBUG flag is not set
+ # CXXFLAGS gets overwritten
+ emake AM_CXXFLAGS="-DBZ_DEBUG" check-testsuite || die "selftest failed"
+}
+
+src_install () {
+ dodir /usr/share/doc/${PF}/html
+ emake \
+ DESTDIR="${D}" \
+ docdir=/usr/share/doc/${PF}/html \
+ install || die "emake install failed"
+ dodoc ChangeLog ChangeLog.1 README README.binutils TODO AUTHORS NEWS
+
+ if use examples; then
+ insinto /usr/share/doc/${PF}/examples
+ doins examples/*.cpp
+ fi
+}
diff --git a/dev-libs/blitz/blitz-0.9.ebuild b/dev-libs/blitz/blitz-0.9.ebuild
index 5b38ad8f5760..9c0337508b22 100644
--- a/dev-libs/blitz/blitz-0.9.ebuild
+++ b/dev-libs/blitz/blitz-0.9.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/blitz/blitz-0.9.ebuild,v 1.8 2008/04/01 15:48:32 dragonheart Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/blitz/blitz-0.9.ebuild,v 1.9 2008/04/26 10:27:37 bicatali Exp $
inherit eutils toolchain-funcs fortran
@@ -8,9 +8,9 @@ DESCRIPTION="High-performance C++ numeric library"
SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
HOMEPAGE="http://www.oonumerics.org/blitz"
#DEPEND="doc? ( virtual/tetex )"
-DEPEND="icc? ( dev-lang/icc )"
+DEPEND=""
RDEPEND=""
-IUSE="icc"
+IUSE=""
SLOT="0"
KEYWORDS="~amd64 ppc x86"
@@ -27,7 +27,7 @@ src_unpack() {
src_compile() {
local myconf
# ICC: if we've got it, use it
- use icc && myconf="--with-cxx=icc" || myconf="--with-cxx=gcc"
+ [[ $(tc-getCXX) = ic*c ]] && myconf="--with-cxx=icc" || myconf="--with-cxx=gcc"
#use doc && myconf="$myconf --enable-latex-docs"
myconf="${myconf} --enable-maintainer-mode --disable-doxygen --disable-dot"
myconf="${myconf} --enable-shared"
@@ -44,5 +44,5 @@ src_install () {
dodir /usr/share/doc/${PF}
emake DESTDIR=${D} docdir=/usr/share/doc/${PF} install || die
dodoc ChangeLog ChangeLog.1 LICENSE README README.binutils \
- TODO COPYING LEGAL AUTHORS NEWS
+ TODO COPYING LEGAL AUTHORS NEWS
}