summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2012-08-13 21:11:11 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2012-08-13 21:11:11 +0000
commit03bc93893542cce27df64185e36b09ca23ebeee5 (patch)
tree79cb230f028dcfcb5a41748a1b5647de3e5fa19a /dev-libs/blitz
parentStable ppc64, bug #430752 (diff)
downloadgentoo-2-03bc93893542cce27df64185e36b09ca23ebeee5.tar.gz
gentoo-2-03bc93893542cce27df64185e36b09ca23ebeee5.tar.bz2
gentoo-2-03bc93893542cce27df64185e36b09ca23ebeee5.zip
Version bump, take maintainership, fixes doc install
(Portage version: 2.2.01.20796-prefix/cvs/Linux x86_64)
Diffstat (limited to 'dev-libs/blitz')
-rw-r--r--dev-libs/blitz/ChangeLog10
-rw-r--r--dev-libs/blitz/blitz-0.10.ebuild59
-rw-r--r--dev-libs/blitz/files/blitz-0.10-docs.patch88
-rw-r--r--dev-libs/blitz/files/blitz-0.10-gcc47.patch33
-rw-r--r--dev-libs/blitz/metadata.xml16
5 files changed, 203 insertions, 3 deletions
diff --git a/dev-libs/blitz/ChangeLog b/dev-libs/blitz/ChangeLog
index 5c3e5d7a587f..61a506e3a241 100644
--- a/dev-libs/blitz/ChangeLog
+++ b/dev-libs/blitz/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-libs/blitz
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/blitz/ChangeLog,v 1.41 2011/07/20 13:56:51 pacho Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/blitz/ChangeLog,v 1.42 2012/08/13 21:11:11 bicatali Exp $
+
+*blitz-0.10 (13 Aug 2012)
+
+ 13 Aug 2012; Sébastien Fabbro <bicatali@gentoo.org> +blitz-0.10.ebuild,
+ +files/blitz-0.10-docs.patch, +files/blitz-0.10-gcc47.patch, metadata.xml:
+ Version bump, take maintainership, fixes doc install
20 Jul 2011; Pacho Ramos <pacho@gentoo.org> metadata.xml:
Drop maintainer due retirement, bug #34534
diff --git a/dev-libs/blitz/blitz-0.10.ebuild b/dev-libs/blitz/blitz-0.10.ebuild
new file mode 100644
index 000000000000..e82ea2534714
--- /dev/null
+++ b/dev-libs/blitz/blitz-0.10.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/blitz/blitz-0.10.ebuild,v 1.1 2012/08/13 21:11:11 bicatali Exp $
+
+EAPI=4
+
+AUTOTOOLS_AUTORECONF=1
+inherit autotools-utils multilib
+
+DESCRIPTION="High-performance C++ numeric library"
+HOMEPAGE="http://blitz.sourceforge.net"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+IUSE="boost debug doc examples static-libs"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~ppc-macos ~x86-linux ~x86-macos"
+LICENSE="|| ( LGPL-3 Artistic-2 BSD )"
+
+RDEPEND="boost? ( >=dev-libs/boost-1.40 )"
+DEPEND="${RDEPEND}
+ doc? ( app-doc/doxygen[dot] )"
+
+PATCHES=( "${FILESDIR}"/${P}-{docs,gcc47}.patch )
+
+src_configure() {
+ # blas / fortran only needed for benchmarks
+ use doc && doxygen -u doc/doxygen/Doxyfile.in
+ local myeconfargs=(
+ --htmldir="${EPREFIX}/usr/share/doc/${PF}/html"
+ --enable-shared
+ --disable-cxx-flags-preset
+ --disable-fortran
+ --without-blas
+ $(use_enable boost serialization)
+ $(use_enable debug)
+ $(use_enable doc doxygen)
+ $(use_enable doc html-docs)
+ $(use_with boost boost "${EPREFIX}/usr")
+ )
+ autotools-utils_src_configure
+}
+
+src_compile() {
+ autotools-utils_src_compile lib $(use doc && echo info html pdf)
+}
+
+src_test() {
+ pushd ${AUTOTOOLS_BUILD_DIR} > /dev/null
+ emake check-testsuite check-examples
+ popd > /dev/null
+}
+
+src_install () {
+ autotools-utils_src_install $(use doc&& echo install-html install-pdf)
+ if use examples; then
+ insinto /usr/share/doc/${PF}/examples
+ doins examples/*.{cpp,f}
+ fi
+}
diff --git a/dev-libs/blitz/files/blitz-0.10-docs.patch b/dev-libs/blitz/files/blitz-0.10-docs.patch
new file mode 100644
index 000000000000..dd0dca77af36
--- /dev/null
+++ b/dev-libs/blitz/files/blitz-0.10-docs.patch
@@ -0,0 +1,88 @@
+* respect user's docdir,htmldir,pdfdir at configuration time
+* install recursive for doxygen generated
+* works for out-of-source directory installation
+
+bicatali@gentoo.org Aug 2012
+
+diff -Nur doc.orig/doxygen/Makefile.am doc/doxygen/Makefile.am
+--- doc.orig/doxygen/Makefile.am 2012-05-11 13:11:13.000000000 -0700
++++ doc/doxygen/Makefile.am 2012-08-13 13:44:27.616583722 -0700
+@@ -2,7 +2,6 @@
+
+ # Support doxygen documentation ?
+
+-docdir = $(datadir)/doc/$(PACKAGE)-$(VERSION)/doxygen
+
+ DISTCLEANFILES = Doxyfile doxygen-warning
+
+@@ -84,29 +83,27 @@
+ $(RM) -rf latex; \
+ fi
+
+-# Install hooks
+-make-install-dirs:
+- @if test '!' -d $(DESTDIR)$(docdir) ; \
+- then mkdir -p $(DESTDIR)$(docdir) ; \
+- fi
+
+-install-data-hook: make-install-dirs
++install-data-hook:
+ @if test -d html; then \
+- echo Installing HTML documentation into $(DESTDIR)$(docdir) ; \
+- $(INSTALL_DATA) html/* $(DESTDIR)$(docdir) ; \
++ echo Installing HTML documentation into $(DESTDIR)$(htmldir) ; \
++ $(MKDIR_P) $(DESTDIR)$(htmldir) ; \
++ cp -r html/* $(DESTDIR)$(htmldir) ; \
+ fi
+ @if test -f $(PACKAGE).pdf; then \
+- echo Installing PDF manual into $(DESTDIR)$(docdir) ; \
+- $(INSTALL_DATA) $(PACKAGE).pdf $(DESTDIR)$(docdir) ; \
++ echo Installing PDF manual into $(DESTDIR)$(pdfdir) ; \
++ $(MKDIR_P) $(DESTDIR)$(pdfdir) ; \
++ $(INSTALL_DATA) $(PACKAGE).pdf $(DESTDIR)$(pdfdir) ; \
+ fi
+ @if test -f $(PACKAGE).ps; then \
+- echo Installing PS manual into $(DESTDIR)$(docdir) ; \
+- $(INSTALL_DATA) $(PACKAGE).ps $(DESTDIR)$(docdir) ; \
++ echo Installing PS manual into $(DESTDIR)$(psdir) ; \
++ $(MKDIR_P) $(DESTDIR)$(psdir) ; \
++ $(INSTALL_DATA) $(PACKAGE).ps $(DESTDIR)$(psdir) ; \
+ fi
+
+ uninstall-hook:
+ @echo Uninstalling doxygen documentation directory ; \
+- rm -rf "$(DESTDIR)$(docdir)";
++ rm -rf "$(DESTDIR)$(htmldir)" "$(DESTDIR)$(psdir)" "$(DESTDIR)$(pdfdir)" ;
+
+
+
+diff -Nur doc.orig/Makefile.am doc/Makefile.am
+--- doc.orig/Makefile.am 2012-05-11 13:11:13.000000000 -0700
++++ doc/Makefile.am 2012-08-13 13:54:04.490647132 -0700
+@@ -4,8 +4,6 @@
+
+ SUBDIRS = examples stencils doxygen
+
+-# docdir directory to install the doc (pdf ps html)
+-docdir = $(datadir)/doc/$(PACKAGE)-$(VERSION)
+
+ DVIPS=export TEXPICTS=$(srcdir); dvips
+ AM_MAKEINFOFLAGS = --no-split -I$(srcdir)
+@@ -78,7 +76,7 @@
+ # Install also the images into the directory html
+ install-html-local:
+ test -z "$(htmldir)" || $(MKDIR_P) "$(DESTDIR)$(htmldir)"
+- $(INSTALL_DATA) *.gif *.jpg $(DESTDIR)$(htmldir)
++ $(INSTALL_DATA) $(srcdir)/*.gif $(srcdir)/*.jpg $(DESTDIR)$(htmldir)
+
+ .PHONY: html
+
+@@ -86,7 +84,7 @@
+
+ # Install also the images into the directory containing the html files
+ install-html-local:
+- $(INSTALL_DATA) *.gif *.jpg blitz.html
++ $(INSTALL_DATA) $(srcdir)/*.gif $(srcdir)/*.jpg $(top_builddir)/doc/blitz.html
+
+ endif
+
diff --git a/dev-libs/blitz/files/blitz-0.10-gcc47.patch b/dev-libs/blitz/files/blitz-0.10-gcc47.patch
new file mode 100644
index 000000000000..d0b35665567b
--- /dev/null
+++ b/dev-libs/blitz/files/blitz-0.10-gcc47.patch
@@ -0,0 +1,33 @@
+diff -ur blitz-0.10/blitz/bzdebug.h blitz-0.10.new/blitz/bzdebug.h
+--- blitz-0.10/blitz/bzdebug.h 2012-05-11 22:11:13.000000000 +0200
++++ blitz-0.10.new/blitz/bzdebug.h 2012-06-28 15:42:38.060656045 +0200
+@@ -117,15 +117,15 @@
+ }
+ }
+
+- #define BZASSERT(X) checkAssert(X, __FILE__, __LINE__)
+- #define BZPRECONDITION(X) checkAssert(X, __FILE__, __LINE__)
+- #define BZPOSTCONDITION(X) checkAssert(X, __FILE__, __LINE__)
+- #define BZSTATECHECK(X,Y) checkAssert(X == Y, __FILE__, __LINE__)
++ #define BZASSERT(X) blitz::checkAssert(X, __FILE__, __LINE__)
++ #define BZPRECONDITION(X) blitz::checkAssert(X, __FILE__, __LINE__)
++ #define BZPOSTCONDITION(X) blitz::checkAssert(X, __FILE__, __LINE__)
++ #define BZSTATECHECK(X,Y) blitz::checkAssert(X == Y, __FILE__, __LINE__)
+ #define BZPRECHECK(X,Y) \
+ { \
+ if ((assertFailMode == false) && (!(X))) \
+ BZ_STD_SCOPE(cerr) << Y << BZ_STD_SCOPE(endl); \
+- checkAssert(X, __FILE__, __LINE__); \
++ blitz::checkAssert(X, __FILE__, __LINE__); \
+ }
+
+ #define BZ_DEBUG_MESSAGE(X) \
+@@ -138,7 +138,7 @@
+ }
+
+ #define BZ_DEBUG_PARAM(X) X
+- #define BZ_PRE_FAIL checkAssert(0)
++ #define BZ_PRE_FAIL blitz::checkAssert(0)
+ #define BZ_ASM_DEBUG_MARKER
+
+ #elif defined(BZ_DEBUG)
diff --git a/dev-libs/blitz/metadata.xml b/dev-libs/blitz/metadata.xml
index bc97bb6ee207..40b4558aaa0c 100644
--- a/dev-libs/blitz/metadata.xml
+++ b/dev-libs/blitz/metadata.xml
@@ -1,5 +1,19 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <herd>cpp</herd>
+<herd>cpp</herd>
+<maintainer>
+ <email>bicatali@gentoo.org</email>
+ <description>feel free to fix/update</description>
+</maintainer>
+<longdescription lang='en'>
+ Blitz++ is a meta-template library for array
+ manipulation in C++ with a speed comparable to Fortran
+ implementations, while preserving an object-oriented
+ interface. These results are being obtained not through better
+ optimizing compilers, preprocessors, or language extensions, but
+ through the use of template techniques. By using templates cleverly,
+ optimizations such as loop fusion, unrolling, tiling, and algorithm
+ specialization can be performed automatically at compile time.
+</longdescription>
</pkgmetadata>