summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorElfyn McBratney <beu@gentoo.org>2005-05-10 23:54:36 +0000
committerElfyn McBratney <beu@gentoo.org>2005-05-10 23:54:36 +0000
commit70e569b3369b720304156e5aec411aaeee8d7965 (patch)
treea694205485cb359182d2c7804e1ef62f6fd9bb02 /dev-libs/apr-util/apr-util-0.9.6-r2.ebuild
parentNew upstream version. (diff)
downloadgentoo-2-70e569b3369b720304156e5aec411aaeee8d7965.tar.gz
gentoo-2-70e569b3369b720304156e5aec411aaeee8d7965.tar.bz2
gentoo-2-70e569b3369b720304156e5aec411aaeee8d7965.zip
Rev bumps to pick up on the LFS-removal from apr.
(Portage version: 2.0.51.21-r1)
Diffstat (limited to 'dev-libs/apr-util/apr-util-0.9.6-r2.ebuild')
-rw-r--r--dev-libs/apr-util/apr-util-0.9.6-r2.ebuild69
1 files changed, 69 insertions, 0 deletions
diff --git a/dev-libs/apr-util/apr-util-0.9.6-r2.ebuild b/dev-libs/apr-util/apr-util-0.9.6-r2.ebuild
new file mode 100644
index 000000000000..6afc427b580d
--- /dev/null
+++ b/dev-libs/apr-util/apr-util-0.9.6-r2.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/apr-util/apr-util-0.9.6-r2.ebuild,v 1.1 2005/05/10 23:54:36 beu Exp $
+
+inherit eutils
+
+DESCRIPTION="Apache Portable Runtime Library"
+HOMEPAGE="http://apr.apache.org/"
+SRC_URI="mirror://apache/apr/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sparc ~x86"
+IUSE="berkdb gdbm ldap"
+
+DEPEND="dev-libs/expat
+ ~dev-libs/apr-0.9.6
+ berkdb? ( sys-libs/db )
+ gdbm? ( sys-libs/gdbm )
+ ldap? ( =net-nds/openldap-2* )"
+
+src_unpack() {
+ unpack ${A} || die "unpack"
+
+ cd ${S} || die
+
+ epatch "${FILESDIR}/apr-util-0.9.x-161086:161087.patch" \
+ || die "patching failed"
+}
+
+src_compile() {
+ local myconf=""
+ if use ldap; then
+ myconf="${myconf} --with-ldap"
+ fi
+
+ if use berkdb; then
+ if has_version '=sys-libs/db-4.2*'; then
+ myconf="${myconf} --with-dbm=db42 --with-berkely-db=/usr"
+ elif has_version '=sys-libs/db-4*'; then
+ myconf="${myconf} --with-dbm=db4 --with-berkely-db=/usr"
+ elif has_version '=sys-libs/db-3*'; then
+ myconf="${myconf} --with-dbm=db3 --with-berkely-db=/usr"
+ elif has_version '=sys-libs/db-2'; then
+ myconf="${myconf} --with-dbm=db2 --with-berkely-db=/usr"
+ fi
+ fi
+
+ econf \
+ --datadir=/usr/share/apr-util-0 \
+ --with-apr=/usr \
+ --with-expat=/usr \
+ $myconf || die
+
+ emake || die
+}
+
+src_install() {
+ make DESTDIR="${D}" installbuilddir=/usr/share/apr-util-0/build install || die
+
+ #bogus values pointing at /var/tmp/portage
+ sed -i -e 's:APU_SOURCE_DIR=.*:APU_SOURCE_DIR=:g' ${D}/usr/bin/apu-config
+ sed -i -e 's:APU_BUILD_DIR=.*:APU_BUILD_DIR=/usr/share/apr-util-0/build:g' ${D}/usr/bin/apu-config
+
+ dodoc CHANGES NOTICE
+
+ # Will install as portage user when using userpriv. Fixing
+ chown -R root:root ${D}/usr/include/apr-0/
+}