summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Black <dragonheart@gentoo.org>2006-11-02 19:01:46 +0000
committerDaniel Black <dragonheart@gentoo.org>2006-11-02 19:01:46 +0000
commit029c128e723d6d5b4ea0b8d140a044f88a29d821 (patch)
treecacc8d9a2bd7f89d0d417565dd6df25e47e819bc /dev-libs/ace
parentadded dev-libs/ace:tao (diff)
downloadgentoo-2-029c128e723d6d5b4ea0b8d140a044f88a29d821.tar.gz
gentoo-2-029c128e723d6d5b4ea0b8d140a044f88a29d821.tar.bz2
gentoo-2-029c128e723d6d5b4ea0b8d140a044f88a29d821.zip
tao extensions as per bug #89913 thanks to Ben Gardiner and Patrizio Bassi
(Portage version: 2.1.2_rc1-r1)
Diffstat (limited to 'dev-libs/ace')
-rw-r--r--dev-libs/ace/ChangeLog7
-rw-r--r--dev-libs/ace/ace-5.5-r1.ebuild68
-rw-r--r--dev-libs/ace/files/digest-ace-5.5-r16
3 files changed, 80 insertions, 1 deletions
diff --git a/dev-libs/ace/ChangeLog b/dev-libs/ace/ChangeLog
index f9efefe97c49..c95391206a25 100644
--- a/dev-libs/ace/ChangeLog
+++ b/dev-libs/ace/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-libs/ace
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/ace/ChangeLog,v 1.35 2006/10/20 00:10:23 kloeri Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/ace/ChangeLog,v 1.36 2006/11/02 19:01:46 dragonheart Exp $
+
+*ace-5.5-r1 (02 Nov 2006)
+
+ 02 Nov 2006; Daniel Black <dragonheart@gentoo.org> +ace-5.5-r1.ebuild:
+ tao extensions as per bug #89913 thanks to Ben Gardiner and Patrizio Bassi
20 Oct 2006; Bryan Østergaard <kloeri@gentoo.org> ace-5.4.6.ebuild:
Stable on Alpha.
diff --git a/dev-libs/ace/ace-5.5-r1.ebuild b/dev-libs/ace/ace-5.5-r1.ebuild
new file mode 100644
index 000000000000..c282552239ad
--- /dev/null
+++ b/dev-libs/ace/ace-5.5-r1.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/ace/ace-5.5-r1.ebuild,v 1.1 2006/11/02 19:01:46 dragonheart Exp $
+
+inherit eutils
+
+S="${WORKDIR}/ACE_wrappers"
+DESCRIPTION="The Adaptive Communications Environment"
+SRC_URI="!tao? ( http://deuce.doc.wustl.edu/old_distribution/ACE-${PV}.tar.bz2 )
+ tao? ( http://deuce.doc.wustl.edu/old_distribution/ACE-${PV}+TAO-1.5.tar.bz2 )"
+
+HOMEPAGE="http://www.cs.wustl.edu/~schmidt/ACE.html"
+
+SLOT="0"
+LICENSE="BSD as-is"
+KEYWORDS="~x86 ~sparc ~ppc ~alpha ~amd64"
+IUSE="X ipv6 tao"
+
+DEPEND="dev-libs/openssl"
+
+RDEPEND="${DEPEND}
+ X? ( || (
+ ( x11-libs/libXt
+ x11-libs/libXaw )
+ virtual/x11 )
+ )"
+
+DEPEND="${DEPEND}
+ X? ( || (
+ ( x11-proto/xproto )
+ virtual/x11 )
+ )"
+
+src_compile() {
+ export ACE_ROOT="${S}"
+ mkdir build
+ cd build
+ ECONF_SOURCE="${S}"
+ econf --enable-lib-all $(use_with X) $(use_enable ipv6) $(use_with tao) || \
+ die "econf died"
+ # --with-qos needs ACE_HAS_RAPI
+ emake static_libs=1 || die
+}
+
+
+src_test() {
+ cd ${S}/build
+ make ACE_ROOT=${S} check || die "self test failed"
+ #einfo "src_test currently stalls after Process_Mutex_Test"
+}
+
+src_install() {
+ cd build
+ make ACE_ROOT="${S}" DESTDIR="${D}" install || die "failed to install"
+}
+
+
+pkg_postinst() {
+ # This is required, as anything trying to compile against ACE will have
+ # problems with conflicting OS.h files if this is not done.
+
+ local CC_MACHINE=`gcc -dumpmachine`
+ local CC_VERSION=`gcc -dumpversion`
+ if [ -d "/usr/lib/gcc-lib/${CC_MACHINE}/${CC_VERSION}/include/ace" ]; then
+ mv "/usr/lib/gcc-lib/${CC_MACHINE}/${CC_VERSION}/include/ace" \
+ "/usr/lib/gcc-lib/${CC_MACHINE}/${CC_VERSION}/include/ace.old"
+ fi
+}
diff --git a/dev-libs/ace/files/digest-ace-5.5-r1 b/dev-libs/ace/files/digest-ace-5.5-r1
new file mode 100644
index 000000000000..4a5abd752187
--- /dev/null
+++ b/dev-libs/ace/files/digest-ace-5.5-r1
@@ -0,0 +1,6 @@
+MD5 8cf19d63f94291e79f0ae6a8e3ecef0e ACE-5.5+TAO-1.5.tar.bz2 19518497
+RMD160 a11421585630071a24d9c1f6ba2d4bdd81b25e9b ACE-5.5+TAO-1.5.tar.bz2 19518497
+SHA256 48bac6620ceda1801cdaa9751a6b0b01be960fd34607897fb823adfe5114797d ACE-5.5+TAO-1.5.tar.bz2 19518497
+MD5 23b8278b50b43ed9b6fa096a65436878 ACE-5.5.tar.bz2 7595626
+RMD160 300763ae9e46975ec35fb0cbe0d9b1959058c2dc ACE-5.5.tar.bz2 7595626
+SHA256 174f665d96edd8af2b38123e0c94039f8f429ecee99d9cb761afde1a082f5ddd ACE-5.5.tar.bz2 7595626