summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2009-01-02 23:36:29 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2009-01-02 23:36:29 +0000
commitae5d7df201a1f90dbbd199241e56f21c0ed23f58 (patch)
tree6ed07e8d1a82f4e6471d6b9cf20da7580a61097a /dev-libs/OpenSRF
parentInitial commit. Dep for EverGreen ILS (via CQL-Parser). (diff)
downloadgentoo-2-ae5d7df201a1f90dbbd199241e56f21c0ed23f58.tar.gz
gentoo-2-ae5d7df201a1f90dbbd199241e56f21c0ed23f58.tar.bz2
gentoo-2-ae5d7df201a1f90dbbd199241e56f21c0ed23f58.zip
Disable the pkg_config routine for now as it needs functional jabber. Fix a braindead search in the ctl tool, and remember to install the docs and javascript, and everything with correct paths.
(Portage version: 2.2_rc20/cvs/Linux 2.6.28-03114-g3c92ec8 x86_64)
Diffstat (limited to 'dev-libs/OpenSRF')
-rw-r--r--dev-libs/OpenSRF/ChangeLog10
-rw-r--r--dev-libs/OpenSRF/OpenSRF-1.0.1.ebuild32
-rw-r--r--dev-libs/OpenSRF/files/OpenSRF-1.0.1-buildfix.patch14
3 files changed, 39 insertions, 17 deletions
diff --git a/dev-libs/OpenSRF/ChangeLog b/dev-libs/OpenSRF/ChangeLog
index 22bf0d4783c7..352b9f9090ee 100644
--- a/dev-libs/OpenSRF/ChangeLog
+++ b/dev-libs/OpenSRF/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-libs/OpenSRF
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/OpenSRF/ChangeLog,v 1.3 2008/12/09 10:05:16 robbat2 Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/OpenSRF/ChangeLog,v 1.4 2009/01/02 23:36:29 robbat2 Exp $
+
+ 02 Jan 2009; Robin H. Johnson <robbat2@gentoo.org>
+ files/OpenSRF-1.0.1-buildfix.patch, OpenSRF-1.0.1.ebuild:
+ Disable the pkg_config routine for now as it needs functional jabber. Fix
+ a braindead search in the ctl tool, and remember to install the docs and
+ javascript, and everything with correct paths.
09 Dec 2008; Robin H. Johnson <robbat2@gentoo.org> OpenSRF-1.0.1.ebuild:
Use a more useful sysconf dir, for OpenILS/Evergreen to pick up.
diff --git a/dev-libs/OpenSRF/OpenSRF-1.0.1.ebuild b/dev-libs/OpenSRF/OpenSRF-1.0.1.ebuild
index d970156249a8..584e7193610e 100644
--- a/dev-libs/OpenSRF/OpenSRF-1.0.1.ebuild
+++ b/dev-libs/OpenSRF/OpenSRF-1.0.1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/OpenSRF/OpenSRF-1.0.1.ebuild,v 1.2 2008/12/09 10:05:16 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/OpenSRF/OpenSRF-1.0.1.ebuild,v 1.3 2009/01/02 23:36:29 robbat2 Exp $
inherit eutils multilib flag-o-matic apache-module autotools perl-module
@@ -99,6 +99,7 @@ src_compile() {
econf \
--with-apxs=/usr/sbin/apxs2 \
--sysconfdir=/etc/opensrf \
+ --localstatedir=/var \
|| die "econf failed"
cd "${S}" && emake || die "main emake failed"
cd "${PERL_S}" && S="${PERL_S}" perl-module_src_compile || die "perl-module_src_compile failed"
@@ -110,9 +111,9 @@ src_install() {
emake install DESTDIR="${D}" || die "Failed to install"
apache-module_src_install || die "apache-module_src_install failed"
cd "${PERL_S}" && S="${PERL_S}" perl-module_src_install || die "perl-module_src_install failed"
- #insinto /usr/share/opensrf
- #doins src/javascript/*js
- #dodoc doc/*
+ insinto /usr/share/opensrf
+ doins src/javascript/*js
+ dodoc README doc/*
}
src_test() {
@@ -121,14 +122,15 @@ src_test() {
}
pkg_config() {
- JABBER_SERVER=${JABBER_SERVER:=localhost}
- JABBER_PORT=${JABBER_PORT:=5222}
- PASSWORD=${PASSWORD:=osrf}
- einfo "Using Jabber server at ${JABBER_SERVER}:${JABBER_PORT}"
- einfo "Adding 'osrf' and 'router' users with password ${PASSWORD}"
- cd "${ROOT}"/usr/share/doc/${PF}/examples
- for user in osrf router ; do
- perl register.pl ${JABBER_SERVER} ${JABBER_PORT} ${user} ${PASSWORD} \
- || die "Failed to add $user user to server"
- done
+ :
+ #JABBER_SERVER=${JABBER_SERVER:=localhost}
+ #JABBER_PORT=${JABBER_PORT:=5222}
+ #PASSWORD=${PASSWORD:=osrf}
+ #einfo "Using Jabber server at ${JABBER_SERVER}:${JABBER_PORT}"
+ #einfo "Adding 'osrf' and 'router' users with password ${PASSWORD}"
+ #cd "${ROOT}"/usr/share/doc/${PF}/examples
+ #for user in osrf router ; do
+ # perl register.pl ${JABBER_SERVER} ${JABBER_PORT} ${user} ${PASSWORD} \
+ # || die "Failed to add $user user to server"
+ #done
}
diff --git a/dev-libs/OpenSRF/files/OpenSRF-1.0.1-buildfix.patch b/dev-libs/OpenSRF/files/OpenSRF-1.0.1-buildfix.patch
index 75a6f8ac2e2e..e93e6e6f824e 100644
--- a/dev-libs/OpenSRF/files/OpenSRF-1.0.1-buildfix.patch
+++ b/dev-libs/OpenSRF/files/OpenSRF-1.0.1-buildfix.patch
@@ -3,6 +3,7 @@
- split out install targets to build the apache modules
- disable perl and apache install targets, will use gentoo tools instead
- compile fix to osrf_chat.c
+- Hardcode location of osrf_config instead of using a long recursive find statement
Signed-off-by: Robin H. Johnson <robbat2@gentoo.org>
@@ -162,3 +163,16 @@ diff -Nuar OpenSRF-1.0.1.orig/Makefile.am OpenSRF-1.0.1/Makefile.am
- cp @srcdir@/src/gateway/apachetools.h @includedir@/opensrf/apachetools.h
+ cp @srcdir@/src/gateway/apachetools.h $(DESTDIR)@includedir@/opensrf/apachetools.h
+diff -Nuar OpenSRF-1.0.1/bin/osrf_ctl.sh
+--- OpenSRF-1.0.1.orig/bin/osrf_ctl.sh 2008-09-24 20:27:44.000000000 -0700
++++ OpenSRF-1.0.1/bin/osrf_ctl.sh 2008-12-09 02:25:39.018456228 -0800
+@@ -87,7 +87,8 @@
+ esac;
+ done
+
+-OSRF_CONFIG=`find $BASEDIR -name osrf_config`
++#OSRF_CONFIG=`find $BASEDIR -name osrf_config`
++OSRF_CONFIG=/usr/bin/osrf_config
+
+ [ -z "$OPT_CONFIG" ] && OPT_CONFIG=`$OSRF_CONFIG --sysconfdir`/opensrf_core.xml;
+ if [ ! -r "$OPT_CONFIG" ]; then