summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2004-08-12 07:09:16 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2004-08-12 07:09:16 +0000
commit22057dd34ae61471f9cf143b264234bdfb9d4c71 (patch)
tree26c48edb81f255c484502c1946dc58cfd5ed9d06 /dev-libs/DirectFB
parentversion bump (bug #59865) (Manifest recommit) (diff)
downloadgentoo-2-22057dd34ae61471f9cf143b264234bdfb9d4c71.tar.gz
gentoo-2-22057dd34ae61471f9cf143b264234bdfb9d4c71.tar.bz2
gentoo-2-22057dd34ae61471f9cf143b264234bdfb9d4c71.zip
Fix mms/sse for non-amd64; error check sed; tidy
Diffstat (limited to 'dev-libs/DirectFB')
-rw-r--r--dev-libs/DirectFB/ChangeLog8
-rw-r--r--dev-libs/DirectFB/DirectFB-0.9.20-r1.ebuild109
-rw-r--r--dev-libs/DirectFB/Manifest6
-rw-r--r--dev-libs/DirectFB/files/digest-DirectFB-0.9.20-r11
4 files changed, 121 insertions, 3 deletions
diff --git a/dev-libs/DirectFB/ChangeLog b/dev-libs/DirectFB/ChangeLog
index ecfa507a3cc9..10591bc12f5e 100644
--- a/dev-libs/DirectFB/ChangeLog
+++ b/dev-libs/DirectFB/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-libs/DirectFB
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/DirectFB/ChangeLog,v 1.41 2004/06/24 23:05:08 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/DirectFB/ChangeLog,v 1.42 2004/08/12 07:09:16 mr_bones_ Exp $
+
+*DirectFB-0.9.20-r1 (12 Aug 2004)
+
+ 12 Aug 2004; Michael Sterrett <mr_bones_@gentoo.org>
+ +DirectFB-0.9.20-r1.ebuild:
+ Fix mms/sse for non-amd64; error check sed; tidy
04 May 2004; Travis Tilley <lv@gentoo.org>
+files/DirectFB-0.9.20-64bit.diff, +files/DirectFB-0.9.20-simd-amd64.diff,
diff --git a/dev-libs/DirectFB/DirectFB-0.9.20-r1.ebuild b/dev-libs/DirectFB/DirectFB-0.9.20-r1.ebuild
new file mode 100644
index 000000000000..910899934711
--- /dev/null
+++ b/dev-libs/DirectFB/DirectFB-0.9.20-r1.ebuild
@@ -0,0 +1,109 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/DirectFB/DirectFB-0.9.20-r1.ebuild,v 1.1 2004/08/12 07:09:16 mr_bones_ Exp $
+
+inherit eutils 64-bit
+
+IUSE_VIDEO_CARDS="ati128 cle266 cyber5k i810 matrox neomagic nsc nvidia radeon savage tdfx"
+
+DESCRIPTION="Thin library on top of the Linux framebuffer devices"
+HOMEPAGE="http://www.directfb.org/"
+SRC_URI="http://www.directfb.org/download/DirectFB/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="x86 ppc -sparc alpha hppa ia64 -mips amd64"
+IUSE="jpeg gif png truetype mpeg mmx sse fusion"
+
+DEPEND="dev-lang/perl
+ gif? ( media-libs/giflib )
+ png? ( media-libs/libpng )
+ jpeg? ( media-libs/jpeg )
+ mpeg? ( media-libs/libmpeg3 )
+ truetype? ( >=media-libs/freetype-2.0.1 )"
+
+pkg_setup() {
+ if [ -z "${VIDEO_CARDS}" ] ; then
+ ewarn "All video drivers will be built since you did not specify"
+ ewarn "via the VIDEO_CARDS variable what video card you use."
+ einfo "DirectFB supports: ${IUSE_VIDEO_CARDS} all none"
+ fi
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}/${PV}-linux-2.6.patch"
+
+ # This patch changes ints to longs where appropriate
+ 64-bit && epatch "${FILESDIR}/DirectFB-0.9.20-64bit.diff"
+
+ # This patch enables simd optimisations for amd64. Since mmx and sse are
+ # masked USE flags on amd64 due to their enabling x86 specific asm more
+ # often than not, we'll just enable them by default. All x86_64 cpus
+ # should support mmx and see. Travis Tilley <lv@gentoo.org>
+ use amd64 && epatch "${FILESDIR}/DirectFB-0.9.20-simd-amd64.diff"
+
+ # bug #36924
+ sed -i \
+ -e 's:wm97xx_ts=yes:wm97xx_ts=no:' configure \
+ || die "sed configure failed"
+}
+
+src_compile() {
+ local vidcards
+ local card
+ local mycppflags
+ local myconf
+
+ for card in ${VIDEO_CARDS} ; do
+ has ${card} ${IUSE_VIDEO_CARDS} && vidcards="${vidcards},${card}"
+ done
+ [ -z "${vidcards}" ] \
+ && vidcards="all" \
+ || vidcards="${vidcards:1}"
+
+ use mpeg && mycppflags="-I/usr/include/libmpeg3"
+ if use amd64 ; then
+ myconf="--enable-mmx --enable-sse"
+ fi
+ econf CPPFLAGS="${mycppflags}" \
+ $(use_enable mmx) \
+ $(use_enable sse) \
+ $(use_enable mpeg libmpeg3) \
+ $(use_enable jpeg) \
+ $(use_enable png) \
+ $(use_enable gif) \
+ $(use_enable truetype freetype) \
+ $(use_enable fusion multi) \
+ ${myconf} \
+ --with-gfxdrivers="${vidcards}" \
+ || die
+
+ if use mpeg ; then
+ sed -i \
+ s':#include <libmpeg3.h>:#include <libmpeg3/libmpeg3.h>:' \
+ ${S}/interfaces/IDirectFBVideoProvider/idirectfbvideoprovider_libmpeg3.c \
+ || die "sed idirectfbvideoprovider_libmpeg3.c failed"
+ fi
+
+ # add extra -lstdc++ so libpng/libflash link correctly
+ make CPPFLAGS="${mycppflags}" LDFLAGS="${LDFLAGS} -lstdc++" || die
+}
+
+src_install() {
+ insinto /etc
+ doins fb.modes
+
+ make DESTDIR="${D}" install || die "make install failed"
+
+ dodoc AUTHORS ChangeLog NEWS README* TODO
+ dohtml -r docs/html/*
+}
+
+pkg_postinst() {
+ ewarn "Each DirectFB update in the 0.9.xx series"
+ ewarn "breaks DirectFB related applications."
+ ewarn "Please run \"revdep-rebuild\" which can be"
+ ewarn "found by emerging the package 'gentoolkit'."
+}
diff --git a/dev-libs/DirectFB/Manifest b/dev-libs/DirectFB/Manifest
index d66701b21562..023fa851642f 100644
--- a/dev-libs/DirectFB/Manifest
+++ b/dev-libs/DirectFB/Manifest
@@ -1,7 +1,9 @@
-MD5 1129b08d3255f5771e00f2eacb6b8051 DirectFB-0.9.20.ebuild 2971
MD5 a42c822b04875c5d64c7db53e3a837bd ChangeLog 6365
+MD5 1129b08d3255f5771e00f2eacb6b8051 DirectFB-0.9.20.ebuild 2971
MD5 b798773c0060701f402cec4cddc05f5d metadata.xml 754
-MD5 ba5b8492b20c817af4f669c914a4fe04 files/0.9.20-linux-2.6.patch 809
+MD5 4b82c1e7311a05e0f719aad63cd39d06 DirectFB-0.9.20-r1.ebuild 3156
MD5 938ad0cd729c90ede0f844b39cbeffa5 files/digest-DirectFB-0.9.20 68
+MD5 ba5b8492b20c817af4f669c914a4fe04 files/0.9.20-linux-2.6.patch 809
MD5 e9dedca8e82842a80fa7bd1507d5f1c6 files/DirectFB-0.9.20-64bit.diff 5060
MD5 cf391a4bf3d83146b5f6e5e93fdf779d files/DirectFB-0.9.20-simd-amd64.diff 6152
+MD5 938ad0cd729c90ede0f844b39cbeffa5 files/digest-DirectFB-0.9.20-r1 68
diff --git a/dev-libs/DirectFB/files/digest-DirectFB-0.9.20-r1 b/dev-libs/DirectFB/files/digest-DirectFB-0.9.20-r1
new file mode 100644
index 000000000000..439811397232
--- /dev/null
+++ b/dev-libs/DirectFB/files/digest-DirectFB-0.9.20-r1
@@ -0,0 +1 @@
+MD5 e42e8ae43f0ad873643f73cc0a9ae7d0 DirectFB-0.9.20.tar.gz 1307323