summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Alfredsen <loki_val@gentoo.org>2009-04-20 05:01:45 +0000
committerPeter Alfredsen <loki_val@gentoo.org>2009-04-20 05:01:45 +0000
commitceb5e2c48f0e3829a028acb881c9db927b010450 (patch)
tree15744fad23971e07df7521e24a69326d330b1762 /dev-lang
parents390 stable (diff)
downloadgentoo-2-ceb5e2c48f0e3829a028acb881c9db927b010450.tar.gz
gentoo-2-ceb5e2c48f0e3829a028acb881c9db927b010450.tar.bz2
gentoo-2-ceb5e2c48f0e3829a028acb881c9db927b010450.zip
Do not require kernel sources, warn if sources not found.
(Portage version: 2.2_rc28/cvs/Linux x86_64)
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/mono/ChangeLog6
-rw-r--r--dev-lang/mono/mono-2.0.1-r1.ebuild20
-rw-r--r--dev-lang/mono/mono-2.2-r5.ebuild21
-rw-r--r--dev-lang/mono/mono-2.4.ebuild20
4 files changed, 44 insertions, 23 deletions
diff --git a/dev-lang/mono/ChangeLog b/dev-lang/mono/ChangeLog
index 59b4a9fc27c7..b46e75fa4e1b 100644
--- a/dev-lang/mono/ChangeLog
+++ b/dev-lang/mono/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-lang/mono
# Copyright 2002-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/mono/ChangeLog,v 1.163 2009/04/17 01:29:22 loki_val Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/mono/ChangeLog,v 1.164 2009/04/20 05:01:45 loki_val Exp $
+
+ 20 Apr 2009; Peter Alfredsen <loki_val@gentoo.org> mono-2.0.1-r1,
+ mono-2.2-r5, mono-2.4:
+ Do not require kernel sources, warn if sources not found.
17 Apr 2009; Peter Alfredsen <loki_val@gentoo.org> mono-2.0.1-r1.ebuild,
mono-2.2-r5.ebuild, mono-2.4.ebuild:
diff --git a/dev-lang/mono/mono-2.0.1-r1.ebuild b/dev-lang/mono/mono-2.0.1-r1.ebuild
index f0b7367966cb..3ee60fec5151 100644
--- a/dev-lang/mono/mono-2.0.1-r1.ebuild
+++ b/dev-lang/mono/mono-2.0.1-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/mono/mono-2.0.1-r1.ebuild,v 1.5 2009/04/17 01:29:22 loki_val Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/mono/mono-2.0.1-r1.ebuild,v 1.6 2009/04/20 05:01:45 loki_val Exp $
EAPI=2
@@ -40,14 +40,20 @@ pkg_setup() {
if use kernel_linux
then
get_version
- require_configured_kernel
- if linux_chkconfig_present SYSVIPC
+ if linux_config_exists
then
- einfo "CONFIG_SYSVIPC is set, looking good."
+ if linux_chkconfig_present SYSVIPC
+ then
+ einfo "CONFIG_SYSVIPC is set, looking good."
+ else
+ eerror "If CONFIG_SYSVIPC is not set in your kernel .config, mono will hang while compiling."
+ eerror "See http://bugs.gentoo.org/261869 for more info."
+ die "Please set CONFIG_SYSVIPC in your kernel .config"
+ fi
else
- eerror "If CONFIG_SYSVIPC is not set in your kernel .config, mono will hang while compiling."
- eerror "See http://bugs.gentoo.org/261869 for more info."
- die "Please set CONFIG_SYSVIPC in your kernel .config"
+ ewarn "Was unable to determine your kernel .config"
+ ewarn "Please note that if CONFIG_SYSVIPC is not set in your kernel .config, mono will hang while compiling."
+ ewarn "See http://bugs.gentoo.org/261869 for more info."
fi
fi
}
diff --git a/dev-lang/mono/mono-2.2-r5.ebuild b/dev-lang/mono/mono-2.2-r5.ebuild
index eddda7dedf72..46606d25acc6 100644
--- a/dev-lang/mono/mono-2.2-r5.ebuild
+++ b/dev-lang/mono/mono-2.2-r5.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/mono/mono-2.2-r5.ebuild,v 1.3 2009/04/17 01:29:22 loki_val Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/mono/mono-2.2-r5.ebuild,v 1.4 2009/04/20 05:01:45 loki_val Exp $
EAPI=2
@@ -42,19 +42,24 @@ PATCHES=(
"${FILESDIR}/mono-2.2-r123987-bless-crash.patch"
"${FILESDIR}/mono-2.2-freebsd-elf_common.patch"
)
-
pkg_setup() {
if use kernel_linux
then
get_version
- require_configured_kernel
- if linux_chkconfig_present SYSVIPC
+ if linux_config_exists
then
- einfo "CONFIG_SYSVIPC is set, looking good."
+ if linux_chkconfig_present SYSVIPC
+ then
+ einfo "CONFIG_SYSVIPC is set, looking good."
+ else
+ eerror "If CONFIG_SYSVIPC is not set in your kernel .config, mono will hang while compiling."
+ eerror "See http://bugs.gentoo.org/261869 for more info."
+ die "Please set CONFIG_SYSVIPC in your kernel .config"
+ fi
else
- eerror "If CONFIG_SYSVIPC is not set in your kernel .config, mono will hang while compiling."
- eerror "See http://bugs.gentoo.org/261869 for more info."
- die "Please set CONFIG_SYSVIPC in your kernel .config"
+ ewarn "Was unable to determine your kernel .config"
+ ewarn "Please note that if CONFIG_SYSVIPC is not set in your kernel .config, mono will hang while compiling."
+ ewarn "See http://bugs.gentoo.org/261869 for more info."
fi
fi
}
diff --git a/dev-lang/mono/mono-2.4.ebuild b/dev-lang/mono/mono-2.4.ebuild
index 9956968a8bfb..739cfee53eb8 100644
--- a/dev-lang/mono/mono-2.4.ebuild
+++ b/dev-lang/mono/mono-2.4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/mono/mono-2.4.ebuild,v 1.4 2009/04/17 01:29:22 loki_val Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/mono/mono-2.4.ebuild,v 1.5 2009/04/20 05:01:45 loki_val Exp $
EAPI=2
@@ -45,14 +45,20 @@ pkg_setup() {
if use kernel_linux
then
get_version
- require_configured_kernel
- if linux_chkconfig_present SYSVIPC
+ if linux_config_exists
then
- einfo "CONFIG_SYSVIPC is set, looking good."
+ if linux_chkconfig_present SYSVIPC
+ then
+ einfo "CONFIG_SYSVIPC is set, looking good."
+ else
+ eerror "If CONFIG_SYSVIPC is not set in your kernel .config, mono will hang while compiling."
+ eerror "See http://bugs.gentoo.org/261869 for more info."
+ die "Please set CONFIG_SYSVIPC in your kernel .config"
+ fi
else
- eerror "If CONFIG_SYSVIPC is not set in your kernel .config, mono will hang while compiling."
- eerror "See http://bugs.gentoo.org/261869 for more info."
- die "Please set CONFIG_SYSVIPC in your kernel .config"
+ ewarn "Was unable to determine your kernel .config"
+ ewarn "Please note that if CONFIG_SYSVIPC is not set in your kernel .config, mono will hang while compiling."
+ ewarn "See http://bugs.gentoo.org/261869 for more info."
fi
fi
}