summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFabian Groffen <grobian@gentoo.org>2012-11-16 19:25:59 +0000
committerFabian Groffen <grobian@gentoo.org>2012-11-16 19:25:59 +0000
commitc8122f933eb5732a55968d65bc92b7d015400bc8 (patch)
tree6b8889ab684405ad97d84181b3f821574bfbce1e /dev-lang
parentVersion bump for the 3.2 series (diff)
downloadgentoo-2-c8122f933eb5732a55968d65bc92b7d015400bc8.tar.gz
gentoo-2-c8122f933eb5732a55968d65bc92b7d015400bc8.tar.bz2
gentoo-2-c8122f933eb5732a55968d65bc92b7d015400bc8.zip
Fix install_name reference of d8
(Portage version: 2.2.01.21313-prefix/cvs/Darwin i386, signed Manifest commit with key 0x5F75F607C5C74E89)
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/v8/ChangeLog6
-rw-r--r--dev-lang/v8/v8-3.14.5.1.ebuild4
-rw-r--r--dev-lang/v8/v8-3.15.1.2.ebuild4
-rw-r--r--dev-lang/v8/v8-9999.ebuild4
4 files changed, 11 insertions, 7 deletions
diff --git a/dev-lang/v8/ChangeLog b/dev-lang/v8/ChangeLog
index 0b3e21739251..cf3a4c437381 100644
--- a/dev-lang/v8/ChangeLog
+++ b/dev-lang/v8/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-lang/v8
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/v8/ChangeLog,v 1.256 2012/11/15 02:10:48 phajdan.jr Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/v8/ChangeLog,v 1.257 2012/11/16 19:25:59 grobian Exp $
+
+ 16 Nov 2012; Fabian Groffen <grobian@gentoo.org> v8-3.14.5.1.ebuild,
+ v8-3.15.1.2.ebuild, v8-9999.ebuild:
+ Fix install_name reference of d8
*v8-3.15.1.2 (15 Nov 2012)
diff --git a/dev-lang/v8/v8-3.14.5.1.ebuild b/dev-lang/v8/v8-3.14.5.1.ebuild
index ea651e27fe86..d205c1ab19cc 100644
--- a/dev-lang/v8/v8-3.14.5.1.ebuild
+++ b/dev-lang/v8/v8-3.14.5.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/v8/v8-3.14.5.1.ebuild,v 1.1 2012/11/15 01:24:20 floppym Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/v8/v8-3.14.5.1.ebuild,v 1.2 2012/11/16 19:25:59 grobian Exp $
EAPI="4"
@@ -95,7 +95,7 @@ src_install() {
|| die
install_name_tool \
-change \
- "${S}"/out/${mytarget}/libv8.so.${soname_version} \
+ /usr/local/lib/libv8.so.${soname_version} \
"${EPREFIX}"/usr/$(get_libdir)/libv8$(get_libname) \
out/${mytarget}/d8 || die
fi
diff --git a/dev-lang/v8/v8-3.15.1.2.ebuild b/dev-lang/v8/v8-3.15.1.2.ebuild
index 96105ad3a93a..bc13e8a27e05 100644
--- a/dev-lang/v8/v8-3.15.1.2.ebuild
+++ b/dev-lang/v8/v8-3.15.1.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/v8/v8-3.15.1.2.ebuild,v 1.1 2012/11/15 02:10:48 phajdan.jr Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/v8/v8-3.15.1.2.ebuild,v 1.2 2012/11/16 19:25:59 grobian Exp $
EAPI="4"
@@ -95,7 +95,7 @@ src_install() {
|| die
install_name_tool \
-change \
- "${S}"/out/${mytarget}/libv8.so.${soname_version} \
+ /usr/local/lib/libv8.so.${soname_version} \
"${EPREFIX}"/usr/$(get_libdir)/libv8$(get_libname) \
out/${mytarget}/d8 || die
fi
diff --git a/dev-lang/v8/v8-9999.ebuild b/dev-lang/v8/v8-9999.ebuild
index 3cc5fed100f2..f2b5fa175066 100644
--- a/dev-lang/v8/v8-9999.ebuild
+++ b/dev-lang/v8/v8-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/v8/v8-9999.ebuild,v 1.32 2012/08/29 17:13:26 phajdan.jr Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/v8/v8-9999.ebuild,v 1.33 2012/11/16 19:25:59 grobian Exp $
EAPI="4"
@@ -102,7 +102,7 @@ src_install() {
|| die
install_name_tool \
-change \
- "${S}"/out/${mytarget}/libv8.so.${soname_version} \
+ /usr/local/lib/libv8.so.${soname_version} \
"${EPREFIX}"/usr/$(get_libdir)/libv8$(get_libname) \
out/${mytarget}/d8 || die
fi