summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2015-05-13 03:08:22 +0000
committerPatrick Lauer <patrick@gentoo.org>2015-05-13 03:08:22 +0000
commit793faa288a4ab9895331fdb7816a30f239308129 (patch)
tree3905db1fcb28f74743600f4bdefc2285d23c42e3 /dev-lang
parentAdd live ebuild #549204 (diff)
downloadgentoo-2-793faa288a4ab9895331fdb7816a30f239308129.tar.gz
gentoo-2-793faa288a4ab9895331fdb7816a30f239308129.tar.bz2
gentoo-2-793faa288a4ab9895331fdb7816a30f239308129.zip
Add live ebuild #549204
(Portage version: 2.2.18/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/pcc/ChangeLog7
-rw-r--r--dev-lang/pcc/pcc-9999.ebuild45
2 files changed, 51 insertions, 1 deletions
diff --git a/dev-lang/pcc/ChangeLog b/dev-lang/pcc/ChangeLog
index 31ffbcaf961e..cba25e87f5d8 100644
--- a/dev-lang/pcc/ChangeLog
+++ b/dev-lang/pcc/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-lang/pcc
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/pcc/ChangeLog,v 1.14 2015/03/09 09:29:02 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/pcc/ChangeLog,v 1.15 2015/05/13 03:08:22 patrick Exp $
+
+*pcc-9999 (13 May 2015)
+
+ 13 May 2015; Patrick Lauer <patrick@gentoo.org> +pcc-9999.ebuild:
+ Add live ebuild #549204
09 Mar 2015; Patrick Lauer <patrick@gentoo.org> pcc-1.1.0-r1.ebuild:
Fix ebuild paths
diff --git a/dev-lang/pcc/pcc-9999.ebuild b/dev-lang/pcc/pcc-9999.ebuild
new file mode 100644
index 000000000000..572413b38007
--- /dev/null
+++ b/dev-lang/pcc/pcc-9999.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/pcc/pcc-9999.ebuild,v 1.1 2015/05/13 03:08:22 patrick Exp $
+
+EAPI=5
+
+inherit eutils versionator autotools
+
+DESCRIPTION="pcc portable c compiler"
+HOMEPAGE="http://pcc.ludd.ltu.se"
+
+if [[ ${PV} = 9999 ]]; then
+ inherit cvs
+ ECVS_SERVER="pcc.ludd.ltu.se:/cvsroot"
+ ECVS_MODULE="${PN}"
+ KEYWORDS=""
+ S="${WORKDIR}/${PN}"
+else
+ SRC_URI="ftp://pcc.ludd.ltu.se/pub/pcc-releases/${P}.tgz"
+ KEYWORDS="~x86 ~amd64 ~amd64-fbsd"
+fi
+
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+DEPEND=">=dev-libs/pcc-libs-${PV}"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ sed -i -e 's/AC_CHECK_PROG(strip,strip,yes,no)//' configure.ac || die "Failed to fix configure.ac"
+ sed -i -e 's/AC_SUBST(strip)//' configure.ac || die "Failed to fix configure.ac more"
+ eautoreconf
+}
+
+src_configure() {
+ econf --disable-stripping
+}
+
+src_compile() {
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+}