summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMikhail Pukhlikov <cynede@gentoo.org>2013-10-07 05:38:10 +0000
committerMikhail Pukhlikov <cynede@gentoo.org>2013-10-07 05:38:10 +0000
commit77409d653b200ee042160be3397cec06c3412469 (patch)
treeac116dd29c815af5f5a0e97a01d3e2ac69844eee /dev-lang
parentFix DESCRIPTION overwritten when migrated away from vim eclass. (diff)
downloadgentoo-2-77409d653b200ee042160be3397cec06c3412469.tar.gz
gentoo-2-77409d653b200ee042160be3397cec06c3412469.tar.bz2
gentoo-2-77409d653b200ee042160be3397cec06c3412469.zip
fsharp bump
(Portage version: 2.2.7_p2/cvs/Linux i686, unsigned Manifest commit)
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/fsharp/ChangeLog7
-rw-r--r--dev-lang/fsharp/fsharp-3.0.29.ebuild31
2 files changed, 37 insertions, 1 deletions
diff --git a/dev-lang/fsharp/ChangeLog b/dev-lang/fsharp/ChangeLog
index 75891b7fecaa..d3d4c5723f46 100644
--- a/dev-lang/fsharp/ChangeLog
+++ b/dev-lang/fsharp/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-lang/fsharp
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/fsharp/ChangeLog,v 1.3 2013/09/29 05:32:29 cynede Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/fsharp/ChangeLog,v 1.4 2013/10/07 05:38:10 cynede Exp $
+
+*fsharp-3.0.29 (07 Oct 2013)
+
+ 07 Oct 2013; Heather Cynede <cynede@gentoo.org> +fsharp-3.0.29.ebuild:
+ fsharp bump
*fsharp-3.0.28 (29 Sep 2013)
diff --git a/dev-lang/fsharp/fsharp-3.0.29.ebuild b/dev-lang/fsharp/fsharp-3.0.29.ebuild
new file mode 100644
index 000000000000..602e7ba8a7c7
--- /dev/null
+++ b/dev-lang/fsharp/fsharp-3.0.29.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/fsharp/fsharp-3.0.29.ebuild,v 1.1 2013/10/07 05:38:10 cynede Exp $
+
+EAPI="5"
+
+AUTOTOOLS_AUTORECONF=1
+
+inherit autotools-utils mono-env
+
+DESCRIPTION="The F# Compiler"
+HOMEPAGE="https://github.com/fsharp/fsharp"
+SRC_URI="https://github.com/fsharp/fsharp/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE=""
+
+MAKEOPTS+=" -j1" #nowarn
+DEPEND="dev-lang/mono"
+RDEPEND="${DEPEND}"
+
+AUTOTOOLS_IN_SOURCE_BUILD=1
+
+src_install() {
+ default
+
+ #for older software compatibility:
+ dosym fsharpc /usr/bin/fsc
+}