summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDanny van Dyk <kugelfang@gentoo.org>2006-06-02 19:31:37 +0000
committerDanny van Dyk <kugelfang@gentoo.org>2006-06-02 19:31:37 +0000
commit6aa060e23d4ff460f223faa5f4e36c178fbe4514 (patch)
tree5436cb7f51c09d763098be9e8d3a8818be10d8ef /dev-lang
parentx86 (diff)
downloadgentoo-2-6aa060e23d4ff460f223faa5f4e36c178fbe4514.tar.gz
gentoo-2-6aa060e23d4ff460f223faa5f4e36c178fbe4514.tar.bz2
gentoo-2-6aa060e23d4ff460f223faa5f4e36c178fbe4514.zip
Added R-2.3.1. Marked R-2.2.1 stable on amd64.
(Portage version: 2.1_pre10-r5)
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/R/ChangeLog8
-rw-r--r--dev-lang/R/R-2.2.1.ebuild4
-rw-r--r--dev-lang/R/R-2.3.1.ebuild110
-rw-r--r--dev-lang/R/files/digest-R-2.2.12
-rw-r--r--dev-lang/R/files/digest-R-2.3.13
5 files changed, 124 insertions, 3 deletions
diff --git a/dev-lang/R/ChangeLog b/dev-lang/R/ChangeLog
index 7349cfce7a21..4391278f6b37 100644
--- a/dev-lang/R/ChangeLog
+++ b/dev-lang/R/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-lang/R
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/R/ChangeLog,v 1.69 2006/05/10 21:48:37 kugelfang Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/R/ChangeLog,v 1.70 2006/06/02 19:31:37 kugelfang Exp $
+
+*R-2.3.1 (02 Jun 2006)
+
+ 02 Jun 2006; Danny van Dyk <kugelfang@gentoo.org> R-2.2.1.ebuild,
+ +R-2.3.1.ebuild:
+ Added R-2.3.1. Marked R-2.2.1 stable on amd64.
*R-2.3.0 (10 May 2006)
diff --git a/dev-lang/R/R-2.2.1.ebuild b/dev-lang/R/R-2.2.1.ebuild
index d2b4948711d7..f4f4684a08ea 100644
--- a/dev-lang/R/R-2.2.1.ebuild
+++ b/dev-lang/R/R-2.2.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/R/R-2.2.1.ebuild,v 1.6 2006/05/10 21:48:37 kugelfang Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/R/R-2.2.1.ebuild,v 1.7 2006/06/02 19:31:37 kugelfang Exp $
inherit fortran toolchain-funcs
@@ -10,7 +10,7 @@ SRC_URI="mirror://cran/src/base/R-2/${P}.tar.gz"
LICENSE="GPL-2 LGPL-2.1"
SLOT="0"
-KEYWORDS="~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+KEYWORDS="amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
IUSE="blas jpeg nls png readline tcltk X lapack"
RDEPEND=">=dev-lang/perl-5.6.1-r3
diff --git a/dev-lang/R/R-2.3.1.ebuild b/dev-lang/R/R-2.3.1.ebuild
new file mode 100644
index 000000000000..cf7fc0cae27e
--- /dev/null
+++ b/dev-lang/R/R-2.3.1.ebuild
@@ -0,0 +1,110 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/R/R-2.3.1.ebuild,v 1.1 2006/06/02 19:31:37 kugelfang Exp $
+
+inherit fortran toolchain-funcs
+
+DESCRIPTION="R is GNU S - A language and environment for statistical computing and graphics."
+HOMEPAGE="http://www.r-project.org/"
+SRC_URI="mirror://cran/src/base/R-2/${P}.tar.gz"
+
+LICENSE="GPL-2 LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="blas jpeg nls png readline tcltk X lapack"
+
+RDEPEND=">=dev-lang/perl-5.6.1-r3
+ readline? ( >=sys-libs/readline-4.1-r3 )
+ jpeg? ( >=media-libs/jpeg-6b-r2 )
+ png? ( >=media-libs/libpng-1.2.1 )
+ blas? ( virtual/blas )
+ lapack? ( virtual/lapack )
+ tcltk? ( dev-lang/tk )
+ X? ( || ( ( x11-libs/libX11 )
+ virtual/x11 ) )"
+DEPEND="${RDEPEND}
+ X? ( || ( ( x11-proto/xproto
+ x11-libs/libXt
+ x11-libs/libX11 )
+ virtual/x11 ) )"
+
+AT_M4DIR="${S}/m4"
+
+pkg_setup() {
+ # Test for a 64 bit architecture - f2c won't work on 64 bit archs with R.
+ # Thanks to vapier for providing the test.
+ cd "${T}"
+ echo 'int main(){}' > test.c
+ $(tc-getCC) -c test.c -o test.o
+ if file test.o | grep -qs 64-bit ; then
+ einfo "64 bit architecture detected, using g77 or gfortran."
+ FORTRAN="gfortran g77 ifc"
+ else
+ FORTRAN="gfortran g77 f2c"
+ fi
+ rm -f test.{c,o}
+ fortran_pkg_setup
+
+ filter-ldflags -Wl,-Bdirect -Bdirect
+}
+
+src_compile() {
+ local myconf="--enable-R-profiling --enable-R-shlib --enable-linux-lfs"
+
+ if use tcltk; then
+ #configure needs to find the files tclConfig.sh and tkConfig.sh
+ myconf="${myconf} --with-tcltk --with-tcl-config=/usr/lib/tclConfig.sh
+ --with-tk-config=/usr/lib/tkConfig.sh"
+ else
+ myconf="${myconf} --without-tcltk"
+ fi
+
+ econf \
+ $(use_enable nls) \
+ $(use_with blas) \
+ $(use_with lapack) \
+ $(use_with jpeg jpeglib) \
+ $(use_with png libpng) \
+ $(use_with readline) \
+ $(use_with X x) \
+ ${myconf} || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ make \
+ prefix=${D}/usr \
+ mandir=${D}/usr/share/man \
+ infodir=${D}/usr/share/info \
+ rhome=${D}/usr/$(get_libdir)/R \
+ install || die "Installation Failed"
+
+ # fix the R wrapper script to have the correct R_HOME_DIR
+ # sed regexp borrowed from included debian rules
+ sed \
+ -e "/^R_HOME_DIR=.*/s::R_HOME_DIR=/usr/$(get_libdir)/R:" \
+ -i ${D}/usr/$(get_libdir)/R/bin/R \
+ || die "sed failed."
+
+ # The same kinds of seds are needed for these variables too, see bug 115140
+ sed \
+ -e "/^R_SHARE_DIR=.*/s::R_SHARE_DIR=/usr/$(get_libdir)/R/share:" \
+ -e "/^R_INCLUDE_DIR=.*/s::R_INCLUDE_DIR=/usr/$(get_libdir)/R/include:" \
+ -e "/^R_DOC_DIR=.*/s::R_DOC_DIR=/usr/$(get_libdir)/R/doc:" \
+ -i ${D}/usr/$(get_libdir)/R/bin/R \
+ || die "sed failed."
+
+ # R installs two identical wrappers under /usr/bin and /usr/lib/R/bin/
+ # the 2nd one is corrected by above sed, the first is replaced by a symlink
+ cd ${D}/usr/bin/
+ rm R
+ dosym ../$(get_libdir)/R/bin/R /usr/bin/R
+ dodir /etc/env.d
+ echo -n \
+ "LDPATH=\"/usr/$(get_libdir)/R/lib\"" \
+ > ${D}/etc/env.d/99R
+ cd ${S}
+
+ dodoc AUTHORS BUGS COPYING* ChangeLog FAQ *NEWS README \
+ RESOURCES THANKS VERSION Y2K
+}
diff --git a/dev-lang/R/files/digest-R-2.2.1 b/dev-lang/R/files/digest-R-2.2.1
index c263b9191c20..3a6a2f9464ce 100644
--- a/dev-lang/R/files/digest-R-2.2.1
+++ b/dev-lang/R/files/digest-R-2.2.1
@@ -1 +1,3 @@
MD5 42542290c6d1585af7ded330f811385c R-2.2.1.tar.gz 13665367
+RMD160 b63b6c5ef1db27a879783460b0ecb6de0d4bba18 R-2.2.1.tar.gz 13665367
+SHA256 db442c769e5e8ecbdb33c771e41bdac4330b565652c5ca730f26f975df30c624 R-2.2.1.tar.gz 13665367
diff --git a/dev-lang/R/files/digest-R-2.3.1 b/dev-lang/R/files/digest-R-2.3.1
new file mode 100644
index 000000000000..08291fafeca4
--- /dev/null
+++ b/dev-lang/R/files/digest-R-2.3.1
@@ -0,0 +1,3 @@
+MD5 a1d6d8081af4c71006a6e5a3ed54e4da R-2.3.1.tar.gz 14285120
+RMD160 061a77f25d3b1144aecdce479aa707e7bea21a82 R-2.3.1.tar.gz 14285120
+SHA256 1952bcf0d169cfe98aef33015a988f85eda72bf0223cd5833669e197fea2e427 R-2.3.1.tar.gz 14285120