summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2007-11-15 12:06:24 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2007-11-15 12:06:24 +0000
commit64085594521af04e7f547e48e381ef83451bcad7 (patch)
tree6e4ae659d649c8686842d4413bc1e3694e33b0d3 /dev-lang
parentVersion bumps (diff)
downloadgentoo-2-64085594521af04e7f547e48e381ef83451bcad7.tar.gz
gentoo-2-64085594521af04e7f547e48e381ef83451bcad7.tar.bz2
gentoo-2-64085594521af04e7f547e48e381ef83451bcad7.zip
Security fix with pcre (bug #198385), now use system libs.
(Portage version: 2.1.3.19, RepoMan options: --force)
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/R/ChangeLog11
-rw-r--r--dev-lang/R/R-2.2.1-r1.ebuild114
-rw-r--r--dev-lang/R/R-2.6.0-r1.ebuild (renamed from dev-lang/R/R-2.5.1.ebuild)29
-rw-r--r--dev-lang/R/files/R-logo.pngbin4867 -> 0 bytes
-rw-r--r--dev-lang/R/files/R.desktop17
-rw-r--r--dev-lang/R/files/digest-R-2.2.1-r13
-rw-r--r--dev-lang/R/files/digest-R-2.5.13
-rw-r--r--dev-lang/R/files/digest-R-2.6.0-r13
-rw-r--r--dev-lang/R/metadata.xml19
9 files changed, 166 insertions, 33 deletions
diff --git a/dev-lang/R/ChangeLog b/dev-lang/R/ChangeLog
index 027ce192ed86..2ed2ac84be73 100644
--- a/dev-lang/R/ChangeLog
+++ b/dev-lang/R/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for dev-lang/R
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/R/ChangeLog,v 1.90 2007/10/06 14:21:27 markusle Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/R/ChangeLog,v 1.91 2007/11/15 12:06:24 bicatali Exp $
+
+*R-2.6.0-r1 (15 Nov 2007)
+*R-2.2.1-r1 (15 Nov 2007)
+
+ 15 Nov 2007; Sébastien Fabbro <bicatali@gentoo.org> -files/R.desktop,
+ -files/R-logo.png, metadata.xml, +R-2.2.1-r1.ebuild, -R-2.5.1.ebuild,
+ +R-2.6.0-r1.ebuild:
+ Security fix with pcre (bug #198385), now use system libs. New ebuild on
+ soon to be commited.
*R-2.6.0 (06 Oct 2007)
diff --git a/dev-lang/R/R-2.2.1-r1.ebuild b/dev-lang/R/R-2.2.1-r1.ebuild
new file mode 100644
index 000000000000..bdbf698de344
--- /dev/null
+++ b/dev-lang/R/R-2.2.1-r1.ebuild
@@ -0,0 +1,114 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/R/R-2.2.1-r1.ebuild,v 1.1 2007/11/15 12:06:24 bicatali Exp $
+
+inherit fortran toolchain-funcs flag-o-matic
+
+DESCRIPTION="R is GNU S - A language and environment for statistical computing and graphics."
+HOMEPAGE="http://www.r-project.org/"
+SRC_URI="mirror://cran/src/base/R-2/${P}.tar.gz"
+
+LICENSE="GPL-2 LGPL-2.1"
+SLOT="0"
+KEYWORDS="amd64 ia64 ppc ppc64 sparc x86"
+IUSE="blas jpeg nls png readline tk X lapack"
+
+RDEPEND=">=dev-lang/perl-5.6.1-r3
+ >=dev-libs/libpcre-7.3
+ app-arch/bzip2
+ readline? ( >=sys-libs/readline-4.1-r3 )
+ jpeg? ( >=media-libs/jpeg-6b-r2 )
+ png? ( >=media-libs/libpng-1.2.1 )
+ blas? ( virtual/blas )
+ lapack? ( virtual/lapack )
+ tk? ( dev-lang/tk
+ dev-lang/tcl )
+ X? ( x11-libs/libX11 )"
+DEPEND="${RDEPEND}
+ X? ( x11-proto/xproto
+ x11-libs/libXt
+ x11-libs/libX11 )"
+
+AT_M4DIR="${S}/m4"
+
+pkg_setup() {
+ # Test for a 64 bit architecture - f2c won't work on 64 bit archs with R.
+ # Thanks to vapier for providing the test.
+ cd "${T}"
+ echo 'int main(){}' > test.c
+ $(tc-getCC) -c test.c -o test.o
+ if file test.o | grep -qs 64-bit ; then
+ einfo "64 bit architecture detected, using g77 or gfortran."
+ FORTRAN="gfortran g77 ifc"
+ else
+ FORTRAN="gfortran g77 f2c"
+ fi
+ rm -f test.{c,o}
+ fortran_pkg_setup
+
+ filter-ldflags -Wl,-Bdirect -Bdirect
+}
+
+src_compile() {
+ local myconf="--enable-R-profiling --enable-R-shlib --enable-linux-lfs"
+
+ if use tk; then
+ #configure needs to find the files tclConfig.sh and tkConfig.sh
+ myconf="${myconf} --with-tcltk --with-tcl-config=/usr/lib/tclConfig.sh
+ --with-tk-config=/usr/lib/tkConfig.sh"
+ else
+ myconf="${myconf} --without-tcltk"
+ fi
+
+ econf \
+ --with-system-zlib \
+ --with-system-bzlib \
+ --with-system-pcre \
+ $(use_enable nls) \
+ $(use_with blas) \
+ $(use_with lapack) \
+ $(use_with jpeg jpeglib) \
+ $(use_with png libpng) \
+ $(use_with readline) \
+ $(use_with X x) \
+ ${myconf} || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ make \
+ prefix="${D}"/usr \
+ mandir="${D}"/usr/share/man \
+ infodir="${D}"/usr/share/info \
+ rhome="${D}"/usr/$(get_libdir)/R \
+ install || die "Installation Failed"
+
+ # fix the R wrapper script to have the correct R_HOME_DIR
+ # sed regexp borrowed from included debian rules
+ sed \
+ -e "/^R_HOME_DIR=.*/s::R_HOME_DIR=/usr/$(get_libdir)/R:" \
+ -i "${D}"/usr/$(get_libdir)/R/bin/R \
+ || die "sed failed."
+
+ # The same kinds of seds are needed for these variables too, see bug 115140
+ sed \
+ -e "/^R_SHARE_DIR=.*/s::R_SHARE_DIR=/usr/$(get_libdir)/R/share:" \
+ -e "/^R_INCLUDE_DIR=.*/s::R_INCLUDE_DIR=/usr/$(get_libdir)/R/include:" \
+ -e "/^R_DOC_DIR=.*/s::R_DOC_DIR=/usr/$(get_libdir)/R/doc:" \
+ -i "${D}"/usr/$(get_libdir)/R/bin/R \
+ || die "sed failed."
+
+ # R installs two identical wrappers under /usr/bin and /usr/lib/R/bin/
+ # the 2nd one is corrected by above sed, the first is replaced by a symlink
+ cd "${D}"/usr/bin/
+ rm R
+ dosym ../$(get_libdir)/R/bin/R /usr/bin/R
+ dodir /etc/env.d
+ echo -n \
+ "LDPATH=\"/usr/$(get_libdir)/R/lib\"" \
+ > "${D}"/etc/env.d/99R
+ cd "${S}"
+
+ dodoc AUTHORS BUGS COPYING* ChangeLog FAQ *NEWS README \
+ RESOURCES THANKS VERSION Y2K
+}
diff --git a/dev-lang/R/R-2.5.1.ebuild b/dev-lang/R/R-2.6.0-r1.ebuild
index db78d9d5a00b..d6f653a67fa1 100644
--- a/dev-lang/R/R-2.5.1.ebuild
+++ b/dev-lang/R/R-2.6.0-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/R/R-2.5.1.ebuild,v 1.4 2007/09/11 12:52:59 markusle Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/R/R-2.6.0-r1.ebuild,v 1.1 2007/11/15 12:06:24 bicatali Exp $
inherit fortran toolchain-funcs flag-o-matic
@@ -14,6 +14,8 @@ KEYWORDS="~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
IUSE="blas jpeg nls png readline tk X lapack gd"
RDEPEND=">=dev-lang/perl-5.6.1-r3
+ >=dev-libs/libpcre-7.3
+ app-arch/bzip2
readline? ( >=sys-libs/readline-4.1-r3 )
jpeg? ( >=media-libs/jpeg-6b-r2 )
png? ( >=media-libs/libpng-1.2.1 )
@@ -69,6 +71,9 @@ src_compile() {
fi
econf \
+ --with-system-zlib \
+ --with-system-bzlib \
+ --with-system-pcre \
$(use_enable nls) \
$(use_with blas) \
$(use_with lapack) \
@@ -83,18 +88,18 @@ src_compile() {
src_install() {
make \
- prefix=${D}/usr \
- mandir=${D}/usr/share/man \
- infodir=${D}/usr/share/info \
- libdir=${D}/usr/$(get_libdir) \
- rhome=${D}/usr/$(get_libdir)/R \
+ prefix="${D}"/usr \
+ mandir="${D}"/usr/share/man \
+ infodir="${D}"/usr/share/info \
+ libdir="${D}"/usr/$(get_libdir) \
+ rhome="${D}"/usr/$(get_libdir)/R \
install || die "Installation Failed"
# fix the R wrapper script to have the correct R_HOME_DIR
# sed regexp borrowed from included debian rules
sed \
-e "/^R_HOME_DIR=.*/s::R_HOME_DIR=/usr/$(get_libdir)/R:" \
- -i ${D}/usr/$(get_libdir)/R/bin/R \
+ -i "${D}"/usr/$(get_libdir)/R/bin/R \
|| die "sed failed."
# The same kinds of seds are needed for these variables too, see bug 115140
@@ -102,23 +107,23 @@ src_install() {
-e "/^R_SHARE_DIR=.*/s::R_SHARE_DIR=/usr/$(get_libdir)/R/share:" \
-e "/^R_INCLUDE_DIR=.*/s::R_INCLUDE_DIR=/usr/$(get_libdir)/R/include:" \
-e "/^R_DOC_DIR=.*/s::R_DOC_DIR=/usr/$(get_libdir)/R/doc:" \
- -i ${D}/usr/$(get_libdir)/R/bin/R \
+ -i "${D}"/usr/$(get_libdir)/R/bin/R \
|| die "sed failed."
# fix paths in libR.pc pkgconfig file
- sed -e "s:${D}::" -i ${D}/usr/$(get_libdir)/pkgconfig/libR.pc \
+ sed -e "s:${D}::" -i "${D}"/usr/$(get_libdir)/pkgconfig/libR.pc \
|| die "Failed to fix libR.pc file"
# R installs two identical wrappers under /usr/bin and /usr/lib/R/bin/
# the 2nd one is corrected by above sed, the first is replaced by a symlink
- cd ${D}/usr/bin/
+ cd "${D}"/usr/bin/
rm R
dosym ../$(get_libdir)/R/bin/R /usr/bin/R
dodir /etc/env.d
echo -n \
"LDPATH=\"/usr/$(get_libdir)/R/lib\"" \
- > ${D}/etc/env.d/99R
- cd ${S}
+ > "${D}"/etc/env.d/99R
+ cd "${S}"
dodoc ChangeLog *NEWS README VERSION
}
diff --git a/dev-lang/R/files/R-logo.png b/dev-lang/R/files/R-logo.png
deleted file mode 100644
index d9ce5e227202..000000000000
--- a/dev-lang/R/files/R-logo.png
+++ /dev/null
Binary files differ
diff --git a/dev-lang/R/files/R.desktop b/dev-lang/R/files/R.desktop
deleted file mode 100644
index ef53caf006d9..000000000000
--- a/dev-lang/R/files/R.desktop
+++ /dev/null
@@ -1,17 +0,0 @@
-[Desktop Entry]
-Name=R
-Name[pt_BR]=R
-Name[da]=R
-Nama[ja]=R
-Name[no]=R
-Name[uk]=R
-Comment=Statistical computing and graphics
-Comment[pt_BR]=Statistical computing and graphics
-Comment[da]=Statistical computing and graphics
-Comment[ja]=Statistical computing and graphics
-Comment[no]=Statistical computing and graphics
-Comment[uk]=Statistical computing and graphics
-Exec=R --gui=gnome
-Icon=R-logo.png
-Terminal=1
-Type=Application
diff --git a/dev-lang/R/files/digest-R-2.2.1-r1 b/dev-lang/R/files/digest-R-2.2.1-r1
new file mode 100644
index 000000000000..3a6a2f9464ce
--- /dev/null
+++ b/dev-lang/R/files/digest-R-2.2.1-r1
@@ -0,0 +1,3 @@
+MD5 42542290c6d1585af7ded330f811385c R-2.2.1.tar.gz 13665367
+RMD160 b63b6c5ef1db27a879783460b0ecb6de0d4bba18 R-2.2.1.tar.gz 13665367
+SHA256 db442c769e5e8ecbdb33c771e41bdac4330b565652c5ca730f26f975df30c624 R-2.2.1.tar.gz 13665367
diff --git a/dev-lang/R/files/digest-R-2.5.1 b/dev-lang/R/files/digest-R-2.5.1
deleted file mode 100644
index 5adf0a12d786..000000000000
--- a/dev-lang/R/files/digest-R-2.5.1
+++ /dev/null
@@ -1,3 +0,0 @@
-MD5 162f6d5a1bd7c60fd652145e050f3f3c R-2.5.1.tar.gz 15224643
-RMD160 0f5ed986c783c0d9baa2310b08278db1b8720f88 R-2.5.1.tar.gz 15224643
-SHA256 8d915327b37f38e742c247bbe6a653417eabf3dadc5880f3a81507924a1df682 R-2.5.1.tar.gz 15224643
diff --git a/dev-lang/R/files/digest-R-2.6.0-r1 b/dev-lang/R/files/digest-R-2.6.0-r1
new file mode 100644
index 000000000000..e5de22d6bc74
--- /dev/null
+++ b/dev-lang/R/files/digest-R-2.6.0-r1
@@ -0,0 +1,3 @@
+MD5 97e5d2542349925962b7469456d45731 R-2.6.0.tar.gz 15447985
+RMD160 54b3d183dfb15af7f861e7b62904998865ad194c R-2.6.0.tar.gz 15447985
+SHA256 8a916e653affa83584119dc08a8b12e30e430dee19a398513515003c43d791da R-2.6.0.tar.gz 15447985
diff --git a/dev-lang/R/metadata.xml b/dev-lang/R/metadata.xml
index b229aec85b8f..f33857fc542b 100644
--- a/dev-lang/R/metadata.xml
+++ b/dev-lang/R/metadata.xml
@@ -2,4 +2,23 @@
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<herd>sci</herd>
+<longdescription lang="en">
+R is a system for statistical computation and graphics. It consists of
+a language plus a run-time environment with graphics, a debugger,
+access to certain system functions, and the ability to run programs
+stored in script files.
+
+The core of R is an interpreted computer language which allows
+branching and looping as well as modular programming using functions.
+Most of the user-visible functions in R are written in R. It is
+possible for the user to interface to procedures written in the C,
+C++, or FORTRAN languages for efficiency. The R distribution contains
+functionality for a large number of statistical procedures. Among
+these are: linear and generalized linear models, nonlinear regression
+models, time series analysis, classical parametric and nonparametric
+tests, clustering and smoothing. There is also a large set of
+functions which provide a flexible graphical environment for creating
+various kinds of data presentations. Additional modules ("add-on
+packages") are available for a variety of specific purposes.
+</longdescription>
</pkgmetadata>