summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJauhien Piatlicki <jauhien@gentoo.org>2015-02-10 11:54:53 +0000
committerJauhien Piatlicki <jauhien@gentoo.org>2015-02-10 11:54:53 +0000
commit60b37d365ef272016ecd2387febbe51e4d9735a8 (patch)
tree3ec870ed3e5ff29e518445c6b104543e1a7721ec /dev-lang
parentwww-servers/tomcat: version bump (diff)
downloadgentoo-2-60b37d365ef272016ecd2387febbe51e4d9735a8.tar.gz
gentoo-2-60b37d365ef272016ecd2387febbe51e4d9735a8.tar.bz2
gentoo-2-60b37d365ef272016ecd2387febbe51e4d9735a8.zip
version bump, move live ebuild to rust overlay
(Portage version: 2.2.15/cvs/Linux x86_64, signed Manifest commit with key 0xB2EFA1D4)
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/rust-bin/ChangeLog11
-rw-r--r--dev-lang/rust-bin/files/rust-bin-0.12.0-no-ldconfig.patch23
-rw-r--r--dev-lang/rust-bin/rust-bin-0.12.0.ebuild77
-rw-r--r--dev-lang/rust-bin/rust-bin-1.0.0_alpha.ebuild (renamed from dev-lang/rust-bin/rust-bin-999.ebuild)60
4 files changed, 39 insertions, 132 deletions
diff --git a/dev-lang/rust-bin/ChangeLog b/dev-lang/rust-bin/ChangeLog
index 01f45657d733..a818461a74f5 100644
--- a/dev-lang/rust-bin/ChangeLog
+++ b/dev-lang/rust-bin/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-lang/rust-bin
-# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/rust-bin/ChangeLog,v 1.1 2014/10/18 12:50:48 jauhien Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/rust-bin/ChangeLog,v 1.2 2015/02/10 11:54:53 jauhien Exp $
+
+*rust-bin-1.0.0_alpha (10 Feb 2015)
+
+ 10 Feb 2015; Jauhien Piatlicki <jauhien@gentoo.org>
+ +rust-bin-1.0.0_alpha.ebuild, -files/rust-bin-0.12.0-no-ldconfig.patch,
+ -rust-bin-0.12.0.ebuild, -rust-bin-999.ebuild:
+ version bump, move live ebuild to rust overlay
*rust-bin-999 (18 Oct 2014)
*rust-bin-0.12.0 (18 Oct 2014)
diff --git a/dev-lang/rust-bin/files/rust-bin-0.12.0-no-ldconfig.patch b/dev-lang/rust-bin/files/rust-bin-0.12.0-no-ldconfig.patch
deleted file mode 100644
index d4c5fd8d1be8..000000000000
--- a/dev-lang/rust-bin/files/rust-bin-0.12.0-no-ldconfig.patch
+++ /dev/null
@@ -1,23 +0,0 @@
-Remove ldconfig(1) execution to prevent the installation script from accessing
-outside of a sandbox.
-
---- install.sh
-+++ install.sh
-@@ -466,17 +466,6 @@ while read p; do
- # The manifest lists all files to install
- done < "${CFG_SRC_DIR}/${CFG_LIBDIR_RELATIVE}/rustlib/manifest.in"
-
--# Run ldconfig to make dynamic libraries available to the linker
--if [ "$CFG_OSTYPE" = "Linux" ]
-- then
-- ldconfig
-- if [ $? -ne 0 ]
-- then
-- warn "failed to run ldconfig."
-- warn "this may happen when not installing as root and may be fine"
-- fi
--fi
--
- # Sanity check: can we run the installed binaries?
- #
- # As with the verification above, make sure the right LD_LIBRARY_PATH-equivalent
diff --git a/dev-lang/rust-bin/rust-bin-0.12.0.ebuild b/dev-lang/rust-bin/rust-bin-0.12.0.ebuild
deleted file mode 100644
index 531dd377f703..000000000000
--- a/dev-lang/rust-bin/rust-bin-0.12.0.ebuild
+++ /dev/null
@@ -1,77 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/rust-bin/rust-bin-0.12.0.ebuild,v 1.1 2014/10/18 12:50:48 jauhien Exp $
-
-EAPI="5"
-
-inherit eutils
-
-DESCRIPTION="Systems programming language from Mozilla"
-HOMEPAGE="http://www.rust-lang.org/"
-SRC_URI="amd64? ( http://static.rust-lang.org/dist/rust-${PV}-x86_64-unknown-linux-gnu.tar.gz )
- x86? ( http://static.rust-lang.org/dist/rust-${PV}-i686-unknown-linux-gnu.tar.gz )"
-
-LICENSE="|| ( MIT Apache-2.0 ) BSD-1 BSD-2 BSD-4 UoI-NCSA"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-
-IUSE="emacs vim-syntax zsh-completion"
-
-DEPEND=">=app-admin/eselect-rust-0.2_pre20141011
- !dev-lang/rust:0
-"
-RDEPEND="${DEPEND}
- emacs? ( >=app-emacs/rust-mode-${PV} )
- vim-syntax? ( >=app-vim/rust-mode-${PV} )
- zsh-completion? ( >=app-shells/rust-zshcomp-${PV} )
-"
-
-src_unpack() {
- default
-
- local postfix
- use amd64 && postfix=x86_64-unknown-linux-gnu
- use x86 && postfix=i686-unknown-linux-gnu
- mv "${WORKDIR}/rust-${PV}-${postfix}" "${S}" || die
-}
-
-src_prepare() {
- epatch "${FILESDIR}/${PN}-0.12.0-no-ldconfig.patch"
-}
-
-src_install() {
- ./install.sh \
- --disable-verify \
- --prefix="${D}/opt/${P}" \
- --mandir="${D}/usr/share/${P}/man"
-
- local rustc=rustc-bin-${PV}
- local rustdoc=rustdoc-bin-${PV}
-
- mv "${D}/opt/${P}/bin/rustc" "${D}/opt/${P}/bin/${rustc}" || die
- mv "${D}/opt/${P}/bin/rustdoc" "${D}/opt/${P}/bin/${rustdoc}" || die
- dosym "/opt/${P}/bin/${rustc}" "/usr/bin/${rustc}"
- dosym "/opt/${P}/bin/${rustdoc}" "/usr/bin/${rustdoc}"
-
- cat <<-EOF > "${T}"/50${P}
- LDPATH="/opt/${P}/lib"
- MANPATH="/usr/share/${P}/man"
- EOF
- doenvd "${T}"/50${P}
-
- dodir /etc/env.d/rust
- touch "${D}/etc/env.d/rust/provider-${P}" || die
-}
-
-pkg_postinst() {
- eselect rust update --if-unset
-
- elog "Rust uses slots now, use 'eselect rust list'"
- elog "and 'eselect rust set' to list and set rust version."
- elog "For more information see 'eselect rust help'"
- elog "and http://wiki.gentoo.org/wiki/Project:Eselect/User_guide"
-}
-
-pkg_postrm() {
- eselect rust unset --if-invalid
-}
diff --git a/dev-lang/rust-bin/rust-bin-999.ebuild b/dev-lang/rust-bin/rust-bin-1.0.0_alpha.ebuild
index 579915984026..427dd9c2a5a1 100644
--- a/dev-lang/rust-bin/rust-bin-999.ebuild
+++ b/dev-lang/rust-bin/rust-bin-1.0.0_alpha.ebuild
@@ -1,65 +1,55 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/rust-bin/rust-bin-999.ebuild,v 1.2 2014/11/30 12:46:22 jauhien Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/rust-bin/rust-bin-1.0.0_alpha.ebuild,v 1.1 2015/02/10 11:54:53 jauhien Exp $
EAPI="5"
inherit eutils
+MY_PV="1.0.0-alpha"
DESCRIPTION="Systems programming language from Mozilla"
HOMEPAGE="http://www.rust-lang.org/"
-MY_SRC_URI="http://static.rust-lang.org/dist/rust-nightly"
+SRC_URI="amd64? ( http://static.rust-lang.org/dist/rust-${MY_PV}-x86_64-unknown-linux-gnu.tar.gz )
+ x86? ( http://static.rust-lang.org/dist/rust-${MY_PV}-i686-unknown-linux-gnu.tar.gz )"
LICENSE="|| ( MIT Apache-2.0 ) BSD-1 BSD-2 BSD-4 UoI-NCSA"
SLOT="0"
-KEYWORDS=""
+KEYWORDS="~amd64 ~x86"
IUSE="emacs vim-syntax zsh-completion"
-CDEPEND=">=app-admin/eselect-rust-0.2_pre20141128
+DEPEND=">=app-admin/eselect-rust-0.2_pre20150206
!dev-lang/rust:0
"
-DEPEND="${CDEPEND}
- net-misc/wget
-"
-RDEPEND="${CDEPEND}
- emacs? ( >=app-emacs/rust-mode-${PV} )
- vim-syntax? ( >=app-vim/rust-mode-${PV} )
- zsh-completion? ( >=app-shells/rust-zshcomp-${PV} )
-"
+RDEPEND="${DEPEND}"
src_unpack() {
+ default
+
local postfix
use amd64 && postfix=x86_64-unknown-linux-gnu
use x86 && postfix=i686-unknown-linux-gnu
-
- wget "${MY_SRC_URI}-${postfix}.tar.gz" || die
- unpack ./"rust-nightly-${postfix}.tar.gz"
-
- mv "${WORKDIR}/rust-nightly-${postfix}" "${S}" || die
-}
-
-src_prepare() {
- epatch "${FILESDIR}/${PN}-0.12.0-no-ldconfig.patch"
+ mv "${WORKDIR}/rust-${MY_PV}-${postfix}" "${S}" || die
}
src_install() {
./install.sh \
--disable-verify \
--prefix="${D}/opt/${P}" \
- --mandir="${D}/usr/share/${P}/man"
+ --mandir="${D}/usr/share/${P}/man" \
+ --disable-ldconfig
local rustc=rustc-bin-${PV}
local rustdoc=rustdoc-bin-${PV}
- local rustlldb=rust-lldb-bin-${PV}
+ local rustgdb=rust-gdb-bin-${PV}
mv "${D}/opt/${P}/bin/rustc" "${D}/opt/${P}/bin/${rustc}" || die
mv "${D}/opt/${P}/bin/rustdoc" "${D}/opt/${P}/bin/${rustdoc}" || die
- mv "${D}/opt/${P}/bin/rust-lldb" "${D}/opt/${P}/bin/${rustlldb}" || die
+ mv "${D}/opt/${P}/bin/rust-gdb" "${D}/opt/${P}/bin/${rustgdb}" || die
dosym "/opt/${P}/bin/${rustc}" "/usr/bin/${rustc}"
dosym "/opt/${P}/bin/${rustdoc}" "/usr/bin/${rustdoc}"
- dosym "/opt/${P}/bin/${rustlldb}" "/usr/bin/${rustlldb}"
+ dosym "/opt/${P}/bin/${rustgdb}" "/usr/bin/${rustgdb}"
cat <<-EOF > "${T}"/50${P}
LDPATH="/opt/${P}/lib"
@@ -79,10 +69,20 @@ pkg_postinst() {
elog "For more information see 'eselect rust help'"
elog "and http://wiki.gentoo.org/wiki/Project:Eselect/User_guide"
- elog "Rust installs a helper script for calling LLDB now,"
- elog "for your convenience it is installed under /usr/bin/rust-lldb-bin-${PV},"
- elog "but note, that there is no LLDB ebuild in the tree currently,"
- elog "so you are on your own if you want to use it."
+ elog "Rust installs a helper script for calling GDB now,"
+ elog "for your convenience it is installed under /usr/bin/rust-gdb-bin-${PV},"
+
+ if has_version app-editors/emacs || has_version app-editors/emacs-vcs; then
+ elog "install app-emacs/rust-mode to get emacs support for rust."
+ fi
+
+ if has_version app-editors/gvim || has_version app-editors/vim; then
+ elog "install app-vim/rust-mode to get vim support for rust."
+ fi
+
+ if has_version 'app-shells/zsh'; then
+ elog "install app-shells/rust-zshcomp to get zsh completion for rust."
+ fi
}
pkg_postrm() {