summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristoph Junghans <ottxor@gentoo.org>2013-11-08 04:01:16 +0000
committerChristoph Junghans <ottxor@gentoo.org>2013-11-08 04:01:16 +0000
commit49844fef6250764e0c325361c8282ae9bf369b23 (patch)
tree6ddfe82775ae77da4af9bcbfeb30ee0f12d1605c /dev-lang
parentDev channel bump. Remove old. (diff)
downloadgentoo-2-49844fef6250764e0c325361c8282ae9bf369b23.tar.gz
gentoo-2-49844fef6250764e0c325361c8282ae9bf369b23.tar.bz2
gentoo-2-49844fef6250764e0c325361c8282ae9bf369b23.zip
version bump
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key C2000586)
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/ispc/ChangeLog9
-rw-r--r--dev-lang/ispc/ispc-1.4.4.ebuild (renamed from dev-lang/ispc/ispc-1.4.3.ebuild)2
-rw-r--r--dev-lang/ispc/ispc-1.5.0.ebuild51
3 files changed, 60 insertions, 2 deletions
diff --git a/dev-lang/ispc/ChangeLog b/dev-lang/ispc/ChangeLog
index 957a76aa91d7..10c7615f3cd7 100644
--- a/dev-lang/ispc/ChangeLog
+++ b/dev-lang/ispc/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-lang/ispc
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/ispc/ChangeLog,v 1.12 2013/06/26 00:29:51 ottxor Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/ispc/ChangeLog,v 1.13 2013/11/08 04:01:16 ottxor Exp $
+
+*ispc-1.5.0 (08 Nov 2013)
+*ispc-1.4.4 (08 Nov 2013)
+
+ 08 Nov 2013; Christoph Junghans <ottxor@gentoo.org> +ispc-1.4.4.ebuild,
+ +ispc-1.5.0.ebuild, -ispc-1.4.3.ebuild:
+ version bump
*ispc-1.4.3 (26 Jun 2013)
diff --git a/dev-lang/ispc/ispc-1.4.3.ebuild b/dev-lang/ispc/ispc-1.4.4.ebuild
index 1cb4ef89d280..9a548ada6ece 100644
--- a/dev-lang/ispc/ispc-1.4.3.ebuild
+++ b/dev-lang/ispc/ispc-1.4.4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/ispc/ispc-1.4.3.ebuild,v 1.1 2013/06/26 00:29:51 ottxor Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/ispc/ispc-1.4.4.ebuild,v 1.1 2013/11/08 04:01:16 ottxor Exp $
EAPI=5
diff --git a/dev-lang/ispc/ispc-1.5.0.ebuild b/dev-lang/ispc/ispc-1.5.0.ebuild
new file mode 100644
index 000000000000..b92818e040ee
--- /dev/null
+++ b/dev-lang/ispc/ispc-1.5.0.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/ispc/ispc-1.5.0.ebuild,v 1.1 2013/11/08 04:01:16 ottxor Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_6,2_7} )
+
+inherit base toolchain-funcs python-any-r1
+
+DESCRIPTION="Intel SPMD Program Compiler"
+HOMEPAGE="http://ispc.github.com/"
+
+if [[ ${PV} = *9999 ]]; then
+ inherit git-2
+ EGIT_REPO_URI="git://github.com/ispc/ispc.git"
+ KEYWORDS=""
+else
+ SRC_URI="https://github.com/${PN}/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="BSD BSD-2 UoI-NCSA"
+SLOT="0"
+IUSE="examples"
+
+RDEPEND="
+ >=sys-devel/clang-3.0
+ >=sys-devel/llvm-3.0
+ "
+DEPEND="
+ ${RDEPEND}
+ ${PYTHON_DEPS}
+ sys-devel/bison
+ sys-devel/flex
+ "
+
+src_compile() {
+ emake LDFLAGS="${LDFLAGS}" OPT="${CXXFLAGS}" CXX="$(tc-getCXX)" CPP="$(tc-getCPP)"
+}
+
+src_install() {
+ dobin ispc
+ dodoc README.rst
+
+ if use examples; then
+ insinto "/usr/share/doc/${PF}/examples"
+ docompress -x "/usr/share/doc/${PF}/examples"
+ doins -r examples/*
+ fi
+}