summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2012-08-24 03:03:35 +0000
committerPatrick Lauer <patrick@gentoo.org>2012-08-24 03:03:35 +0000
commit2b2c8f96864fb72f93f1e27ba5b9fc8800757443 (patch)
treec7f2a25fd41ae1032a51ea89d8c80b503ff831cc /dev-lang
parentbump and take over maintainership, many things may change soon (diff)
downloadgentoo-2-2b2c8f96864fb72f93f1e27ba5b9fc8800757443.tar.gz
gentoo-2-2b2c8f96864fb72f93f1e27ba5b9fc8800757443.tar.bz2
gentoo-2-2b2c8f96864fb72f93f1e27ba5b9fc8800757443.zip
Bump
(Portage version: 2.2.0_alpha122/cvs/Linux x86_64)
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/nqp/ChangeLog7
-rw-r--r--dev-lang/nqp/nqp-2012.08.ebuild51
2 files changed, 57 insertions, 1 deletions
diff --git a/dev-lang/nqp/ChangeLog b/dev-lang/nqp/ChangeLog
index 5d0e0f051e42..ce1ec781f9da 100644
--- a/dev-lang/nqp/ChangeLog
+++ b/dev-lang/nqp/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-lang/nqp
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/nqp/ChangeLog,v 1.13 2012/07/26 05:24:06 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/nqp/ChangeLog,v 1.14 2012/08/24 03:03:35 patrick Exp $
+
+*nqp-2012.08 (24 Aug 2012)
+
+ 24 Aug 2012; Patrick Lauer <patrick@gentoo.org> +nqp-2012.08.ebuild:
+ Bump
*nqp-2012.07 (26 Jul 2012)
diff --git a/dev-lang/nqp/nqp-2012.08.ebuild b/dev-lang/nqp/nqp-2012.08.ebuild
new file mode 100644
index 000000000000..2a90ea38fcb5
--- /dev/null
+++ b/dev-lang/nqp/nqp-2012.08.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/nqp/nqp-2012.08.ebuild,v 1.1 2012/08/24 03:03:35 patrick Exp $
+
+EAPI=3
+
+inherit eutils multilib
+
+PARROT_VERSION="4.4.0"
+
+DESCRIPTION="Not Quite Perl, a Perl 6 bootstrapping compiler"
+HOMEPAGE="http://rakudo.org/"
+SRC_URI="http://github.com/perl6/${PN}/tarball/${PV} -> ${P}.tar.gz"
+
+LICENSE="Artistic-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc"
+
+RDEPEND=">=dev-lang/parrot-${PARROT_VERSION}[unicode]"
+DEPEND="${RDEPEND}
+ dev-lang/perl"
+
+src_prepare() {
+ cd "${WORKDIR}"
+ ln -s * "${S}" || die
+ cd "${S}"
+ echo "${PV}" > VERSION
+}
+
+src_configure() {
+ perl Configure.pl || die
+}
+
+src_compile() {
+ emake -j1 || die
+}
+
+src_test() {
+ emake -j1 test || die
+}
+
+src_install() {
+ emake DESTDIR="${ED}" install || die
+
+ dodoc CREDITS README || die
+
+ if use doc; then
+ dodoc docs/* || die
+ fi
+}