summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2014-04-27 11:19:59 +0000
committerGilles Dartiguelongue <eva@gentoo.org>2014-04-27 11:19:59 +0000
commit279c75532875e501152e23e1876025cdcec575a8 (patch)
tree14179cdb07f9906dfde49bfb03c1506f39ee0928 /dev-lang
parentVersion bump. (diff)
downloadgentoo-2-279c75532875e501152e23e1876025cdcec575a8.tar.gz
gentoo-2-279c75532875e501152e23e1876025cdcec575a8.tar.bz2
gentoo-2-279c75532875e501152e23e1876025cdcec575a8.zip
Version bump.
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key C6085806)
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/vala/ChangeLog7
-rw-r--r--dev-lang/vala/vala-0.24.0.ebuild38
2 files changed, 44 insertions, 1 deletions
diff --git a/dev-lang/vala/ChangeLog b/dev-lang/vala/ChangeLog
index 6c89c9ed25f8..4614fa9c8e6e 100644
--- a/dev-lang/vala/ChangeLog
+++ b/dev-lang/vala/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-lang/vala
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/vala/ChangeLog,v 1.168 2014/04/25 18:52:14 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/vala/ChangeLog,v 1.169 2014/04/27 11:19:59 eva Exp $
+
+*vala-0.24.0 (27 Apr 2014)
+
+ 27 Apr 2014; Gilles Dartiguelongue <eva@gentoo.org> +vala-0.24.0.ebuild:
+ Version bump.
25 Apr 2014; Pacho Ramos <pacho@gentoo.org>
-files/vala-0.14.2-cogl-pango-1.0.patch, -vala-0.10.4-r2.ebuild,
diff --git a/dev-lang/vala/vala-0.24.0.ebuild b/dev-lang/vala/vala-0.24.0.ebuild
new file mode 100644
index 000000000000..f71a851c4e8e
--- /dev/null
+++ b/dev-lang/vala/vala-0.24.0.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/vala/vala-0.24.0.ebuild,v 1.1 2014/04/27 11:19:59 eva Exp $
+
+EAPI="5"
+GCONF_DEBUG="no"
+
+inherit gnome2
+
+DESCRIPTION="Compiler for the GObject type system"
+HOMEPAGE="https://wiki.gnome.org/Vala"
+
+LICENSE="LGPL-2.1"
+SLOT="0.24"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~arm-linux ~x86-linux"
+IUSE="test +vapigen"
+
+RDEPEND="
+ >=dev-libs/glib-2.18:2
+ >=dev-libs/vala-common-${PV}
+"
+DEPEND="${RDEPEND}
+ !${CATEGORY}/${PN}:0
+ dev-libs/libxslt
+ sys-devel/flex
+ virtual/pkgconfig
+ virtual/yacc
+ test? (
+ dev-libs/dbus-glib
+ >=dev-libs/glib-2.26:2 )
+"
+
+src_configure() {
+ DOCS="AUTHORS ChangeLog MAINTAINERS NEWS README"
+ gnome2_src_configure \
+ --disable-unversioned \
+ $(use_enable vapigen)
+}