summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBenedikt Boehm <hollow@gentoo.org>2008-03-23 11:53:04 +0000
committerBenedikt Boehm <hollow@gentoo.org>2008-03-23 11:53:04 +0000
commit16fe700fe717af620e94902e7c76091bbc73ff53 (patch)
tree34ffbfd9ae492f59d6e3bd1d16c473ac418b5917 /dev-lang
parentadd slatex support thanks to Massimo Zanetti <zanetti.massimo@gmail.com>, bug... (diff)
downloadgentoo-2-16fe700fe717af620e94902e7c76091bbc73ff53.tar.gz
gentoo-2-16fe700fe717af620e94902e7c76091bbc73ff53.tar.bz2
gentoo-2-16fe700fe717af620e94902e7c76091bbc73ff53.zip
fix depend.apache usage wrt #208033
(Portage version: 2.1.4.4)
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/php/ChangeLog7
-rw-r--r--dev-lang/php/php-4.4.8.ebuild91
-rw-r--r--dev-lang/php/php-4.4.8_pre20070816.ebuild93
-rw-r--r--dev-lang/php/php-5.2.5-r1.ebuild93
-rw-r--r--dev-lang/php/php-5.2.6_rc1-r1.ebuild91
5 files changed, 136 insertions, 239 deletions
diff --git a/dev-lang/php/ChangeLog b/dev-lang/php/ChangeLog
index e172be3e547c..071103c29bb6 100644
--- a/dev-lang/php/ChangeLog
+++ b/dev-lang/php/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-lang/php
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/php/ChangeLog,v 1.250 2008/03/19 13:09:36 hoffie Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/php/ChangeLog,v 1.251 2008/03/23 11:53:04 hollow Exp $
+
+ 23 Mar 2008; Benedikt Böhm <hollow@gentoo.org>
+ php-4.4.8_pre20070816.ebuild, php-4.4.8.ebuild, php-5.2.5-r1.ebuild,
+ php-5.2.6_rc1-r1.ebuild:
+ fix depend.apache usage wrt #208033
19 Mar 2008; Christian Hoffmann <hoffie@gentoo.org>
-php-5.2.4_pre200708051230-r2.ebuild, -php-5.2.5_p20080206-r3.ebuild,
diff --git a/dev-lang/php/php-4.4.8.ebuild b/dev-lang/php/php-4.4.8.ebuild
index d9c0f7153205..1c4f8ecd3b52 100644
--- a/dev-lang/php/php-4.4.8.ebuild
+++ b/dev-lang/php/php-4.4.8.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/php/php-4.4.8.ebuild,v 1.1 2008/01/08 17:28:26 hoffie Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/php/php-4.4.8.ebuild,v 1.2 2008/03/23 11:53:04 hollow Exp $
CGI_SAPI_USE="discard-path force-cgi-redirect"
APACHE2_SAPI_USE="concurrentmodphp threads"
@@ -45,47 +45,28 @@ pkg_setup() {
# Threaded Apache2 support
if use apache2 ; then
- if [[ "${APACHE_VERSION}" != "0" ]] ; then
- if ! use threads ; then
- APACHE2_SAFE_MPMS="itk peruser prefork"
- else
- APACHE2_SAFE_MPMS="event leader metuxmpm perchild threadpool worker"
- fi
-
- ewarn
- ewarn "If this package fails with a fatal error about Apache2 not having"
- ewarn "been compiled with a compatible MPM, this is normally because you"
- ewarn "need to toggle the 'threads' USE flag."
- ewarn
- ewarn "If 'threads' is off, try switching it on."
- ewarn "If 'threads' is on, try switching it off."
- ewarn
-
- apache-module_pkg_setup
- fi
+ has_apache_threads
fi
# Concurrent PHP Apache2 modules support
if use apache2 ; then
- if [[ "${APACHE_VERSION}" != "0" ]] ; then
- if use concurrentmodphp ; then
- ewarn
- ewarn "'concurrentmodphp' makes it possible to load multiple, differently"
- ewarn "versioned mod_php's into the same Apache instance. This is done with"
- ewarn "a few linker tricks and workarounds, and is not guaranteed to always"
- ewarn "work correctly, so use it at your own risk. Especially, do not use"
- ewarn "this in conjunction with PHP modules (PECL, ...) other than the ones"
- ewarn "you may find in the Portage tree or the PHP Overlay!"
- ewarn "This is an experimental feature, so please rebuild PHP"
- ewarn "without the 'concurrentmodphp' USE flag if you experience"
- ewarn "any problems, and then reproduce any bugs before filing"
- ewarn "them in Gentoo's Bugzilla or bugs.php.net."
- ewarn "If you have conclusive evidence that a bug directly"
- ewarn "derives from 'concurrentmodphp', please file a bug in"
- ewarn "Gentoo's Bugzilla only."
- ewarn
- ebeep 5
- fi
+ if use concurrentmodphp ; then
+ ewarn
+ ewarn "'concurrentmodphp' makes it possible to load multiple, differently"
+ ewarn "versioned mod_php's into the same Apache instance. This is done with"
+ ewarn "a few linker tricks and workarounds, and is not guaranteed to always"
+ ewarn "work correctly, so use it at your own risk. Especially, do not use"
+ ewarn "this in conjunction with PHP modules (PECL, ...) other than the ones"
+ ewarn "you may find in the Portage tree or the PHP Overlay!"
+ ewarn "This is an experimental feature, so please rebuild PHP"
+ ewarn "without the 'concurrentmodphp' USE flag if you experience"
+ ewarn "any problems, and then reproduce any bugs before filing"
+ ewarn "them in Gentoo's Bugzilla or bugs.php.net."
+ ewarn "If you have conclusive evidence that a bug directly"
+ ewarn "derives from 'concurrentmodphp', please file a bug in"
+ ewarn "Gentoo's Bugzilla only."
+ ewarn
+ ebeep 5
fi
fi
@@ -120,9 +101,7 @@ php_determine_sapis() {
# note - apache SAPI comes after the simpler cli/cgi sapis
if use apache2 ; then
- if [[ "${APACHE_VERSION}" != "0" ]] ; then
- PHPSAPIS="${PHPSAPIS} apache${APACHE_VERSION}"
- fi
+ PHPSAPIS="${PHPSAPIS} apache${APACHE_VERSION}"
fi
}
@@ -135,13 +114,11 @@ src_unpack() {
# Concurrent PHP Apache2 modules support
if use apache2 ; then
- if [[ "${APACHE_VERSION}" != "0" ]] ; then
- if use concurrentmodphp ; then
- if [[ -n "${CONCURRENTMODPHP_PATCH}" ]] && [[ -f "${WORKDIR}/${CONCURRENTMODPHP_PATCH}" ]] ; then
- epatch "${WORKDIR}/${CONCURRENTMODPHP_PATCH}"
- else
- ewarn "There is no concurrent mod_php patch available for this PHP release yet!"
- fi
+ if use concurrentmodphp ; then
+ if [[ -n "${CONCURRENTMODPHP_PATCH}" ]] && [[ -f "${WORKDIR}/${CONCURRENTMODPHP_PATCH}" ]] ; then
+ epatch "${WORKDIR}/${CONCURRENTMODPHP_PATCH}"
+ else
+ ewarn "There is no concurrent mod_php patch available for this PHP release yet!"
fi
fi
fi
@@ -281,11 +258,9 @@ src_compile_normal() {
# Support the Apache2 extras, they must be set globally for all
# SAPIs to work correctly, especially for external PHP extensions
if use apache2 ; then
- if [[ "${APACHE_VERSION}" != "0" ]] ; then
- # Concurrent PHP Apache2 modules support
- if use concurrentmodphp ; then
- append-ldflags "-Wl,--version-script=${FILESDIR}/php4-ldvs"
- fi
+ # Concurrent PHP Apache2 modules support
+ if use concurrentmodphp ; then
+ append-ldflags "-Wl,--version-script=${FILESDIR}/php4-ldvs"
fi
fi
@@ -293,12 +268,10 @@ src_compile_normal() {
# Support the Apache2 extras, they must be set globally for all
# SAPIs to work correctly, especially for external PHP extensions
if use apache2 ; then
- if [[ "${APACHE_VERSION}" != "0" ]] ; then
- # Threaded Apache2 support
- if use threads ; then
- my_conf="${my_conf} --enable-experimental-zts"
- ewarn "Enabling ZTS for Apache2 MPM"
- fi
+ # Threaded Apache2 support
+ if use threads ; then
+ my_conf="${my_conf} --enable-experimental-zts"
+ ewarn "Enabling ZTS for Apache2 MPM"
fi
fi
diff --git a/dev-lang/php/php-4.4.8_pre20070816.ebuild b/dev-lang/php/php-4.4.8_pre20070816.ebuild
index 39d024237470..45ef2f343281 100644
--- a/dev-lang/php/php-4.4.8_pre20070816.ebuild
+++ b/dev-lang/php/php-4.4.8_pre20070816.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/php/php-4.4.8_pre20070816.ebuild,v 1.9 2007/08/29 10:22:06 corsair Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/php/php-4.4.8_pre20070816.ebuild,v 1.10 2008/03/23 11:53:04 hollow Exp $
CGI_SAPI_USE="discard-path force-cgi-redirect"
APACHE2_SAPI_USE="concurrentmodphp threads"
@@ -51,47 +51,28 @@ pkg_setup() {
# Threaded Apache2 support
if use apache2 ; then
- if [[ "${APACHE_VERSION}" != "0" ]] ; then
- if ! use threads ; then
- APACHE2_SAFE_MPMS="itk peruser prefork"
- else
- APACHE2_SAFE_MPMS="event leader metuxmpm perchild threadpool worker"
- fi
-
- ewarn
- ewarn "If this package fails with a fatal error about Apache2 not having"
- ewarn "been compiled with a compatible MPM, this is normally because you"
- ewarn "need to toggle the 'threads' USE flag."
- ewarn
- ewarn "If 'threads' is off, try switching it on."
- ewarn "If 'threads' is on, try switching it off."
- ewarn
-
- apache-module_pkg_setup
- fi
+ has_apache_threads
fi
# Concurrent PHP Apache2 modules support
if use apache2 ; then
- if [[ "${APACHE_VERSION}" != "0" ]] ; then
- if use concurrentmodphp ; then
- ewarn
- ewarn "'concurrentmodphp' makes it possible to load multiple, differently"
- ewarn "versioned mod_php's into the same Apache instance. This is done with"
- ewarn "a few linker tricks and workarounds, and is not guaranteed to always"
- ewarn "work correctly, so use it at your own risk. Especially, do not use"
- ewarn "this in conjunction with PHP modules (PECL, ...) other than the ones"
- ewarn "you may find in the Portage tree or the PHP Overlay!"
- ewarn "This is an experimental feature, so please rebuild PHP"
- ewarn "without the 'concurrentmodphp' USE flag if you experience"
- ewarn "any problems, and then reproduce any bugs before filing"
- ewarn "them in Gentoo's Bugzilla or bugs.php.net."
- ewarn "If you have conclusive evidence that a bug directly"
- ewarn "derives from 'concurrentmodphp', please file a bug in"
- ewarn "Gentoo's Bugzilla only."
- ewarn
- ebeep 5
- fi
+ if use concurrentmodphp ; then
+ ewarn
+ ewarn "'concurrentmodphp' makes it possible to load multiple, differently"
+ ewarn "versioned mod_php's into the same Apache instance. This is done with"
+ ewarn "a few linker tricks and workarounds, and is not guaranteed to always"
+ ewarn "work correctly, so use it at your own risk. Especially, do not use"
+ ewarn "this in conjunction with PHP modules (PECL, ...) other than the ones"
+ ewarn "you may find in the Portage tree or the PHP Overlay!"
+ ewarn "This is an experimental feature, so please rebuild PHP"
+ ewarn "without the 'concurrentmodphp' USE flag if you experience"
+ ewarn "any problems, and then reproduce any bugs before filing"
+ ewarn "them in Gentoo's Bugzilla or bugs.php.net."
+ ewarn "If you have conclusive evidence that a bug directly"
+ ewarn "derives from 'concurrentmodphp', please file a bug in"
+ ewarn "Gentoo's Bugzilla only."
+ ewarn
+ ebeep 5
fi
fi
@@ -126,9 +107,7 @@ php_determine_sapis() {
# note - apache SAPI comes after the simpler cli/cgi sapis
if use apache2 ; then
- if [[ "${APACHE_VERSION}" != "0" ]] ; then
- PHPSAPIS="${PHPSAPIS} apache${APACHE_VERSION}"
- fi
+ PHPSAPIS="${PHPSAPIS} apache${APACHE_VERSION}"
fi
}
@@ -141,13 +120,11 @@ src_unpack() {
# Concurrent PHP Apache2 modules support
if use apache2 ; then
- if [[ "${APACHE_VERSION}" != "0" ]] ; then
- if use concurrentmodphp ; then
- if [[ -n "${CONCURRENTMODPHP_PATCH}" ]] && [[ -f "${WORKDIR}/${CONCURRENTMODPHP_PATCH}" ]] ; then
- epatch "${WORKDIR}/${CONCURRENTMODPHP_PATCH}"
- else
- ewarn "There is no concurrent mod_php patch available for this PHP release yet!"
- fi
+ if use concurrentmodphp ; then
+ if [[ -n "${CONCURRENTMODPHP_PATCH}" ]] && [[ -f "${WORKDIR}/${CONCURRENTMODPHP_PATCH}" ]] ; then
+ epatch "${WORKDIR}/${CONCURRENTMODPHP_PATCH}"
+ else
+ ewarn "There is no concurrent mod_php patch available for this PHP release yet!"
fi
fi
fi
@@ -291,11 +268,9 @@ src_compile_normal() {
# Support the Apache2 extras, they must be set globally for all
# SAPIs to work correctly, especially for external PHP extensions
if use apache2 ; then
- if [[ "${APACHE_VERSION}" != "0" ]] ; then
- # Concurrent PHP Apache2 modules support
- if use concurrentmodphp ; then
- append-ldflags "-Wl,--version-script=${FILESDIR}/php4-ldvs"
- fi
+ # Concurrent PHP Apache2 modules support
+ if use concurrentmodphp ; then
+ append-ldflags "-Wl,--version-script=${FILESDIR}/php4-ldvs"
fi
fi
@@ -303,12 +278,10 @@ src_compile_normal() {
# Support the Apache2 extras, they must be set globally for all
# SAPIs to work correctly, especially for external PHP extensions
if use apache2 ; then
- if [[ "${APACHE_VERSION}" != "0" ]] ; then
- # Threaded Apache2 support
- if use threads ; then
- my_conf="${my_conf} --enable-experimental-zts"
- ewarn "Enabling ZTS for Apache2 MPM"
- fi
+ # Threaded Apache2 support
+ if use threads ; then
+ my_conf="${my_conf} --enable-experimental-zts"
+ ewarn "Enabling ZTS for Apache2 MPM"
fi
fi
diff --git a/dev-lang/php/php-5.2.5-r1.ebuild b/dev-lang/php/php-5.2.5-r1.ebuild
index 0f2a13166c7b..0d285c35a13b 100644
--- a/dev-lang/php/php-5.2.5-r1.ebuild
+++ b/dev-lang/php/php-5.2.5-r1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/php/php-5.2.5-r1.ebuild,v 1.7 2007/12/15 14:44:10 welp Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/php/php-5.2.5-r1.ebuild,v 1.8 2008/03/23 11:53:04 hollow Exp $
CGI_SAPI_USE="discard-path force-cgi-redirect"
APACHE2_SAPI_USE="concurrentmodphp threads"
@@ -45,47 +45,28 @@ pkg_setup() {
# Threaded Apache2 support
if use apache2 ; then
- if [[ "${APACHE_VERSION}" != "0" ]] ; then
- if ! use threads ; then
- APACHE2_SAFE_MPMS="itk peruser prefork"
- else
- APACHE2_SAFE_MPMS="event leader metuxmpm perchild threadpool worker"
- fi
-
- ewarn
- ewarn "If this package fails with a fatal error about Apache2 not having"
- ewarn "been compiled with a compatible MPM, this is normally because you"
- ewarn "need to toggle the 'threads' USE flag."
- ewarn
- ewarn "If 'threads' is off, try switching it on."
- ewarn "If 'threads' is on, try switching it off."
- ewarn
-
- apache-module_pkg_setup
- fi
+ has_apache_threads
fi
# Concurrent PHP Apache2 modules support
if use apache2 ; then
- if [[ "${APACHE_VERSION}" != "0" ]] ; then
- if use concurrentmodphp ; then
- ewarn
- ewarn "'concurrentmodphp' makes it possible to load multiple, differently"
- ewarn "versioned mod_php's into the same Apache instance. This is done with"
- ewarn "a few linker tricks and workarounds, and is not guaranteed to always"
- ewarn "work correctly, so use it at your own risk. Especially, do not use"
- ewarn "this in conjunction with PHP modules (PECL, ...) other than the ones"
- ewarn "you may find in the Portage tree or the PHP Overlay!"
- ewarn "This is an experimental feature, so please rebuild PHP"
- ewarn "without the 'concurrentmodphp' USE flag if you experience"
- ewarn "any problems, and then reproduce any bugs before filing"
- ewarn "them in Gentoo's Bugzilla or bugs.php.net."
- ewarn "If you have conclusive evidence that a bug directly"
- ewarn "derives from 'concurrentmodphp', please file a bug in"
- ewarn "Gentoo's Bugzilla only."
- ewarn
- ebeep 5
- fi
+ if use concurrentmodphp ; then
+ ewarn
+ ewarn "'concurrentmodphp' makes it possible to load multiple, differently"
+ ewarn "versioned mod_php's into the same Apache instance. This is done with"
+ ewarn "a few linker tricks and workarounds, and is not guaranteed to always"
+ ewarn "work correctly, so use it at your own risk. Especially, do not use"
+ ewarn "this in conjunction with PHP modules (PECL, ...) other than the ones"
+ ewarn "you may find in the Portage tree or the PHP Overlay!"
+ ewarn "This is an experimental feature, so please rebuild PHP"
+ ewarn "without the 'concurrentmodphp' USE flag if you experience"
+ ewarn "any problems, and then reproduce any bugs before filing"
+ ewarn "them in Gentoo's Bugzilla or bugs.php.net."
+ ewarn "If you have conclusive evidence that a bug directly"
+ ewarn "derives from 'concurrentmodphp', please file a bug in"
+ ewarn "Gentoo's Bugzilla only."
+ ewarn
+ ebeep 5
fi
fi
@@ -120,9 +101,7 @@ php_determine_sapis() {
# note - apache SAPI comes after the simpler cli/cgi sapis
if use apache2 ; then
- if [[ "${APACHE_VERSION}" != "0" ]] ; then
- PHPSAPIS="${PHPSAPIS} apache${APACHE_VERSION}"
- fi
+ PHPSAPIS="${PHPSAPIS} apache${APACHE_VERSION}"
fi
}
@@ -135,13 +114,11 @@ src_unpack() {
# Concurrent PHP Apache2 modules support
if use apache2 ; then
- if [[ "${APACHE_VERSION}" != "0" ]] ; then
- if use concurrentmodphp ; then
- if [[ -n "${CONCURRENTMODPHP_PATCH}" ]] && [[ -f "${WORKDIR}/${CONCURRENTMODPHP_PATCH}" ]] ; then
- epatch "${WORKDIR}/${CONCURRENTMODPHP_PATCH}"
- else
- ewarn "There is no concurrent mod_php patch available for this PHP release yet!"
- fi
+ if use concurrentmodphp ; then
+ if [[ -n "${CONCURRENTMODPHP_PATCH}" ]] && [[ -f "${WORKDIR}/${CONCURRENTMODPHP_PATCH}" ]] ; then
+ epatch "${WORKDIR}/${CONCURRENTMODPHP_PATCH}"
+ else
+ ewarn "There is no concurrent mod_php patch available for this PHP release yet!"
fi
fi
fi
@@ -294,11 +271,9 @@ src_compile_normal() {
# Support the Apache2 extras, they must be set globally for all
# SAPIs to work correctly, especially for external PHP extensions
if use apache2 ; then
- if [[ "${APACHE_VERSION}" != "0" ]] ; then
- # Concurrent PHP Apache2 modules support
- if use concurrentmodphp ; then
- append-ldflags "-Wl,--version-script=${FILESDIR}/php5-ldvs"
- fi
+ # Concurrent PHP Apache2 modules support
+ if use concurrentmodphp ; then
+ append-ldflags "-Wl,--version-script=${FILESDIR}/php5-ldvs"
fi
fi
@@ -306,12 +281,10 @@ src_compile_normal() {
# Support the Apache2 extras, they must be set globally for all
# SAPIs to work correctly, especially for external PHP extensions
if use apache2 ; then
- if [[ "${APACHE_VERSION}" != "0" ]] ; then
- # Threaded Apache2 support
- if use threads ; then
- my_conf="${my_conf} --enable-maintainer-zts"
- ewarn "Enabling ZTS for Apache2 MPM"
- fi
+ # Threaded Apache2 support
+ if use threads ; then
+ my_conf="${my_conf} --enable-maintainer-zts"
+ ewarn "Enabling ZTS for Apache2 MPM"
fi
fi
diff --git a/dev-lang/php/php-5.2.6_rc1-r1.ebuild b/dev-lang/php/php-5.2.6_rc1-r1.ebuild
index 87be03946e77..58f12b6f5e88 100644
--- a/dev-lang/php/php-5.2.6_rc1-r1.ebuild
+++ b/dev-lang/php/php-5.2.6_rc1-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/php/php-5.2.6_rc1-r1.ebuild,v 1.7 2008/03/09 08:07:54 dertobi123 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/php/php-5.2.6_rc1-r1.ebuild,v 1.8 2008/03/23 11:53:04 hollow Exp $
CGI_SAPI_USE="discard-path force-cgi-redirect"
APACHE2_SAPI_USE="concurrentmodphp threads"
@@ -52,47 +52,28 @@ pkg_setup() {
# Threaded Apache2 support
if use apache2 ; then
- if [[ "${APACHE_VERSION}" != "0" ]] ; then
- if ! use threads ; then
- APACHE2_SAFE_MPMS="itk peruser prefork"
- else
- APACHE2_SAFE_MPMS="event leader metuxmpm perchild threadpool worker"
- fi
-
- ewarn
- ewarn "If this package fails with a fatal error about Apache2 not having"
- ewarn "been compiled with a compatible MPM, this is normally because you"
- ewarn "need to toggle the 'threads' USE flag."
- ewarn
- ewarn "If 'threads' is off, try switching it on."
- ewarn "If 'threads' is on, try switching it off."
- ewarn
-
- apache-module_pkg_setup
- fi
+ has_apache_threads
fi
# Concurrent PHP Apache2 modules support
if use apache2 ; then
- if [[ "${APACHE_VERSION}" != "0" ]] ; then
- if use concurrentmodphp ; then
- ewarn
- ewarn "'concurrentmodphp' makes it possible to load multiple, differently"
- ewarn "versioned mod_php's into the same Apache instance. This is done with"
- ewarn "a few linker tricks and workarounds, and is not guaranteed to always"
- ewarn "work correctly, so use it at your own risk. Especially, do not use"
- ewarn "this in conjunction with PHP modules (PECL, ...) other than the ones"
- ewarn "you may find in the Portage tree or the PHP Overlay!"
- ewarn "This is an experimental feature, so please rebuild PHP"
- ewarn "without the 'concurrentmodphp' USE flag if you experience"
- ewarn "any problems, and then reproduce any bugs before filing"
- ewarn "them in Gentoo's Bugzilla or bugs.php.net."
- ewarn "If you have conclusive evidence that a bug directly"
- ewarn "derives from 'concurrentmodphp', please file a bug in"
- ewarn "Gentoo's Bugzilla only."
- ewarn
- ebeep 5
- fi
+ if use concurrentmodphp ; then
+ ewarn
+ ewarn "'concurrentmodphp' makes it possible to load multiple, differently"
+ ewarn "versioned mod_php's into the same Apache instance. This is done with"
+ ewarn "a few linker tricks and workarounds, and is not guaranteed to always"
+ ewarn "work correctly, so use it at your own risk. Especially, do not use"
+ ewarn "this in conjunction with PHP modules (PECL, ...) other than the ones"
+ ewarn "you may find in the Portage tree or the PHP Overlay!"
+ ewarn "This is an experimental feature, so please rebuild PHP"
+ ewarn "without the 'concurrentmodphp' USE flag if you experience"
+ ewarn "any problems, and then reproduce any bugs before filing"
+ ewarn "them in Gentoo's Bugzilla or bugs.php.net."
+ ewarn "If you have conclusive evidence that a bug directly"
+ ewarn "derives from 'concurrentmodphp', please file a bug in"
+ ewarn "Gentoo's Bugzilla only."
+ ewarn
+ ebeep 5
fi
fi
@@ -127,9 +108,7 @@ php_determine_sapis() {
# note - apache SAPI comes after the simpler cli/cgi sapis
if use apache2 ; then
- if [[ "${APACHE_VERSION}" != "0" ]] ; then
- PHPSAPIS="${PHPSAPIS} apache${APACHE_VERSION}"
- fi
+ PHPSAPIS="${PHPSAPIS} apache${APACHE_VERSION}"
fi
}
@@ -142,13 +121,11 @@ src_unpack() {
# Concurrent PHP Apache2 modules support
if use apache2 ; then
- if [[ "${APACHE_VERSION}" != "0" ]] ; then
- if use concurrentmodphp ; then
- if [[ -n "${CONCURRENTMODPHP_PATCH}" ]] && [[ -f "${WORKDIR}/${CONCURRENTMODPHP_PATCH}" ]] ; then
- epatch "${WORKDIR}/${CONCURRENTMODPHP_PATCH}"
- else
- ewarn "There is no concurrent mod_php patch available for this PHP release yet!"
- fi
+ if use concurrentmodphp ; then
+ if [[ -n "${CONCURRENTMODPHP_PATCH}" ]] && [[ -f "${WORKDIR}/${CONCURRENTMODPHP_PATCH}" ]] ; then
+ epatch "${WORKDIR}/${CONCURRENTMODPHP_PATCH}"
+ else
+ ewarn "There is no concurrent mod_php patch available for this PHP release yet!"
fi
fi
fi
@@ -302,11 +279,9 @@ src_compile_normal() {
# Support the Apache2 extras, they must be set globally for all
# SAPIs to work correctly, especially for external PHP extensions
if use apache2 ; then
- if [[ "${APACHE_VERSION}" != "0" ]] ; then
- # Concurrent PHP Apache2 modules support
- if use concurrentmodphp ; then
- append-ldflags "-Wl,--version-script=${FILESDIR}/php5-ldvs"
- fi
+ # Concurrent PHP Apache2 modules support
+ if use concurrentmodphp ; then
+ append-ldflags "-Wl,--version-script=${FILESDIR}/php5-ldvs"
fi
fi
@@ -314,12 +289,10 @@ src_compile_normal() {
# Support the Apache2 extras, they must be set globally for all
# SAPIs to work correctly, especially for external PHP extensions
if use apache2 ; then
- if [[ "${APACHE_VERSION}" != "0" ]] ; then
- # Threaded Apache2 support
- if use threads ; then
- my_conf="${my_conf} --enable-maintainer-zts"
- ewarn "Enabling ZTS for Apache2 MPM"
- fi
+ # Threaded Apache2 support
+ if use threads ; then
+ my_conf="${my_conf} --enable-maintainer-zts"
+ ewarn "Enabling ZTS for Apache2 MPM"
fi
fi