summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2010-12-25 05:29:26 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2010-12-25 05:29:26 +0000
commit8cd504ebf4131030feb7ea3a11d366275b93b19d (patch)
treefc81e3f403ae52e22a305cf78099d81a5ae30ce5 /dev-lang/yasm
parentUse gentoo mirrors (diff)
downloadgentoo-2-8cd504ebf4131030feb7ea3a11d366275b93b19d.tar.gz
gentoo-2-8cd504ebf4131030feb7ea3a11d366275b93b19d.tar.bz2
gentoo-2-8cd504ebf4131030feb7ea3a11d366275b93b19d.zip
Fix for Cython 0.14 wrt #348587 by Arfrever Frehtes Taifersar Arahesis.
(Portage version: 2.2.0_alpha10/cvs/Linux x86_64)
Diffstat (limited to 'dev-lang/yasm')
-rw-r--r--dev-lang/yasm/ChangeLog8
-rw-r--r--dev-lang/yasm/files/yasm-1.1.0-cython-0.14.patch22
-rw-r--r--dev-lang/yasm/yasm-1.1.0-r1.ebuild48
-rw-r--r--dev-lang/yasm/yasm-1.1.0.ebuild6
4 files changed, 80 insertions, 4 deletions
diff --git a/dev-lang/yasm/ChangeLog b/dev-lang/yasm/ChangeLog
index d9054739b893..04ecf08c5a9d 100644
--- a/dev-lang/yasm/ChangeLog
+++ b/dev-lang/yasm/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-lang/yasm
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/yasm/ChangeLog,v 1.43 2010/11/03 12:02:48 phajdan.jr Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/yasm/ChangeLog,v 1.44 2010/12/25 05:29:26 ssuominen Exp $
+
+*yasm-1.1.0-r1 (25 Dec 2010)
+
+ 25 Dec 2010; Samuli Suominen <ssuominen@gentoo.org> +yasm-1.1.0-r1.ebuild,
+ +files/yasm-1.1.0-cython-0.14.patch:
+ Fix for Cython 0.14 wrt #348587 by Arfrever Frehtes Taifersar Arahesis.
03 Nov 2010; Pawel Hajdan jr <phajdan.jr@gentoo.org> yasm-1.1.0.ebuild:
x86 stable wrt bug #343143
diff --git a/dev-lang/yasm/files/yasm-1.1.0-cython-0.14.patch b/dev-lang/yasm/files/yasm-1.1.0-cython-0.14.patch
new file mode 100644
index 000000000000..65a0585ce200
--- /dev/null
+++ b/dev-lang/yasm/files/yasm-1.1.0-cython-0.14.patch
@@ -0,0 +1,22 @@
+http://bugs.gentoo.org/show_bug.cgi?id=348587
+
+--- tools/python-yasm/yasm.pyx
++++ tools/python-yasm/yasm.pyx
+@@ -97,7 +97,7 @@
+ #
+ cdef class __assoc_data_callback:
+ cdef yasm_assoc_data_callback *cb
+- def __new__(self, destroy, print_):
++ def __cinit__(self, destroy, print_):
+ self.cb = <yasm_assoc_data_callback *>malloc(sizeof(yasm_assoc_data_callback))
+ self.cb.destroy = <void (*) (void *)>PyCObject_AsVoidPtr(destroy)
+ #self.cb.print_ = <void (*) (void *, FILE *, int)>PyCObject_AsVoidPtr(print_)
+@@ -107,7 +107,7 @@
+
+ cdef class Register:
+ cdef unsigned long reg
+- def __new__(self, reg):
++ def __cinit__(self, reg):
+ self.reg = reg
+
+ include "errwarn.pxi"
diff --git a/dev-lang/yasm/yasm-1.1.0-r1.ebuild b/dev-lang/yasm/yasm-1.1.0-r1.ebuild
new file mode 100644
index 000000000000..5f1618959657
--- /dev/null
+++ b/dev-lang/yasm/yasm-1.1.0-r1.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/yasm/yasm-1.1.0-r1.ebuild,v 1.1 2010/12/25 05:29:26 ssuominen Exp $
+
+EAPI=2
+PYTHON_DEPEND="python? 2:2.6"
+
+inherit autotools eutils python
+
+DESCRIPTION="An assembler for x86 and x86_64 instruction sets"
+HOMEPAGE="http://www.tortall.net/projects/yasm/"
+SRC_URI="http://www.tortall.net/projects/yasm/releases/${P}.tar.gz"
+
+LICENSE="Artistic BSD GPL-2 LGPL-2"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~x64-macos ~x86-macos ~x86-solaris"
+IUSE="nls python"
+
+RDEPEND="nls? ( virtual/libintl )"
+DEPEND="nls? ( sys-devel/gettext )
+ python? ( >=dev-python/cython-0.13 )"
+
+pkg_setup() {
+ if use python; then
+ python_set_active_version 2
+ python_pkg_setup
+ fi
+}
+
+src_prepare() {
+ epatch \
+ "${FILESDIR}"/${PN}-1.1.0-skip_cython_check.patch \
+ "${FILESDIR}"/${PN}-1.1.0-cython-0.14.patch
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_enable python) \
+ $(use_enable python python-bindings) \
+ --disable-dependency-tracking \
+ $(use_enable nls)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ dodoc AUTHORS
+}
diff --git a/dev-lang/yasm/yasm-1.1.0.ebuild b/dev-lang/yasm/yasm-1.1.0.ebuild
index 19618314a984..bbfbda82a9e4 100644
--- a/dev-lang/yasm/yasm-1.1.0.ebuild
+++ b/dev-lang/yasm/yasm-1.1.0.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/yasm/yasm-1.1.0.ebuild,v 1.3 2010/11/03 12:02:48 phajdan.jr Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/yasm/yasm-1.1.0.ebuild,v 1.4 2010/12/25 05:29:26 ssuominen Exp $
EAPI=2
-PYTHON_DEPEND="python? 2:2.4"
+PYTHON_DEPEND="python? 2:2.6"
inherit autotools eutils python
@@ -18,7 +18,7 @@ IUSE="nls python"
RDEPEND="nls? ( virtual/libintl )"
DEPEND="nls? ( sys-devel/gettext )
- python? ( >=dev-python/cython-0.11.3 )"
+ python? ( >=dev-python/cython-0.11.3 <dev-python/cython-0.14 )"
pkg_setup() {
if use python; then