summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2015-01-24 12:59:24 +0000
committerPacho Ramos <pacho@gentoo.org>2015-01-24 12:59:24 +0000
commit88ff94ba0feacaae490b26b4bf81bdeec17eeb75 (patch)
tree33920f0fc2e77591938247a68360704660d5bd8f /dev-lang/vala
parentVersion bump, drop old (diff)
downloadgentoo-2-88ff94ba0feacaae490b26b4bf81bdeec17eeb75.tar.gz
gentoo-2-88ff94ba0feacaae490b26b4bf81bdeec17eeb75.tar.bz2
gentoo-2-88ff94ba0feacaae490b26b4bf81bdeec17eeb75.zip
Version bump
(Portage version: 2.2.15/cvs/Linux x86_64, signed Manifest commit with key A188FBD4)
Diffstat (limited to 'dev-lang/vala')
-rw-r--r--dev-lang/vala/ChangeLog9
-rw-r--r--dev-lang/vala/vala-0.26.2.ebuild36
2 files changed, 43 insertions, 2 deletions
diff --git a/dev-lang/vala/ChangeLog b/dev-lang/vala/ChangeLog
index 4858b59dc44e..80e539803b3b 100644
--- a/dev-lang/vala/ChangeLog
+++ b/dev-lang/vala/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-lang/vala
-# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/vala/ChangeLog,v 1.187 2014/12/21 12:25:00 eva Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/vala/ChangeLog,v 1.188 2015/01/24 12:59:24 pacho Exp $
+
+*vala-0.26.2 (24 Jan 2015)
+
+ 24 Jan 2015; Pacho Ramos <pacho@gentoo.org> +vala-0.26.2.ebuild:
+ Version bump
*vala-0.26.1 (21 Dec 2014)
diff --git a/dev-lang/vala/vala-0.26.2.ebuild b/dev-lang/vala/vala-0.26.2.ebuild
new file mode 100644
index 000000000000..ee4a28c8266c
--- /dev/null
+++ b/dev-lang/vala/vala-0.26.2.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/vala/vala-0.26.2.ebuild,v 1.1 2015/01/24 12:59:24 pacho Exp $
+
+EAPI="5"
+GCONF_DEBUG="no"
+
+inherit gnome2
+
+DESCRIPTION="Compiler for the GObject type system"
+HOMEPAGE="https://wiki.gnome.org/Vala"
+
+LICENSE="LGPL-2.1"
+SLOT="0.26"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~arm-linux ~x86-linux"
+IUSE="test"
+
+RDEPEND="
+ >=dev-libs/glib-2.24:2
+ >=dev-libs/vala-common-${PV}
+"
+DEPEND="${RDEPEND}
+ !${CATEGORY}/${PN}:0
+ dev-libs/libxslt
+ sys-devel/flex
+ virtual/pkgconfig
+ virtual/yacc
+ test? (
+ dev-libs/dbus-glib
+ >=dev-libs/glib-2.26:2 )
+"
+
+src_configure() {
+ DOCS="AUTHORS ChangeLog MAINTAINERS NEWS README"
+ gnome2_src_configure --disable-unversioned
+}