summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2006-03-24 00:12:51 +0000
committerMike Frysinger <vapier@gentoo.org>2006-03-24 00:12:51 +0000
commit48a172e05f2e9c09c9079baff5440a512cf458c9 (patch)
treeeef7f84b7afb8021dace7cfde193a618fd7a6f25 /dev-lang/ucblogo
parentdeps are implied by games-rpg/adonthell (diff)
downloadgentoo-2-48a172e05f2e9c09c9079baff5440a512cf458c9.tar.gz
gentoo-2-48a172e05f2e9c09c9079baff5440a512cf458c9.tar.bz2
gentoo-2-48a172e05f2e9c09c9079baff5440a512cf458c9.zip
Fix by Lukasz Demianiuk to add support for DESTDIR to emacs dir #127354.
(Portage version: 2.1_pre6-r6)
Diffstat (limited to 'dev-lang/ucblogo')
-rw-r--r--dev-lang/ucblogo/ChangeLog8
-rw-r--r--dev-lang/ucblogo/files/ucblogo-5.5-destdir.patch32
-rw-r--r--dev-lang/ucblogo/ucblogo-5.5.ebuild4
3 files changed, 40 insertions, 4 deletions
diff --git a/dev-lang/ucblogo/ChangeLog b/dev-lang/ucblogo/ChangeLog
index 562839ddefdb..aba50066670e 100644
--- a/dev-lang/ucblogo/ChangeLog
+++ b/dev-lang/ucblogo/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-lang/ucblogo
-# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/ucblogo/ChangeLog,v 1.2 2005/11/20 06:42:47 vapier Exp $
+# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/ucblogo/ChangeLog,v 1.3 2006/03/24 00:12:51 vapier Exp $
+
+ 24 Mar 2006; Mike Frysinger <vapier@gentoo.org>
+ files/ucblogo-5.5-destdir.patch, ucblogo-5.5.ebuild:
+ Fix by Lukasz Demianiuk to add support for DESTDIR to emacs dir #127354.
20 Nov 2005; Mike Frysinger <vapier@gentoo.org>
+files/ucblogo-5.5-dont-require-tetex.patch, ucblogo-5.5.ebuild:
diff --git a/dev-lang/ucblogo/files/ucblogo-5.5-destdir.patch b/dev-lang/ucblogo/files/ucblogo-5.5-destdir.patch
index 36c4c63d7d04..89fd129c488e 100644
--- a/dev-lang/ucblogo/files/ucblogo-5.5-destdir.patch
+++ b/dev-lang/ucblogo/files/ucblogo-5.5-destdir.patch
@@ -41,3 +41,35 @@
+ -cp -f usermanual.pdf $(DESTDIR)$(DOCSDIR)/.
+ -cp -f usermanual.texi $(DESTDIR)$(DOCSDIR)/.
+ -cp -f ../usermanual $(DESTDIR)$(DOCSDIR)/.
+--- emacs/makefile
++++ emacs/makefile
+@@ -40,16 +40,16 @@
+ -rm -f add.user install-logo-mode dot.emacs dot.loops *.elc
+
+ install: all
+- for d in $(EMACSDIR); do [ -d $$d ] || mkdir -p $$d || exit 1; done
+- cp -f logo.* $(EMACSDIR)/.
+- cp -f letrec.* $(EMACSDIR)/.
+- cp -f comint*.* $(EMACSDIR)/.
+- cp -f tutor* $(EMACSDIR)/.
+- cp -f dot.loops $(EMACSDIR)/.
+- cp -f dot.logo $(EMACSDIR)/.logo
+- cp -f dot.LOOPS $(EMACSDIR)/.LOOPS
+- cp -f dot.emacs $(EMACSDIR)/.
+- cp -f README $(EMACSDIR)/.
+- cp -p install-logo-mode $(BINDIR)/.
+- cp -f edfunc.el $(EMACSDIR)/.
+- cp -f check.lg $(EMACSDIR)/.
++ for d in $(EMACSDIR); do [ -d $(DESTDIR)$$d ] || mkdir -p $(DESTDIR)$$d || exit 1; done
++ cp -f logo.* $(DESTDIR)$(EMACSDIR)/.
++ cp -f letrec.* $(DESTDIR)$(EMACSDIR)/.
++ cp -f comint*.* $(DESTDIR)$(EMACSDIR)/.
++ cp -f tutor* $(DESTDIR)$(EMACSDIR)/.
++ cp -f dot.loops $(DESTDIR)$(EMACSDIR)/.
++ cp -f dot.logo $(DESTDIR)$(EMACSDIR)/.logo
++ cp -f dot.LOOPS $(DESTDIR)$(EMACSDIR)/.LOOPS
++ cp -f dot.emacs $(DESTDIR)$(EMACSDIR)/.
++ cp -f README $(DESTDIR)$(EMACSDIR)/.
++ cp -p install-logo-mode $(DESTDIR)$(BINDIR)/.
++ cp -f edfunc.el $(DESTDIR)$(EMACSDIR)/.
++ cp -f check.lg $(DESTDIR)$(EMACSDIR)/.
diff --git a/dev-lang/ucblogo/ucblogo-5.5.ebuild b/dev-lang/ucblogo/ucblogo-5.5.ebuild
index e1a6cdbc0410..0e40ab4efd05 100644
--- a/dev-lang/ucblogo/ucblogo-5.5.ebuild
+++ b/dev-lang/ucblogo/ucblogo-5.5.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/ucblogo/ucblogo-5.5.ebuild,v 1.4 2006/02/25 05:42:34 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/ucblogo/ucblogo-5.5.ebuild,v 1.5 2006/03/24 00:12:51 vapier Exp $
inherit eutils
@@ -22,7 +22,7 @@ src_unpack() {
epatch "${FILESDIR}"/${P}-destdir.patch
epatch "${FILESDIR}"/${P}-fhs.patch
epatch "${FILESDIR}"/${P}-dont-require-tetex.patch
- use emacs || echo 'all install:' > emacs/makefile
+# use emacs || echo 'all install:' > emacs/makefile
}
src_compile() {