summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDoug Goldstein <cardoe@gentoo.org>2006-07-08 22:34:28 +0000
committerDoug Goldstein <cardoe@gentoo.org>2006-07-08 22:34:28 +0000
commita7ed2ccf93297d388726f7910a93b9c277ba5b43 (patch)
treeec1e0968beaa675657a09abcf330e4821282bcda /dev-lang/swig/swig-1.3.27.ebuild
parentremove spider and add media-optical. (diff)
downloadgentoo-2-a7ed2ccf93297d388726f7910a93b9c277ba5b43.tar.gz
gentoo-2-a7ed2ccf93297d388726f7910a93b9c277ba5b43.tar.bz2
gentoo-2-a7ed2ccf93297d388726f7910a93b9c277ba5b43.zip
split USE='tcltk' to 'tcl' & 'tk' per bug #17808. Nuked X USE flag since it was only to find tk from tcltk
(Portage version: 2.1.1_pre2-r6)
Diffstat (limited to 'dev-lang/swig/swig-1.3.27.ebuild')
-rw-r--r--dev-lang/swig/swig-1.3.27.ebuild14
1 files changed, 6 insertions, 8 deletions
diff --git a/dev-lang/swig/swig-1.3.27.ebuild b/dev-lang/swig/swig-1.3.27.ebuild
index 37d4e7a0ee34..ec4b9bbfe669 100644
--- a/dev-lang/swig/swig-1.3.27.ebuild
+++ b/dev-lang/swig/swig-1.3.27.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/swig/swig-1.3.27.ebuild,v 1.4 2006/02/17 16:34:52 chriswhite Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/swig/swig-1.3.27.ebuild,v 1.5 2006/07/08 22:34:28 cardoe Exp $
inherit flag-o-matic mono eutils #48511
@@ -11,7 +11,7 @@ SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
LICENSE="as-is"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc-macos ~ppc64 ~s390 ~sparc ~x86"
-IUSE="doc guile java lua mono ocaml perl php pike python ruby tcltk X"
+IUSE="doc guile java lua mono ocaml perl php pike python ruby tcl tk"
RESTRICT="test"
DEPEND="lua? ( dev-lang/lua )
@@ -24,10 +24,8 @@ DEPEND="lua? ( dev-lang/lua )
python? ( virtual/python )
ocaml? ( dev-lang/ocaml )
ruby? ( virtual/ruby )
- tcltk? (
- dev-lang/tcl
- X? ( dev-lang/tk )
- )"
+ tcl? ( dev-lang/tcl )
+ tk? ( dev-lang/tk )"
src_compile() {
strip-flags
@@ -39,8 +37,8 @@ src_compile() {
fi
econf \
- $(use_with X x) \
- $(use_with tcltk tcl) \
+ $(use_with tk x) \
+ $(use_with tcl) \
$(use_with python python python) \
$(use_with perl perl5 /usr/bin/perl) \
$(use_with java java "${JAVA_HOME}") \