summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2006-02-28 01:58:50 +0000
committerMike Frysinger <vapier@gentoo.org>2006-02-28 01:58:50 +0000
commit61482258b210c43d37c533ab0a509a4341b9add3 (patch)
tree17ef41f7f94e8a87fd648d0d8c6c03885d88e71e /dev-lang/spidermonkey/spidermonkey-1.5-r1.ebuild
parentRemove src_compile. (diff)
downloadgentoo-2-61482258b210c43d37c533ab0a509a4341b9add3.tar.gz
gentoo-2-61482258b210c43d37c533ab0a509a4341b9add3.tar.bz2
gentoo-2-61482258b210c43d37c533ab0a509a4341b9add3.zip
Clean up build system to not suck #123564 by Jeroen Roovers.
(Portage version: 2.1_pre5-r1)
Diffstat (limited to 'dev-lang/spidermonkey/spidermonkey-1.5-r1.ebuild')
-rw-r--r--dev-lang/spidermonkey/spidermonkey-1.5-r1.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-lang/spidermonkey/spidermonkey-1.5-r1.ebuild b/dev-lang/spidermonkey/spidermonkey-1.5-r1.ebuild
new file mode 100644
index 000000000000..fc8a8293a9ce
--- /dev/null
+++ b/dev-lang/spidermonkey/spidermonkey-1.5-r1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/spidermonkey/spidermonkey-1.5-r1.ebuild,v 1.1 2006/02/28 01:58:50 vapier Exp $
+
+inherit eutils toolchain-funcs
+
+MY_P="js-${PV}"
+DESCRIPTION="Stand-alone JavaScript C library"
+HOMEPAGE="http://www.mozilla.org/js/spidermonkey/"
+SRC_URI="ftp://ftp.mozilla.org/pub/mozilla.org/js/${MY_P}.tar.gz"
+
+LICENSE="NPL-1.1"
+SLOT="0"
+KEYWORDS="-*" #~amd64 ~hppa ~ppc ~ppc64 ~x86"
+IUSE=""
+
+S=${WORKDIR}/js/src
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${PN}-1.5-build.patch
+}
+
+src_compile() {
+ tc-export CC LD AR
+ emake -j1 -f Makefile.ref || die
+}
+
+src_install() {
+ make -f Makefile.ref install DESTDIR="${D}" || die
+ dodoc ../jsd/README
+ dohtml README.html
+}