summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAron Griffis <agriffis@gentoo.org>2001-09-09 17:32:24 +0000
committerAron Griffis <agriffis@gentoo.org>2001-09-09 17:32:24 +0000
commit9229f261e7e2242e3ca6902f6f7989e9d46c05c3 (patch)
tree1eb953141e3309cb0f69423760357d57dbbc79fc /dev-lang/ruby
parentDisabled the korean locale to get the package to compile. If anybody needs ko... (diff)
downloadgentoo-2-9229f261e7e2242e3ca6902f6f7989e9d46c05c3.tar.gz
gentoo-2-9229f261e7e2242e3ca6902f6f7989e9d46c05c3.tar.bz2
gentoo-2-9229f261e7e2242e3ca6902f6f7989e9d46c05c3.zip
Updated from 1.6.2 to 1.6.4. Prompted to update by the 1.6.2 source
missing from the URL.
Diffstat (limited to 'dev-lang/ruby')
-rw-r--r--dev-lang/ruby/files/digest-ruby-1.6.41
-rw-r--r--dev-lang/ruby/ruby-1.6.4.ebuild25
2 files changed, 26 insertions, 0 deletions
diff --git a/dev-lang/ruby/files/digest-ruby-1.6.4 b/dev-lang/ruby/files/digest-ruby-1.6.4
new file mode 100644
index 000000000000..8c06d7604eac
--- /dev/null
+++ b/dev-lang/ruby/files/digest-ruby-1.6.4
@@ -0,0 +1 @@
+MD5 428690b893527bdad6a4867489bdadbd ruby-1.6.4.tar.gz
diff --git a/dev-lang/ruby/ruby-1.6.4.ebuild b/dev-lang/ruby/ruby-1.6.4.ebuild
new file mode 100644
index 000000000000..8da2527fe9d3
--- /dev/null
+++ b/dev-lang/ruby/ruby-1.6.4.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Jerry Alexandratos <jerry@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/ruby/ruby-1.6.4.ebuild,v 1.1 2001/09/09 17:32:24 agriffis Exp $
+
+A=${P}.tar.gz
+S=${WORKDIR}/${P}
+DESCRIPTION="An object-oriented scripting language"
+SRC_URI="ftp://ftp.netlab.co.jp/pub/lang/ruby/${A}"
+HOMEPAGE="http://www.ruby-lang.org/"
+
+DEPEND=">=sys-libs/glibc-2.1.3
+ >=sys-libs/gdbm-1.8.0
+ >=sys-libs/readline-4.1
+ >=sys-libs/ncurses-5.2"
+
+src_compile() {
+ ./configure --prefix=/usr --mandir=/usr/share/man --host=${CHOST} || die
+ make || die
+}
+
+src_install () {
+ make DESTDIR=${D} install || die
+ dodoc COPYING* ChangeLog MANIFEST README* ToDo
+}