summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Robbins <drobbins@gentoo.org>2002-04-07 05:52:01 +0000
committerDaniel Robbins <drobbins@gentoo.org>2002-04-07 05:52:01 +0000
commitf569ae12c2da96221665fc6c2eda528c4253ffb2 (patch)
tree18cb00a9a8e66ad76cb269884ee6e9aa5f096fed /dev-lang/python
parentnew version (diff)
downloadgentoo-2-f569ae12c2da96221665fc6c2eda528c4253ffb2.tar.gz
gentoo-2-f569ae12c2da96221665fc6c2eda528c4253ffb2.tar.bz2
gentoo-2-f569ae12c2da96221665fc6c2eda528c4253ffb2.zip
fix for creating build images -- C++ support now disabled in that case.
Diffstat (limited to 'dev-lang/python')
-rw-r--r--dev-lang/python/ChangeLog15
-rw-r--r--dev-lang/python/python-2.2-r4.ebuild10
2 files changed, 13 insertions, 12 deletions
diff --git a/dev-lang/python/ChangeLog b/dev-lang/python/ChangeLog
index ec69cae02fea..3bd59e4e73db 100644
--- a/dev-lang/python/ChangeLog
+++ b/dev-lang/python/ChangeLog
@@ -1,19 +1,14 @@
# ChangeLog for dev-lang/python
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/ChangeLog,v 1.3 2002/03/30 17:00:38 drobbins Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/ChangeLog,v 1.4 2002/04/07 05:52:01 drobbins Exp $
+ 06 Apr 2002; Daniel Robbins <drobbins@gentoo.org> : the 2.2-r4 ebuild now
+ disables C++ support if we are creating a new build image (since we have no
+ C++ in that case).
+
30 Mar 2002; Daniel Robbins <drobbins@gentoo.org> : changed PROVIDE from
virtual/python-2.2 to virtual/python. No rev bump.
-*python-2.2-r5 (17 Mar 2002)
-
- 17 Mar 2002; Daniel Robbins <drobbins@gentoo.org> : new release with a
- /usr/lib/python/site-packages directory; /usr/lib/python2.2/site-packages is
- a symlink pointing to this new directory. This allows new versions of python
- (2.3, etc) to also point to the generic site-packages directory, allowing
- already-installed python modules to be available to all installed versions of
- python.
-
*python-2.2-r4 (1 Feb 2002)
1 Feb 2002; G.Bevin <gbevin@gentoo.org> ChangeLog :
diff --git a/dev-lang/python/python-2.2-r4.ebuild b/dev-lang/python/python-2.2-r4.ebuild
index f27c880b9665..8c55847f00a1 100644
--- a/dev-lang/python/python-2.2-r4.ebuild
+++ b/dev-lang/python/python-2.2-r4.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Maintainer: Daniel Robbins <drobbins@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.2-r4.ebuild,v 1.2 2002/03/31 00:12:34 drobbins Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.2-r4.ebuild,v 1.3 2002/04/07 05:52:01 drobbins Exp $
PYVER="`echo ${PV} | cut -d '.' -f 1,2`"
S=${WORKDIR}/Python-${PV}
@@ -98,11 +98,17 @@ src_compile() {
scmd="$scmd s:#\(resource .*\):\1:;" # Jeremy Hylton's rlimit interface
sed "$scmd" Modules/Setup.dist > Modules/Setup
+ local myopts
+ #if we are creating a new build image, we remove the dependency on g++
+ if [ "`use build`" -a ! "`use bootstrap`" ]
+ then
+ myopts="--with-cxx=no"
+ fi
./configure \
--prefix=/usr \
--without-libdb \
--infodir='${prefix}'/share/info \
- --mandir='${prefix}'/share/man
+ --mandir='${prefix}'/share/man $myopts
assert "Configure failed"
# kill the -DHAVE_CONFIG_H flag
mv Makefile Makefile.orig