summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatti Bickel <mabi@gentoo.org>2010-06-14 17:03:23 +0000
committerMatti Bickel <mabi@gentoo.org>2010-06-14 17:03:23 +0000
commit9e54bb3456249b260f687034e1869a7863b9f240 (patch)
tree42c86983048f983461451d4abff393fcb990ec71 /dev-lang/php
parentFix dependencies. Simplify src_test(). (diff)
downloadgentoo-2-9e54bb3456249b260f687034e1869a7863b9f240.tar.gz
gentoo-2-9e54bb3456249b260f687034e1869a7863b9f240.tar.bz2
gentoo-2-9e54bb3456249b260f687034e1869a7863b9f240.zip
sync with php-overlay
(Portage version: 2.1.8.3/cvs/Linux x86_64)
Diffstat (limited to 'dev-lang/php')
-rw-r--r--dev-lang/php/ChangeLog7
-rw-r--r--dev-lang/php/files/eblits/src_install-v1.eblit15
-rw-r--r--dev-lang/php/php-5.3.2.ebuild6
3 files changed, 23 insertions, 5 deletions
diff --git a/dev-lang/php/ChangeLog b/dev-lang/php/ChangeLog
index e8e76d060931..ddc9191c4501 100644
--- a/dev-lang/php/ChangeLog
+++ b/dev-lang/php/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-lang/php
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/php/ChangeLog,v 1.384 2010/06/12 22:05:54 mabi Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/php/ChangeLog,v 1.385 2010/06/14 17:03:23 mabi Exp $
+
+ 14 Jun 2010; <mabi@gentoo.org> files/eblits/src_install-v1.eblit,
+ php-5.3.2.ebuild:
+ sync with overlay: repair apache2 USE dep, cli SAPI on by default (bug
+ #310383), show all SAPIs in php-config (bug #278439)
12 Jun 2010; <mabi@gentoo.org> php-5.3.2.ebuild, metadata.xml:
USE="mbstring" already covered by USE="unicode"; set USE-defaults to match
diff --git a/dev-lang/php/files/eblits/src_install-v1.eblit b/dev-lang/php/files/eblits/src_install-v1.eblit
index ce0ca97e4902..d3312579f171 100644
--- a/dev-lang/php/files/eblits/src_install-v1.eblit
+++ b/dev-lang/php/files/eblits/src_install-v1.eblit
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/php/files/eblits/src_install-v1.eblit,v 1.2 2010/06/09 16:11:28 mabi Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/php/files/eblits/src_install-v1.eblit,v 1.3 2010/06/14 17:03:22 mabi Exp $
eblit-php-src_install() {
# Makefile forgets to create this before trying to write to it...
@@ -26,6 +26,7 @@ eblit-php-src_install() {
keepdir /usr/share/php${PHP_MV}
local sapi="", file=""
+ local sapi_list=""
for sapi in ${SAPIS}; do
if use "${sapi}" ; then
@@ -46,6 +47,14 @@ eblit-php-src_install() {
fi
php_install_ini "${sapi}"
+
+ # construct correct SAPI string for php-config
+ # thanks to ferringb for the bash voodoo
+ if [[ "${sapi}" == "apache2" ]]; then
+ sapi_list="${sapi_list:+${sapi_list} }apache2handler"
+ else
+ sapi_list="${sapi_list:+${sapi_list} }${sapi}"
+ fi
fi
done
@@ -54,6 +63,10 @@ eblit-php-src_install() {
"20php${PHP_MV}"
sed -e "s|/lib/|/$(get_libdir)/|g" -i \
"${D}/etc/env.d/20php${PHP_MV}"
+
+ # set php-config variable correctly (bug #278439)
+ sed -e "s:^\(php_sapis=\)\".*\"$:\1\"${sapi_list}\":" -i \
+ "${D}/usr/$(get_libdir)/php5/bin/php-config"
}
php_install_ini() {
diff --git a/dev-lang/php/php-5.3.2.ebuild b/dev-lang/php/php-5.3.2.ebuild
index 05700f7e89b1..8c9fa0122deb 100644
--- a/dev-lang/php/php-5.3.2.ebuild
+++ b/dev-lang/php/php-5.3.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/php/php-5.3.2.ebuild,v 1.7 2010/06/12 22:05:54 mabi Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/php/php-5.3.2.ebuild,v 1.8 2010/06/14 17:03:23 mabi Exp $
EAPI=2
@@ -76,7 +76,7 @@ IUSE="kolab"
# SAPIs and SAPI-specific USE flags:
IUSE="${IUSE}
- ${SAPIS}
+ +${SAPIS}
concurrentmodphp threads"
IUSE="${IUSE} adabas bcmath berkdb birdstep bzip2 calendar cdb cjk
@@ -94,7 +94,7 @@ IUSE="${IUSE} adabas bcmath berkdb birdstep bzip2 calendar cdb cjk
DEPEND="app-admin/php-toolkit
>=dev-libs/libpcre-7.9[unicode]
adabas? ( >=dev-db/unixODBC-1.8.13 )
- apache2? ( !threads? ( www-servers/apache[-threads] ) )
+ apache2? ( www-servers/apache[threads=] )
berkdb? ( =sys-libs/db-4* )
birdstep? ( >=dev-db/unixODBC-1.8.13 )
bzip2? ( app-arch/bzip2 )