summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2012-07-19 06:05:32 +0000
committerPatrick Lauer <patrick@gentoo.org>2012-07-19 06:05:32 +0000
commita14e2980c3ca50ade18373e6dd38ffc77eb54e39 (patch)
tree8bb99a39ab621929daa65f35d44f6095b44bc653 /dev-lang/parrot
parentVersion bump for beta channel release. (diff)
downloadgentoo-2-a14e2980c3ca50ade18373e6dd38ffc77eb54e39.tar.gz
gentoo-2-a14e2980c3ca50ade18373e6dd38ffc77eb54e39.tar.bz2
gentoo-2-a14e2980c3ca50ade18373e6dd38ffc77eb54e39.zip
Bump, clean up old
(Portage version: 2.2.0_alpha120/cvs/Linux x86_64)
Diffstat (limited to 'dev-lang/parrot')
-rw-r--r--dev-lang/parrot/ChangeLog10
-rw-r--r--dev-lang/parrot/parrot-4.0.0.ebuild79
-rw-r--r--dev-lang/parrot/parrot-4.1.0.ebuild86
-rw-r--r--dev-lang/parrot/parrot-4.2.0.ebuild86
-rw-r--r--dev-lang/parrot/parrot-4.6.0.ebuild (renamed from dev-lang/parrot/parrot-4.3.0.ebuild)5
5 files changed, 9 insertions, 257 deletions
diff --git a/dev-lang/parrot/ChangeLog b/dev-lang/parrot/ChangeLog
index bd4ea4f6b220..e400f526494f 100644
--- a/dev-lang/parrot/ChangeLog
+++ b/dev-lang/parrot/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-lang/parrot
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/parrot/ChangeLog,v 1.55 2012/06/20 08:10:20 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/parrot/ChangeLog,v 1.56 2012/07/19 06:05:32 patrick Exp $
+
+*parrot-4.6.0 (19 Jul 2012)
+
+ 19 Jul 2012; Patrick Lauer <patrick@gentoo.org> +parrot-4.6.0.ebuild,
+ -parrot-4.0.0.ebuild, -parrot-4.1.0.ebuild, -parrot-4.2.0.ebuild,
+ -parrot-4.3.0.ebuild:
+ Bump, clean up old
*parrot-4.5.0 (20 Jun 2012)
@@ -256,4 +263,3 @@
Long overdue, the ebuild for parrot. Original version submitted in bug 74405
by Adrian Lambeck <adrian.lambeck@basicsedv.de>, cleaned up for a better
install.
-
diff --git a/dev-lang/parrot/parrot-4.0.0.ebuild b/dev-lang/parrot/parrot-4.0.0.ebuild
deleted file mode 100644
index 3c304c9c9f5f..000000000000
--- a/dev-lang/parrot/parrot-4.0.0.ebuild
+++ /dev/null
@@ -1,79 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/parrot/parrot-4.0.0.ebuild,v 1.1 2012/02/16 06:44:06 patrick Exp $
-
-EAPI=3
-
-inherit eutils multilib
-
-DESCRIPTION="Virtual machine designed to efficiently compile and execute bytecode for dynamic languages"
-HOMEPAGE="http://www.parrot.org/"
-#SRC_URI="ftp://ftp.parrot.org/pub/parrot/releases/supported/${PV}/${P}.tar.bz2"
-SRC_URI="ftp://ftp.parrot.org/pub/parrot/releases/stable/${PV}/${P}.tar.bz2"
-
-LICENSE="Artistic-2"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
-IUSE="opengl nls doc examples gdbm gmp ssl +unicode pcre"
-
-RDEPEND="sys-libs/readline
- opengl? ( media-libs/freeglut )
- nls? ( sys-devel/gettext )
- unicode? ( >=dev-libs/icu-2.6 )
- gdbm? ( >=sys-libs/gdbm-1.8.3-r1 )
- gmp? ( >=dev-libs/gmp-4.1.4 )
- ssl? ( dev-libs/openssl )
- pcre? ( dev-libs/libpcre )"
-
-DEPEND="dev-lang/perl[doc?]
- ${RDEPEND}"
-
-src_configure() {
- myconf="--disable-rpath"
- use unicode || myconf+=" --without-icu"
- use ssl || myconf+=" --without-crypto"
- use gdbm || myconf+=" --without-gdbm"
- use nls || myconf+=" --without-gettext"
- use gmp || myconf+=" --without-gmp"
- use opengl || myconf+=" --without-opengl"
- use pcre || myconf+=" --without-pcre"
-
- perl Configure.pl \
- --ccflags="${CFLAGS}" \
- --linkflags="${LDFLAGS}" \
- --prefix="${EPREFIX}"/usr \
- --libdir="${EPREFIX}"/usr/$(get_libdir) \
- --mandir="${EPREFIX}"/usr/share/man \
- --sysconfdir="${EPREFIX}"/etc \
- --sharedstatedir="${EPREFIX}"/var/lib/parrot \
- $myconf || die
-}
-
-src_compile() {
- export LD_LIBRARY_PATH=${LD_LIBRARY_PATH:+$LD_LIBRARY_PATH:}"${S}"/blib/lib
- # occasionally dies in parallel make
- emake -j1 || die
- if use doc ; then
- emake -j1 html || die
- fi
-}
-
-src_test() {
- emake -j1 test || die
-}
-
-src_install() {
- emake -j1 install-dev DESTDIR="${D}" DOC_DIR="${EPREFIX}/usr/share/doc/${PF}" || die
- dodoc CREDITS DONORS.pod PBC_COMPAT PLATFORMS RESPONSIBLE_PARTIES TODO || die
- if use examples; then
- insinto "/usr/share/doc/${PF}/examples"
- doins -r examples/* || die
- fi
- if use doc; then
- insinto "/usr/share/doc/${PF}/editor"
- doins -r editor || die
- cd docs/html
- dohtml -r developer.html DONORS.pod.html index.html ops.html parrotbug.html pdds.html \
- pmc.html tools.html docs src tools || die
- fi
-}
diff --git a/dev-lang/parrot/parrot-4.1.0.ebuild b/dev-lang/parrot/parrot-4.1.0.ebuild
deleted file mode 100644
index bdcf5dada6a4..000000000000
--- a/dev-lang/parrot/parrot-4.1.0.ebuild
+++ /dev/null
@@ -1,86 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/parrot/parrot-4.1.0.ebuild,v 1.1 2012/03/08 04:18:42 patrick Exp $
-
-EAPI=3
-
-# There's multiple small issues at the moment, so ...
-RESTRICT="test"
-
-inherit eutils multilib
-
-DESCRIPTION="Virtual machine designed to efficiently compile and execute bytecode for dynamic languages"
-HOMEPAGE="http://www.parrot.org/"
-SRC_URI="ftp://ftp.parrot.org/pub/parrot/releases/devel/${PV}/${P}.tar.bz2"
-
-LICENSE="Artistic-2"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
-IUSE="opengl nls doc examples gdbm gmp ssl +unicode pcre"
-
-RDEPEND="sys-libs/readline
- opengl? ( media-libs/freeglut )
- nls? ( sys-devel/gettext )
- unicode? ( >=dev-libs/icu-2.6 )
- gdbm? ( >=sys-libs/gdbm-1.8.3-r1 )
- gmp? ( >=dev-libs/gmp-4.1.4 )
- ssl? ( dev-libs/openssl )
- pcre? ( dev-libs/libpcre )"
-
-DEPEND="dev-lang/perl[doc?]
- ${RDEPEND}"
-
-src_prepare() {
- # Fix for #404195 - pcre detection is wonky
- sed -i 's:libpcre.so.0:libpcre.so.1:' runtime/parrot/library/pcre.pir || die "Couldn't fix pcre location"
-}
-
-src_configure() {
- myconf="--disable-rpath"
- use unicode || myconf+=" --without-icu"
- use ssl || myconf+=" --without-crypto"
- use gdbm || myconf+=" --without-gdbm"
- use nls || myconf+=" --without-gettext"
- use gmp || myconf+=" --without-gmp"
- use opengl || myconf+=" --without-opengl"
- use pcre || myconf+=" --without-pcre"
-
- perl Configure.pl \
- --ccflags="${CFLAGS}" \
- --linkflags="${LDFLAGS}" \
- --prefix="${EPREFIX}"/usr \
- --libdir="${EPREFIX}"/usr/$(get_libdir) \
- --mandir="${EPREFIX}"/usr/share/man \
- --sysconfdir="${EPREFIX}"/etc \
- --sharedstatedir="${EPREFIX}"/var/lib/parrot \
- $myconf || die
-}
-
-src_compile() {
- export LD_LIBRARY_PATH=${LD_LIBRARY_PATH:+$LD_LIBRARY_PATH:}"${S}"/blib/lib
- # occasionally dies in parallel make
- emake -j1 || die
- if use doc ; then
- emake -j1 html || die
- fi
-}
-
-src_test() {
- emake -j1 test || die
-}
-
-src_install() {
- emake -j1 install-dev DESTDIR="${D}" DOC_DIR="${EPREFIX}/usr/share/doc/${PF}" || die
- dodoc CREDITS DONORS.pod PBC_COMPAT PLATFORMS RESPONSIBLE_PARTIES TODO || die
- if use examples; then
- insinto "/usr/share/doc/${PF}/examples"
- doins -r examples/* || die
- fi
- if use doc; then
- insinto "/usr/share/doc/${PF}/editor"
- doins -r editor || die
- cd docs/html
- dohtml -r developer.html DONORS.pod.html index.html ops.html parrotbug.html pdds.html \
- pmc.html tools.html docs src tools || die
- fi
-}
diff --git a/dev-lang/parrot/parrot-4.2.0.ebuild b/dev-lang/parrot/parrot-4.2.0.ebuild
deleted file mode 100644
index 79b8f7257118..000000000000
--- a/dev-lang/parrot/parrot-4.2.0.ebuild
+++ /dev/null
@@ -1,86 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/parrot/parrot-4.2.0.ebuild,v 1.1 2012/03/21 15:06:36 patrick Exp $
-
-EAPI=3
-
-# There's multiple small issues at the moment, so ...
-RESTRICT="test"
-
-inherit eutils multilib
-
-DESCRIPTION="Virtual machine designed to efficiently compile and execute bytecode for dynamic languages"
-HOMEPAGE="http://www.parrot.org/"
-SRC_URI="ftp://ftp.parrot.org/pub/parrot/releases/devel/${PV}/${P}.tar.bz2"
-
-LICENSE="Artistic-2"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
-IUSE="opengl nls doc examples gdbm gmp ssl +unicode pcre"
-
-RDEPEND="sys-libs/readline
- opengl? ( media-libs/freeglut )
- nls? ( sys-devel/gettext )
- unicode? ( >=dev-libs/icu-2.6 )
- gdbm? ( >=sys-libs/gdbm-1.8.3-r1 )
- gmp? ( >=dev-libs/gmp-4.1.4 )
- ssl? ( dev-libs/openssl )
- pcre? ( dev-libs/libpcre )"
-
-DEPEND="dev-lang/perl[doc?]
- ${RDEPEND}"
-
-src_prepare() {
- # Fix for #404195 - pcre detection is wonky
- sed -i 's:libpcre.so.0:libpcre.so.1:' runtime/parrot/library/pcre.pir || die "Couldn't fix pcre location"
-}
-
-src_configure() {
- myconf="--disable-rpath"
- use unicode || myconf+=" --without-icu"
- use ssl || myconf+=" --without-crypto"
- use gdbm || myconf+=" --without-gdbm"
- use nls || myconf+=" --without-gettext"
- use gmp || myconf+=" --without-gmp"
- use opengl || myconf+=" --without-opengl"
- use pcre || myconf+=" --without-pcre"
-
- perl Configure.pl \
- --ccflags="${CFLAGS}" \
- --linkflags="${LDFLAGS}" \
- --prefix="${EPREFIX}"/usr \
- --libdir="${EPREFIX}"/usr/$(get_libdir) \
- --mandir="${EPREFIX}"/usr/share/man \
- --sysconfdir="${EPREFIX}"/etc \
- --sharedstatedir="${EPREFIX}"/var/lib/parrot \
- $myconf || die
-}
-
-src_compile() {
- export LD_LIBRARY_PATH=${LD_LIBRARY_PATH:+$LD_LIBRARY_PATH:}"${S}"/blib/lib
- # occasionally dies in parallel make
- emake -j1 || die
- if use doc ; then
- emake -j1 html || die
- fi
-}
-
-src_test() {
- emake -j1 test || die
-}
-
-src_install() {
- emake -j1 install-dev DESTDIR="${D}" DOC_DIR="${EPREFIX}/usr/share/doc/${PF}" || die
- dodoc CREDITS DONORS.pod PBC_COMPAT PLATFORMS RESPONSIBLE_PARTIES TODO || die
- if use examples; then
- insinto "/usr/share/doc/${PF}/examples"
- doins -r examples/* || die
- fi
- if use doc; then
- insinto "/usr/share/doc/${PF}/editor"
- doins -r editor || die
- cd docs/html
- dohtml -r developer.html DONORS.pod.html index.html ops.html parrotbug.html pdds.html \
- pmc.html tools.html docs src tools || die
- fi
-}
diff --git a/dev-lang/parrot/parrot-4.3.0.ebuild b/dev-lang/parrot/parrot-4.6.0.ebuild
index 095d6f9ed6b6..610212a8b402 100644
--- a/dev-lang/parrot/parrot-4.3.0.ebuild
+++ b/dev-lang/parrot/parrot-4.6.0.ebuild
@@ -1,12 +1,9 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/parrot/parrot-4.3.0.ebuild,v 1.1 2012/04/20 08:52:36 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/parrot/parrot-4.6.0.ebuild,v 1.1 2012/07/19 06:05:32 patrick Exp $
EAPI=3
-# There's multiple small issues at the moment, so ...
-RESTRICT="test"
-
inherit eutils multilib
DESCRIPTION="Virtual machine designed to efficiently compile and execute bytecode for dynamic languages"