summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2014-01-07 05:28:34 +0000
committerPatrick Lauer <patrick@gentoo.org>2014-01-07 05:28:34 +0000
commitf36cc2adcc24d773008dbc9826342102d47c8e3e (patch)
tree03a552a7a7fbe3fd191416371da867279ce96102 /dev-lang/opendylan-bin
parentFixing -9999 ebuild for 2013.2 release (diff)
downloadgentoo-2-f36cc2adcc24d773008dbc9826342102d47c8e3e.tar.gz
gentoo-2-f36cc2adcc24d773008dbc9826342102d47c8e3e.tar.bz2
gentoo-2-f36cc2adcc24d773008dbc9826342102d47c8e3e.zip
Bump
(Portage version: 2.2.8/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'dev-lang/opendylan-bin')
-rw-r--r--dev-lang/opendylan-bin/ChangeLog9
-rw-r--r--dev-lang/opendylan-bin/opendylan-bin-2013.2.ebuild33
2 files changed, 40 insertions, 2 deletions
diff --git a/dev-lang/opendylan-bin/ChangeLog b/dev-lang/opendylan-bin/ChangeLog
index f45e994f9349..39651dd3e087 100644
--- a/dev-lang/opendylan-bin/ChangeLog
+++ b/dev-lang/opendylan-bin/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-lang/opendylan-bin
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/opendylan-bin/ChangeLog,v 1.6 2013/07/12 03:00:14 patrick Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/opendylan-bin/ChangeLog,v 1.7 2014/01/07 05:28:34 patrick Exp $
+
+*opendylan-bin-2013.2 (07 Jan 2014)
+
+ 07 Jan 2014; Patrick Lauer <patrick@gentoo.org> +opendylan-bin-2013.2.ebuild:
+ Bump
12 Jul 2013; Patrick Lauer <patrick@gentoo.org> opendylan-bin-2012.1.ebuild,
opendylan-bin-2013.1.ebuild:
diff --git a/dev-lang/opendylan-bin/opendylan-bin-2013.2.ebuild b/dev-lang/opendylan-bin/opendylan-bin-2013.2.ebuild
new file mode 100644
index 000000000000..ab6a61ff2973
--- /dev/null
+++ b/dev-lang/opendylan-bin/opendylan-bin-2013.2.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/opendylan-bin/opendylan-bin-2013.2.ebuild,v 1.1 2014/01/07 05:28:34 patrick Exp $
+EAPI=4
+
+DESCRIPTION="OpenDylan language runtime environment (prebuilt)"
+
+MY_PN="opendylan"
+MY_P="${MY_PN}-${PV}"
+HOMEPAGE="http://opendylan.org"
+SRC_URI="amd64? ( http://opendylan.org/downloads/${MY_PN}/${PV}/${MY_P}-x86_64-linux.tar.bz2 )
+ x86? ( http://opendylan.org/downloads/${MY_PN}/${PV}/${MY_P}-x86-linux.tar.bz2 )"
+LICENSE="Opendylan"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+
+IUSE=""
+
+DEPEND="dev-libs/boehm-gc"
+RDEPEND="${DEPEND}"
+
+S=${WORKDIR}/${MY_P}
+
+src_configure() { :; }
+src_compile() { :; }
+
+src_install() {
+ # this is a precompiled tarball
+ mkdir -p "${D}/opt/${MY_P}"
+ cp -ar "${S}"/* "${D}/opt/${MY_P}" || die "Failed to copy stuff"
+ mkdir -p "${D}/etc/env.d/opendylan"
+ echo "export PATH=/opt/opendylan-2013.2/bin:\$PATH" > "${D}/etc/env.d/opendylan/99-opendylan-bin" || die "Failed to add env settings"
+}