summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthieu Sozeau <mattam@gentoo.org>2004-08-08 09:06:00 +0000
committerMatthieu Sozeau <mattam@gentoo.org>2004-08-08 09:06:00 +0000
commita11f390fe7ef07acefbe74b21aed9fa731917420 (patch)
treefe7897eb9b9465d034e0a0624328af0f3b46901c /dev-lang/ocaml/ocaml-3.07-r1.ebuild
parentocaml latex use flag (diff)
downloadgentoo-2-a11f390fe7ef07acefbe74b21aed9fa731917420.tar.gz
gentoo-2-a11f390fe7ef07acefbe74b21aed9fa731917420.tar.bz2
gentoo-2-a11f390fe7ef07acefbe74b21aed9fa731917420.zip
Fix bug #50028.
Diffstat (limited to 'dev-lang/ocaml/ocaml-3.07-r1.ebuild')
-rw-r--r--dev-lang/ocaml/ocaml-3.07-r1.ebuild9
1 files changed, 7 insertions, 2 deletions
diff --git a/dev-lang/ocaml/ocaml-3.07-r1.ebuild b/dev-lang/ocaml/ocaml-3.07-r1.ebuild
index dd699dcffc86..8cfb36853926 100644
--- a/dev-lang/ocaml/ocaml-3.07-r1.ebuild
+++ b/dev-lang/ocaml/ocaml-3.07-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/ocaml/ocaml-3.07-r1.ebuild,v 1.19 2004/07/27 13:14:34 alexander Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/ocaml/ocaml-3.07-r1.ebuild,v 1.20 2004/08/08 09:06:00 mattam Exp $
inherit flag-o-matic eutils
@@ -13,7 +13,7 @@ SRC_URI="http://caml.inria.fr/distrib/${P}/${P}.tar.gz
LICENSE="QPL-1.0 LGPL-2"
SLOT="0"
KEYWORDS="x86 ~sparc ~ppc alpha ~ia64 ~amd64 hppa ~macos"
-IUSE="tcltk"
+IUSE="tcltk latex"
DEPEND="virtual/libc
tcltk? ( >=dev-lang/tk-3.3.3 )"
@@ -81,6 +81,11 @@ pkg_postinst() {
ranlib /usr/lib/ocaml/stdlib.a
ranlib /usr/lib/ocaml/libasmrun.a
+
+ if use latex; then
+ echo "TEXINPUTS=/usr/lib/ocaml/ocamldoc:" > /etc/env.d/99ocamldoc
+ fi
+
echo
einfo "OCaml is not binary compatible from version to version,"
einfo "so you (may) need to rebuild all packages depending on it that"