summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthieu Sozeau <mattam@gentoo.org>2004-07-06 20:40:57 +0000
committerMatthieu Sozeau <mattam@gentoo.org>2004-07-06 20:40:57 +0000
commit4533f1b09546448d5766eb88249ddb0dfe6135f5 (patch)
tree92c7e82d9eab9f2f4213dc417235ee4792f8c328 /dev-lang/ocaml/ocaml-3.07-r1.ebuild
parentAdd fileselect dialog patch from Ximian/Suse. (Manifest recommit) (diff)
downloadgentoo-2-4533f1b09546448d5766eb88249ddb0dfe6135f5.tar.gz
gentoo-2-4533f1b09546448d5766eb88249ddb0dfe6135f5.tar.bz2
gentoo-2-4533f1b09546448d5766eb88249ddb0dfe6135f5.zip
Move 3.07 to stable on x86, and add script to ease the 3.06 -> 3.07 transition
Diffstat (limited to 'dev-lang/ocaml/ocaml-3.07-r1.ebuild')
-rw-r--r--dev-lang/ocaml/ocaml-3.07-r1.ebuild15
1 files changed, 13 insertions, 2 deletions
diff --git a/dev-lang/ocaml/ocaml-3.07-r1.ebuild b/dev-lang/ocaml/ocaml-3.07-r1.ebuild
index eac8f4c036ab..dfe28676a3a9 100644
--- a/dev-lang/ocaml/ocaml-3.07-r1.ebuild
+++ b/dev-lang/ocaml/ocaml-3.07-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/ocaml/ocaml-3.07-r1.ebuild,v 1.12 2004/07/02 04:29:48 eradicator Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/ocaml/ocaml-3.07-r1.ebuild,v 1.13 2004/07/06 20:40:57 mattam Exp $
inherit flag-o-matic eutils
@@ -12,7 +12,7 @@ SRC_URI="http://caml.inria.fr/distrib/${P}/${P}.tar.gz
LICENSE="QPL-1.0 LGPL-2"
SLOT="0"
-KEYWORDS="~x86 ~sparc ~ppc alpha ~ia64 -amd64 hppa"
+KEYWORDS="x86 ~sparc ~ppc alpha ~ia64 -amd64 hppa"
IUSE="tcltk"
DEPEND="virtual/libc
@@ -63,3 +63,14 @@ src_install() {
# documentation
dodoc Changes INSTALL LICENSE README Upgrading
}
+
+pkg_postinst() {
+ echo
+ einfo "OCaml is not binary compatible from version to version,"
+ einfo "so you (may) need to rebuild all packages depending on it that"
+ einfo "are actually installed on your system."
+ einfo "To do so, you can run: "
+ einfo "sh ${FILESDIR}/ocaml-rebuild.sh [emerge options]"
+ einfo "Which will call emerge on all old packages with the given options"
+ echo
+} \ No newline at end of file