summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2008-05-08 22:01:50 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2008-05-08 22:01:50 +0000
commit0cd208170024493b328464ea21777d5c200fd314 (patch)
tree911e2d02e1ae6bd11fdaef158d11e4eb2a31a894 /dev-lang/nasm
parentnever try to run nasmw (diff)
downloadgentoo-2-0cd208170024493b328464ea21777d5c200fd314.tar.gz
gentoo-2-0cd208170024493b328464ea21777d5c200fd314.tar.bz2
gentoo-2-0cd208170024493b328464ea21777d5c200fd314.zip
old
(Portage version: 2.1.4.4)
Diffstat (limited to 'dev-lang/nasm')
-rw-r--r--dev-lang/nasm/nasm-0.98.39-r1.ebuild65
-rw-r--r--dev-lang/nasm/nasm-2.01.ebuild61
2 files changed, 0 insertions, 126 deletions
diff --git a/dev-lang/nasm/nasm-0.98.39-r1.ebuild b/dev-lang/nasm/nasm-0.98.39-r1.ebuild
deleted file mode 100644
index 62d9349c8e89..000000000000
--- a/dev-lang/nasm/nasm-0.98.39-r1.ebuild
+++ /dev/null
@@ -1,65 +0,0 @@
-# Copyright 1999-2005 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/nasm/nasm-0.98.39-r1.ebuild,v 1.3 2005/12/26 08:02:31 mr_bones_ Exp $
-
-inherit toolchain-funcs
-
-DESCRIPTION="groovy little assembler"
-HOMEPAGE="http://nasm.sourceforge.net/"
-SRC_URI="mirror://sourceforge/nasm/${P}.tar.bz2"
-
-LICENSE="LGPL-2.1"
-SLOT="0"
-KEYWORDS="-* amd64 x86"
-IUSE="doc build"
-
-DEPEND="!build? ( dev-lang/perl )
- doc? ( virtual/ghostscript sys-apps/texinfo )"
-RDEPEND=""
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
- if [ "$(gcc-major-version)" -eq "2" ] ; then
- sed -i \
- -e 's:-std=c99::g' \
- configure \
- || die "sed failed"
- fi
- #security fix for bug #92991
- sed -i \
- -e '/vsprintf/c\ vsnprintf(buffer, sizeof(buffer), format, ap);
- ' output/outieee.c \
- || die "sed failed"
-}
-
-src_compile() {
- econf || die
-
- if use build; then
- emake nasm || die "emake failed"
- else
- emake all || die "emake failed"
- emake rdf || die "emake failed"
- if use doc ; then
- emake doc || die "emake failed"
- fi
- fi
-}
-
-src_install() {
- if use build; then
- dobin nasm || die "dobin failed"
- else
- dobin nasm ndisasm rdoff/{ldrdf,rdf2bin,rdf2ihx,rdfdump,rdflib,rdx} \
- || die "dobin failed"
- dosym /usr/bin/rdf2bin /usr/bin/rdf2com
- doman nasm.1 ndisasm.1
- dodoc AUTHORS CHANGES ChangeLog README TODO
- if use doc; then
- doinfo doc/info/*
- dohtml doc/html/*
- dodoc doc/nasmdoc.*
- fi
- fi
-}
diff --git a/dev-lang/nasm/nasm-2.01.ebuild b/dev-lang/nasm/nasm-2.01.ebuild
deleted file mode 100644
index 3756aeefd1d0..000000000000
--- a/dev-lang/nasm/nasm-2.01.ebuild
+++ /dev/null
@@ -1,61 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/nasm/nasm-2.01.ebuild,v 1.1 2008/01/21 20:00:56 mr_bones_ Exp $
-
-inherit eutils toolchain-funcs flag-o-matic
-
-DESCRIPTION="groovy little assembler"
-HOMEPAGE="http://nasm.sourceforge.net/"
-SRC_URI="mirror://sourceforge/nasm/${P}.tar.bz2"
-
-LICENSE="LGPL-2.1"
-SLOT="0"
-KEYWORDS="-* ~amd64 ~x86 ~x86-fbsd"
-IUSE="doc build"
-
-DEPEND="!build? ( dev-lang/perl )
- doc? ( virtual/ghostscript sys-apps/texinfo )"
-RDEPEND=""
-
-src_unpack() {
- unpack ${A}
- if [ "$(gcc-major-version)" -eq "2" ] ; then
- cd "${S}"
- sed -i \
- -e 's:-std=c99::g' \
- configure \
- || die "sed failed"
- fi
-}
-
-src_compile() {
- strip-flags
- econf || die
-
- if use build; then
- emake nasm || die "emake failed"
- else
- emake all || die "emake failed"
- emake rdf || die "emake failed"
- if use doc ; then
- emake doc || die "emake failed"
- fi
- fi
-}
-
-src_install() {
- if use build; then
- dobin nasm || die "dobin failed"
- else
- dobin nasm ndisasm rdoff/{ldrdf,rdf2bin,rdf2ihx,rdfdump,rdflib,rdx} \
- || die "dobin failed"
- dosym /usr/bin/rdf2bin /usr/bin/rdf2com
- doman nasm.1 ndisasm.1
- dodoc AUTHORS CHANGES ChangeLog README TODO
- if use doc; then
- doinfo doc/info/*
- dohtml doc/html/*
- dodoc doc/nasmdoc.*
- fi
- fi
-}