summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlistair Bush <ali_bush@gentoo.org>2010-12-18 10:17:27 +0000
committerAlistair Bush <ali_bush@gentoo.org>2010-12-18 10:17:27 +0000
commit91b75d8f790054a2bd810ca44e36b76b2e5c5ead (patch)
treec7d8dc1c9832ebeb7eee74cca433b7d13890cd6d /dev-lang/mono
parentfix wrong email address (diff)
downloadgentoo-2-91b75d8f790054a2bd810ca44e36b76b2e5c5ead.tar.gz
gentoo-2-91b75d8f790054a2bd810ca44e36b76b2e5c5ead.tar.bz2
gentoo-2-91b75d8f790054a2bd810ca44e36b76b2e5c5ead.zip
Cleanup -9999 ebuild. fix build.
(Portage version: 2.1.9.25/cvs/Linux x86_64)
Diffstat (limited to 'dev-lang/mono')
-rw-r--r--dev-lang/mono/mono-9999.ebuild23
1 files changed, 14 insertions, 9 deletions
diff --git a/dev-lang/mono/mono-9999.ebuild b/dev-lang/mono/mono-9999.ebuild
index f26845939f1f..90ce910352b2 100644
--- a/dev-lang/mono/mono-9999.ebuild
+++ b/dev-lang/mono/mono-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/mono/mono-9999.ebuild,v 1.4 2010/10/05 21:22:03 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/mono/mono-9999.ebuild,v 1.5 2010/12/18 10:17:27 ali_bush Exp $
EAPI=2
@@ -12,7 +12,7 @@ HOMEPAGE="http://www.go-mono.com"
LICENSE="MIT LGPL-2.1 GPL-2 BSD-4 NPL-1.1 Ms-PL GPL-2-with-linking-exception IDPL"
SLOT="0"
KEYWORDS=""
-IUSE="hardened xen moonlight minimal"
+IUSE="hardened xen minimal"
#Bash requirement is for += operator
COMMONDEPEND="!<dev-dotnet/pnet-0.6.12
@@ -89,20 +89,25 @@ src_configure() {
#Remove this at your own peril. Mono will barf in unexpected ways.
append-flags -fno-strict-aliasing
- #NOTE: We need the static libs for now so mono-debugger works.
- #See http://bugs.gentoo.org/show_bug.cgi?id=256264 for details
-
- #--with-glib=system configure: error: --with-glib=system is no longer supported as of Mono 2.8
- #--static_mono=yes (default anyway)
+ # NOTE: We need the static libs for now so mono-debugger works.
+ # See http://bugs.gentoo.org/show_bug.cgi?id=256264 for details
+ #
+ # --without-moonlight since www-plugins/moonlight is not the only one
+ # using mono: https://bugzilla.novell.com/show_bug.cgi?id=641005#c3
+ #
+ # --with-profile4 needs to be always enabled since it's used by default
+ # and, otherwise, problems like bug #340641 appear.
go-mono_src_configure \
+ --enable-static \
--disable-quiet-build \
- $(use_with moonlight) \
+ --without-moonlight \
--with-libgdiplus=$(use minimal && printf "no" || printf "installed" ) \
$(use_with xen xen_opt) \
--without-ikvm-native \
--with-jit \
- --disable-dtrace
+ --disable-dtrace \
+ --with-profile4
}
src_test() {