summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2010-10-15 20:25:57 +0000
committerPacho Ramos <pacho@gentoo.org>2010-10-15 20:25:57 +0000
commit1d55a80346ab33dd00ad861d9eaf23eaf22ced58 (patch)
tree7a08dc14cc68d657aa26dd48020b3aeba556b1ce /dev-lang/mono
parentVersion bump #341129 by Marco Paolone. (diff)
downloadgentoo-2-1d55a80346ab33dd00ad861d9eaf23eaf22ced58.tar.gz
gentoo-2-1d55a80346ab33dd00ad861d9eaf23eaf22ced58.tar.bz2
gentoo-2-1d55a80346ab33dd00ad861d9eaf23eaf22ced58.zip
Fix bugs 340365 and 340641, remove old testing.
(Portage version: 2.1.9.14/cvs/Linux x86_64)
Diffstat (limited to 'dev-lang/mono')
-rw-r--r--dev-lang/mono/ChangeLog14
-rw-r--r--dev-lang/mono/mono-2.8-r1.ebuild (renamed from dev-lang/mono/mono-2.8.ebuild)20
2 files changed, 25 insertions, 9 deletions
diff --git a/dev-lang/mono/ChangeLog b/dev-lang/mono/ChangeLog
index ba630469159c..05206c9fce22 100644
--- a/dev-lang/mono/ChangeLog
+++ b/dev-lang/mono/ChangeLog
@@ -1,6 +1,18 @@
# ChangeLog for dev-lang/mono
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/mono/ChangeLog,v 1.201 2010/10/08 08:29:02 ali_bush Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/mono/ChangeLog,v 1.202 2010/10/15 20:25:57 pacho Exp $
+
+*mono-2.8-r1 (15 Oct 2010)
+
+ 15 Oct 2010; Pacho Ramos <pacho@gentoo.org> -mono-2.8.ebuild,
+ +mono-2.8-r1.ebuild:
+ Force building with profile4 support (as it's used by default and
+ disabling it causes problems like reported in bug #340641 by Kamen Dokov
+ and tman) and building without moonlight configure option since it simply
+ strips mono from anything not used by www-plugins/moonlight (that is not
+ suitable for us since we need to support many other mono apps, thanks to
+ Miguel de Icaza for the explanation and Alistair Bush for tracking this
+ upstream and giving me a heads up when needed).
*mono-2.8 (08 Oct 2010)
diff --git a/dev-lang/mono/mono-2.8.ebuild b/dev-lang/mono/mono-2.8-r1.ebuild
index 13d4fa7f77b7..feda8a4b1069 100644
--- a/dev-lang/mono/mono-2.8.ebuild
+++ b/dev-lang/mono/mono-2.8-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/mono/mono-2.8.ebuild,v 1.1 2010/10/08 08:29:02 ali_bush Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/mono/mono-2.8-r1.ebuild,v 1.1 2010/10/15 20:25:57 pacho Exp $
EAPI="2"
@@ -13,7 +13,7 @@ LICENSE="MIT LGPL-2.1 GPL-2 BSD-4 NPL-1.1 Ms-PL GPL-2-with-linking-exception IDP
SLOT="0"
KEYWORDS="~amd64 ~ppc ~x86"
-IUSE="hardened minimal moonlight +profile4 xen"
+IUSE="hardened minimal xen"
#Bash requirement is for += operator
COMMONDEPEND="!<dev-dotnet/pnet-0.6.12
@@ -82,21 +82,25 @@ src_configure() {
#Remove this at your own peril. Mono will barf in unexpected ways.
append-flags -fno-strict-aliasing
- #NOTE: We need the static libs for now so mono-debugger works.
- #See http://bugs.gentoo.org/show_bug.cgi?id=256264 for details
-
- #--with-glib=system configure: error: --with-glib=system is no longer supported as of Mono 2.8
+ # NOTE: We need the static libs for now so mono-debugger works.
+ # See http://bugs.gentoo.org/show_bug.cgi?id=256264 for details
+ #
+ # --without-moonlight since www-plugins/moonlight is not the only one
+ # using mono: https://bugzilla.novell.com/show_bug.cgi?id=641005#c3
+ #
+ # --with-profile4 needs to be always enabled since it's used by default
+ # and, otherwise, problems like bug #340641 appear.
go-mono_src_configure \
--enable-static \
--disable-quiet-build \
- $(use_with moonlight) \
+ --without-moonlight \
--with-libgdiplus=$(use minimal && printf "no" || printf "installed" ) \
$(use_with xen xen_opt) \
--without-ikvm-native \
--with-jit \
--disable-dtrace \
- $(use_with profile4)
+ --with-profile4
}
src_test() {