summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJurek Bartuszek <jurek@gentoo.org>2008-05-31 22:25:14 +0000
committerJurek Bartuszek <jurek@gentoo.org>2008-05-31 22:25:14 +0000
commitf1ea6a549944c75b97c5522bee0a0e2749dc7cd6 (patch)
treeb8ccb960c2a23eda963e38a73693b5e214143ccc /dev-lang/mono-basic
parentVersion bump (diff)
downloadgentoo-2-f1ea6a549944c75b97c5522bee0a0e2749dc7cd6.tar.gz
gentoo-2-f1ea6a549944c75b97c5522bee0a0e2749dc7cd6.tar.bz2
gentoo-2-f1ea6a549944c75b97c5522bee0a0e2749dc7cd6.zip
dev-lang/mono-basic: version bump
(Portage version: 2.1.4.4)
Diffstat (limited to 'dev-lang/mono-basic')
-rw-r--r--dev-lang/mono-basic/ChangeLog9
-rw-r--r--dev-lang/mono-basic/mono-basic-1.9.ebuild36
2 files changed, 43 insertions, 2 deletions
diff --git a/dev-lang/mono-basic/ChangeLog b/dev-lang/mono-basic/ChangeLog
index debd7b205960..412a52d448b6 100644
--- a/dev-lang/mono-basic/ChangeLog
+++ b/dev-lang/mono-basic/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-lang/mono-basic
-# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/mono-basic/ChangeLog,v 1.8 2007/12/14 20:05:36 jurek Exp $
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/mono-basic/ChangeLog,v 1.9 2008/05/31 22:25:14 jurek Exp $
+
+*mono-basic-1.9 (31 May 2008)
+
+ 31 May 2008; Jurek Bartuszek <jurek@gentoo.org> +mono-basic-1.9.ebuild:
+ Version bump
*mono-basic-1.2.6 (14 Dec 2007)
diff --git a/dev-lang/mono-basic/mono-basic-1.9.ebuild b/dev-lang/mono-basic/mono-basic-1.9.ebuild
new file mode 100644
index 000000000000..6cf26df61918
--- /dev/null
+++ b/dev-lang/mono-basic/mono-basic-1.9.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/mono-basic/mono-basic-1.9.ebuild,v 1.1 2008/05/31 22:25:14 jurek Exp $
+
+inherit mono multilib
+
+DESCRIPTION="Visual Basic .NET Runtime and Class Libraries"
+HOMEPAGE="http://www.go-mono.com"
+SRC_URI="http://go-mono.com/sources/${PN}/${P}.tar.bz2"
+
+LICENSE="|| ( GPL-2 LGPL-2 X11 )"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="=dev-lang/mono-${PV}*"
+DEPEND="${RDEPEND}"
+
+RESTRICT="test"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ sed -i -e "s|\(mono_libdir=\${exec_prefix}\)/lib|\1/$(get_libdir)|" \
+ configure || die "sed failed"
+}
+
+src_compile() {
+ econf || die "configure failed"
+ emake || die "make failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "install failed"
+}