summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHarald van Dijk <truedfx@gentoo.org>2010-02-06 09:15:14 +0000
committerHarald van Dijk <truedfx@gentoo.org>2010-02-06 09:15:14 +0000
commit4882c67fa2fdd095cff0e3ef346b48d6a2d064ac (patch)
treef22a84ea68b41da18b08f83c8cb9f69777d9b2ed /dev-lang/lazarus
parentVersion bump (diff)
downloadgentoo-2-4882c67fa2fdd095cff0e3ef346b48d6a2d064ac.tar.gz
gentoo-2-4882c67fa2fdd095cff0e3ef346b48d6a2d064ac.tar.bz2
gentoo-2-4882c67fa2fdd095cff0e3ef346b48d6a2d064ac.zip
Version bump (#292561)
(Portage version: 2.2_rc62/cvs/Linux x86_64)
Diffstat (limited to 'dev-lang/lazarus')
-rw-r--r--dev-lang/lazarus/ChangeLog10
-rw-r--r--dev-lang/lazarus/lazarus-0.9.28.2.ebuild73
2 files changed, 81 insertions, 2 deletions
diff --git a/dev-lang/lazarus/ChangeLog b/dev-lang/lazarus/ChangeLog
index 7b35836b962a..3951ca24a702 100644
--- a/dev-lang/lazarus/ChangeLog
+++ b/dev-lang/lazarus/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-lang/lazarus
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/lazarus/ChangeLog,v 1.30 2009/07/22 20:24:39 truedfx Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/lazarus/ChangeLog,v 1.31 2010/02/06 09:15:14 truedfx Exp $
+
+*lazarus-0.9.28.2 (06 Feb 2010)
+
+ 06 Feb 2010; Harald van Dijk <truedfx@gentoo.org>
+ +lazarus-0.9.28.2.ebuild:
+ Version bump (#292561)
*lazarus-0.9.26-r4 (22 Jul 2009)
diff --git a/dev-lang/lazarus/lazarus-0.9.28.2.ebuild b/dev-lang/lazarus/lazarus-0.9.28.2.ebuild
new file mode 100644
index 000000000000..8ac17254d82e
--- /dev/null
+++ b/dev-lang/lazarus/lazarus-0.9.28.2.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/lazarus/lazarus-0.9.28.2.ebuild,v 1.1 2010/02/06 09:15:14 truedfx Exp $
+
+EAPI=2
+
+inherit eutils
+
+RESTRICT="strip" #269221
+
+FPCVER="2.4.0"
+
+SLOT="0" # Note: Slotting Lazarus needs slotting fpc, see DEPEND.
+LICENSE="GPL-2 LGPL-2.1 LGPL-2.1-linking-exception"
+KEYWORDS="~amd64 ~ppc ~x86"
+DESCRIPTION="Lazarus IDE is a feature rich visual programming environment emulating Delphi."
+HOMEPAGE="http://www.lazarus.freepascal.org/"
+IUSE=""
+SRC_URI="mirror://sourceforge/lazarus/${P}-src.tar.bz2"
+
+DEPEND="~dev-lang/fpc-${FPCVER}[source]
+ net-misc/rsync
+ >=x11-libs/gtk+-2.0"
+RDEPEND="${DEPEND}
+ !=gnome-base/librsvg-2.16.1"
+DEPEND="${DEPEND}
+ >=sys-devel/binutils-2.19.1-r1"
+
+S=${WORKDIR}/${PN}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-0.9.26-fpcsrc.patch
+
+ # Use default configuration (minus stripping) unless specifically requested otherwise
+ if ! test ${PPC_CONFIG_PATH+set} ; then
+ local FPCVER=$(fpc -iV)
+ export PPC_CONFIG_PATH="${WORKDIR}"
+ sed -e 's/^FPBIN=/#&/' /usr/lib/fpc/${FPCVER}/samplecfg |
+ sh -s /usr/lib/fpc/${FPCVER} "${PPC_CONFIG_PATH}" || die
+ #sed -i -e '/^-Xs/d' "${PPC_CONFIG_PATH}"/fpc.cfg || die
+ fi
+}
+
+src_compile() {
+ LCL_PLATFORM=gtk2 emake -j1 || die "make failed!"
+}
+
+src_install() {
+ diropts -m0755
+ dodir /usr/share
+ # Using rsync to avoid unnecessary copies and cleaning...
+ # Note: *.o and *.ppu are needed
+ rsync -a \
+ --exclude="CVS" --exclude=".cvsignore" \
+ --exclude="*.ppw" --exclude="*.ppl" \
+ --exclude="*.ow" --exclude="*.a"\
+ --exclude="*.rst" --exclude=".#*" \
+ --exclude="*.~*" --exclude="*.bak" \
+ --exclude="*.orig" --exclude="*.rej" \
+ --exclude=".xvpics" --exclude="*.compiled" \
+ --exclude="killme*" --exclude=".gdb_hist*" \
+ --exclude="debian" --exclude="COPYING*" \
+ --exclude="*.app" \
+ "${S}" "${D}"usr/share \
+ || die "Unable to copy files!"
+
+ dosym ../share/lazarus/startlazarus /usr/bin/startlazarus
+ dosym ../share/lazarus/startlazarus /usr/bin/lazarus
+ dosym ../share/lazarus/lazbuild /usr/bin/lazbuild
+ dosym ../lazarus/images/ide_icon48x48.png /usr/share/pixmaps/lazarus.png
+
+ make_desktop_entry startlazarus "Lazarus IDE" "lazarus" || die "Failed making desktop entry!"
+}