summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2011-03-17 02:21:26 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2011-03-17 02:21:26 +0000
commitce8c4136265fe810a6bd5d950f00bc19b56ea12e (patch)
tree7dcfc17702239582add2d7e98bbf390b7e178d6c /dev-lang/jimtcl/jimtcl-9999.ebuild
parentInitial import of acr38u. thanks to Vincent Hardy in bug #187422 for writing ... (diff)
downloadgentoo-2-ce8c4136265fe810a6bd5d950f00bc19b56ea12e.tar.gz
gentoo-2-ce8c4136265fe810a6bd5d950f00bc19b56ea12e.tar.bz2
gentoo-2-ce8c4136265fe810a6bd5d950f00bc19b56ea12e.zip
Initial commit of jimtcl package. Required for newer openocd packages. Thanks to Peter Stuge <peter@stuge.se> for the initial ebuild. Bug #346473
(Portage version: 2.2.0_alpha27/cvs/Linux x86_64)
Diffstat (limited to 'dev-lang/jimtcl/jimtcl-9999.ebuild')
-rw-r--r--dev-lang/jimtcl/jimtcl-9999.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-lang/jimtcl/jimtcl-9999.ebuild b/dev-lang/jimtcl/jimtcl-9999.ebuild
new file mode 100644
index 000000000000..f544846cea27
--- /dev/null
+++ b/dev-lang/jimtcl/jimtcl-9999.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/jimtcl/jimtcl-9999.ebuild,v 1.1 2011/03/17 02:21:26 hwoarang Exp $
+
+EAPI="2"
+
+inherit git
+
+DESCRIPTION="Small footprint implementation of Tcl programming language"
+HOMEPAGE="http://jim.berlios.de/"
+EGIT_REPO="http://repo.or.cz/r/jimtcl.git"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS=""
+IUSE="static-libs"
+
+src_configure() {
+ ! use static-libs && myconf=--with-jim-shared
+ econf ${myconf} \
+ --with-jim-ext=nvp
+}
+
+src_compile() {
+ emake all docs || die
+}
+
+src_install() {
+ dobin jimsh || die "dobin failed"
+ dolib.so libjim.so || die "dolib failed"
+ insinto /usr/include
+ doins jim.h jimautoconf.h jim-subcmd.h jim-nvp.h jim-signal.h
+ doins jim-win32compat.h jim-eventloop.h jim-config.h
+ dodoc AUTHORS README TODO || die "dodoc failed"
+ dohtml Tcl.html || die "dohtml failed"
+}