summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristoph Junghans <ottxor@gentoo.org>2013-01-08 05:43:51 +0000
committerChristoph Junghans <ottxor@gentoo.org>2013-01-08 05:43:51 +0000
commite1d560253f91e20f8313bf521767907f7faa64aa (patch)
tree5a09a6039aa5c562215949a6944852aa6d78a9ac /dev-lang/ispc
parentoverride INSTALL_SYSCONFDIR to install properly in a prefix environment (diff)
downloadgentoo-2-e1d560253f91e20f8313bf521767907f7faa64aa.tar.gz
gentoo-2-e1d560253f91e20f8313bf521767907f7faa64aa.tar.bz2
gentoo-2-e1d560253f91e20f8313bf521767907f7faa64aa.zip
fix llvm deps (bug #450786), python dep, remove old
(Portage version: 2.2.0_alpha149/cvs/Linux x86_64, signed Manifest commit with key C2000586)
Diffstat (limited to 'dev-lang/ispc')
-rw-r--r--dev-lang/ispc/ChangeLog8
-rw-r--r--dev-lang/ispc/ispc-1.2.2.ebuild44
-rw-r--r--dev-lang/ispc/ispc-1.3.0.ebuild16
3 files changed, 17 insertions, 51 deletions
diff --git a/dev-lang/ispc/ChangeLog b/dev-lang/ispc/ChangeLog
index cad70b41dedc..e29e25486144 100644
--- a/dev-lang/ispc/ChangeLog
+++ b/dev-lang/ispc/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-lang/ispc
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/ispc/ChangeLog,v 1.7 2012/09/10 00:07:30 ottxor Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/ispc/ChangeLog,v 1.8 2013/01/08 05:43:51 ottxor Exp $
+
+ 08 Jan 2013; Christoph Junghans <ottxor@gentoo.org> -ispc-1.2.2.ebuild,
+ ispc-1.3.0.ebuild:
+ fix llvm deps (bug #450786), python dep, remove old
10 Sep 2012; Christoph Junghans <ottxor@gentoo.org> metadata.xml:
updated metadata.xml
diff --git a/dev-lang/ispc/ispc-1.2.2.ebuild b/dev-lang/ispc/ispc-1.2.2.ebuild
deleted file mode 100644
index 456c1ed8a4dc..000000000000
--- a/dev-lang/ispc/ispc-1.2.2.ebuild
+++ /dev/null
@@ -1,44 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/ispc/ispc-1.2.2.ebuild,v 1.3 2012/06/19 12:22:33 ago Exp $
-
-EAPI=4
-GITHUB_ID="2c75ac1"
-
-inherit toolchain-funcs
-
-DESCRIPTION="Intel SPMD Program Compiler"
-HOMEPAGE="http://ispc.github.com/"
-SRC_URI="https://github.com/ispc/ispc/tarball/v${PV} -> ${PN}-git-${PV}.tgz"
-S="${WORKDIR}/${PN}-${PN}-${GITHUB_ID}"
-
-LICENSE="BSD BSD-2 UoI-NCSA"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="examples"
-
-RDEPEND="
- =sys-devel/clang-3.0*
- =sys-devel/llvm-3.0*
- "
-DEPEND="
- ${RDEPEND}
- sys-devel/bison
- sys-devel/flex
- "
-
-DOCS=( README.rst )
-
-src_compile() {
- emake LDFLAGS="${LDFLAGS}" OPT="${CXXFLAGS}" CXX="$(tc-getCXX)" CPP="$(tc-getCPP)"
-}
-
-src_install() {
- dobin ispc
-
- if use examples; then
- insinto "/usr/share/doc/${PF}/examples"
- docompress -x "/usr/share/doc/${PF}/examples"
- doins -r examples/*
- fi
-}
diff --git a/dev-lang/ispc/ispc-1.3.0.ebuild b/dev-lang/ispc/ispc-1.3.0.ebuild
index 9f89f175f418..cb1f11e974ea 100644
--- a/dev-lang/ispc/ispc-1.3.0.ebuild
+++ b/dev-lang/ispc/ispc-1.3.0.ebuild
@@ -1,10 +1,12 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/ispc/ispc-1.3.0.ebuild,v 1.3 2012/08/26 18:41:28 ottxor Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/ispc/ispc-1.3.0.ebuild,v 1.4 2013/01/08 05:43:51 ottxor Exp $
EAPI=4
-inherit base toolchain-funcs
+PYTHON_DEPEND="2"
+
+inherit base toolchain-funcs python
DESCRIPTION="Intel SPMD Program Compiler"
HOMEPAGE="http://ispc.github.com/"
@@ -24,8 +26,8 @@ KEYWORDS="~amd64 ~x86"
IUSE="examples"
RDEPEND="
- >=sys-devel/clang-3.0
- >=sys-devel/llvm-3.0
+ || ( =sys-devel/clang-3.0* =sys-devel/clang-3.1* )
+ || ( =sys-devel/llvm-3.0* =sys-devel/llvm-3.1* )
"
DEPEND="
${RDEPEND}
@@ -33,6 +35,10 @@ DEPEND="
sys-devel/flex
"
+pkg_setup() {
+ python_set_active_version 2
+}
+
src_compile() {
emake LDFLAGS="${LDFLAGS}" OPT="${CXXFLAGS}" CXX="$(tc-getCXX)" CPP="$(tc-getCPP)"
}