summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKarl Trygve Kalleberg <karltk@gentoo.org>2005-07-05 13:35:50 +0000
committerKarl Trygve Kalleberg <karltk@gentoo.org>2005-07-05 13:35:50 +0000
commiteed7253dc4403dcc6ec1b2e1e9edaac2bd668a77 (patch)
tree71b4e0ae93cf3b49f6303abf3ba3c53b97a3f6be /dev-lang/icc
parentoops, missed to commit thjis earlier. Handle moduledb a little tidier (diff)
downloadgentoo-2-eed7253dc4403dcc6ec1b2e1e9edaac2bd668a77.tar.gz
gentoo-2-eed7253dc4403dcc6ec1b2e1e9edaac2bd668a77.tar.bz2
gentoo-2-eed7253dc4403dcc6ec1b2e1e9edaac2bd668a77.zip
Old upstream release.
(Portage version: 2.0.51.19)
Diffstat (limited to 'dev-lang/icc')
-rw-r--r--dev-lang/icc/ChangeLog9
-rw-r--r--dev-lang/icc/files/9.0.021/05icc-ifc6
-rw-r--r--dev-lang/icc/files/9.0.021/icc10
-rw-r--r--dev-lang/icc/files/9.0.021/iccifc.conf29
-rw-r--r--dev-lang/icc/files/9.0.021/icpc10
-rw-r--r--dev-lang/icc/files/digest-icc-9.0.0211
-rw-r--r--dev-lang/icc/icc-9.0.021.ebuild126
7 files changed, 190 insertions, 1 deletions
diff --git a/dev-lang/icc/ChangeLog b/dev-lang/icc/ChangeLog
index 93d80608c9ef..6d7cea141a68 100644
--- a/dev-lang/icc/ChangeLog
+++ b/dev-lang/icc/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-lang/icc
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/icc/ChangeLog,v 1.27 2005/07/04 21:55:23 kugelfang Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/icc/ChangeLog,v 1.28 2005/07/05 13:35:50 karltk Exp $
+
+*icc-9.0.021 (05 Jul 2005)
+
+ 05 Jul 2005; Karl Trygve Kalleberg <karltk@gentoo.org>
+ +files/9.0.021/05icc-ifc, +files/9.0.021/iccifc.conf, +files/9.0.021/icc,
+ +files/9.0.021/icpc, +icc-9.0.021.ebuild:
+ Old upstream release. But this one is generally available.
04 Jul 2005; Danny van Dyk <kugelfang@gentoo.org> icc-9.0.023.ebuild:
Fixed to work on amd64 and marked accordingly.
diff --git a/dev-lang/icc/files/9.0.021/05icc-ifc b/dev-lang/icc/files/9.0.021/05icc-ifc
new file mode 100644
index 000000000000..236ca7ef56e0
--- /dev/null
+++ b/dev-lang/icc/files/9.0.021/05icc-ifc
@@ -0,0 +1,6 @@
+IA32ROOT=/opt/intel/compiler90
+INTEL_FLEXLM_LICENSE=/opt/intel/compiler90/licenses
+LDPATH=/opt/intel/compiler90/lib
+MANPATH=/opt/intel/compiler90/man
+PATH=/opt/intel/compiler90/bin
+ROOTPATH=/opt/intel/compiler90/bin
diff --git a/dev-lang/icc/files/9.0.021/icc b/dev-lang/icc/files/9.0.021/icc
new file mode 100644
index 000000000000..e9ba0b9c107c
--- /dev/null
+++ b/dev-lang/icc/files/9.0.021/icc
@@ -0,0 +1,10 @@
+#! /bin/sh
+#
+# Gentoo-specific wrapper script for the Intel C/C++ compilers
+#
+# Maintainer: Karl Trygve Kalleberg <karltk@gentoo.org>
+#
+
+export INTEL_LICENSE_FILE="/opt/intel/compiler90/licenses"
+export LD_LIBRARY_PATH="/opt/intel/compiler90/lib"
+/opt/intel/compiler90/bin/iccbin $*
diff --git a/dev-lang/icc/files/9.0.021/iccifc.conf b/dev-lang/icc/files/9.0.021/iccifc.conf
new file mode 100644
index 000000000000..4f5d6789c65d
--- /dev/null
+++ b/dev-lang/icc/files/9.0.021/iccifc.conf
@@ -0,0 +1,29 @@
+#This file is used to set global (hopefully) compiler variables for the
+#Intel ICC and IFC compilers. The ICFLAGS and ICCFLAGS are the
+#equivalents of the CFLAGS and CXXFLAGS - specific for ICC & IFC.
+
+#Note that the following flags are currently considered to be rather
+#problematic, and you may experience significant difficulty in emerges
+#with these flags
+#
+# -ip -ipo -ipo_obj -static -fast -cxxlib-gcc
+#
+
+#The following settings are a good starting point for Pentium 4 owners.
+#Pentium 3 owners should replace -xN with -xK
+#Pentium M owners should replace -xN with -xB
+#Prescott owners should replace -xN with -xP
+
+ICFLAGS = "-O2 -xN -noalign"
+ICXXFLAGS = "${ICFLAGS}"
+IFCFLAGS = "${ICFLAGS}"
+
+#The following variables define the compilers and linkers
+
+ICC = "icc"
+ICXX = "icpc"
+ICPP = "${ICC} -E"
+ICXXCPP = "${ICXX} -E"
+IFC = "ifc"
+ILD = "xild"
+IAR = "xiar"
diff --git a/dev-lang/icc/files/9.0.021/icpc b/dev-lang/icc/files/9.0.021/icpc
new file mode 100644
index 000000000000..f03dddfc7906
--- /dev/null
+++ b/dev-lang/icc/files/9.0.021/icpc
@@ -0,0 +1,10 @@
+#! /bin/sh
+#
+# Gentoo-specific wrapper script for Intel C/C++ compiler suite
+#
+# Maintainer: Karl Trygve Kalleberg <karltk@gentoo.org>
+#
+
+export INTEL_LICENSE_FILE="/opt/intel/compiler90/licenses"
+export LD_LIBRARY_PATH="/opt/intel/compiler90/lib"
+/opt/intel/compiler90/bin/icpcbin $*
diff --git a/dev-lang/icc/files/digest-icc-9.0.021 b/dev-lang/icc/files/digest-icc-9.0.021
new file mode 100644
index 000000000000..5d83d4be96a3
--- /dev/null
+++ b/dev-lang/icc/files/digest-icc-9.0.021
@@ -0,0 +1 @@
+MD5 bedd32b245b6d381321e94022341e5b1 l_cc_p_9.0.021.tar.gz 201197170
diff --git a/dev-lang/icc/icc-9.0.021.ebuild b/dev-lang/icc/icc-9.0.021.ebuild
new file mode 100644
index 000000000000..abf9c7707a7c
--- /dev/null
+++ b/dev-lang/icc/icc-9.0.021.ebuild
@@ -0,0 +1,126 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/icc/icc-9.0.021.ebuild,v 1.1 2005/07/05 13:35:50 karltk Exp $
+
+inherit rpm
+
+DESCRIPTION="Intel C++ Compiler - Intel's Pentium optimized compiler for Linux"
+SRC_URI="l_cc_p_${PV}.tar.gz"
+HOMEPAGE="http://www.intel.com/software/products/compilers/clin/"
+LICENSE="icc-9.0"
+RDEPEND=">=sys-libs/glibc-2.2.5"
+SLOT="9.0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+RESTRICT="nostrip fetch"
+S="${WORKDIR}/l_cc_p_${PV}"
+
+src_unpack() {
+ unpack ${A}
+
+ cd ${S} || die
+
+ # The tarball contains rpms for multiple arches, and a lot of
+ # auxiliary rpms common across arches. We must throw away
+ # the arch we're not.
+ case ${ARCH} in
+ amd64)
+ rm -f intel-*.{i386,ia64}.rpm
+ ;;
+ ia64)
+ rm -f intel-*.{em64t,i386}.rpm
+ ;;
+ x86)
+ rm -f intel-*.{em64t,ia64}.rpm
+ ;;
+ esac
+
+ for x in *.rpm
+ do
+ # WORKDIR must be set properly for rpm_unpack()
+ rpm_unpack ${S}/${x}
+ done
+
+}
+
+src_compile() {
+ instdir=/opt/intel/compiler90
+
+ for x in opt/intel/*/*/bin/* ; do
+ sed "s|<INSTALLDIR>|${instdir}|g" -i $x
+ done
+
+ # == SRC_BASE
+ eval `grep "^[ ]*PACKAGEID=" ${S}/install.sh`
+
+ # From UNTAG_SUPPORT() in 'install.sh'
+ SUPPORTFILE=${S}/opt/intel/cc*/9.0/doc/csupport
+ if [ -f ${SUPPORTFILE} ]
+ then
+ einfo "Untagging: ${SUPPORTFILE}"
+ sed s@\<installpackageid\>@${PACKAGEID}@g ${SUPPORTFILE} > ${SUPPORTFILE}.abs
+ mv ${SUPPORTFILE}.abs ${SUPPORTFILE}
+ chmod 644 ${SUPPORTFILE}
+ fi
+
+ # From UNTAG_SUPPORT_IDB() in 'install.sh'
+ SUPPORTFILE=${S}/opt/intel/idb*/9.0/doc/idbsupport
+ if [ -f ${SUPPORTFILE} ]
+ then
+ einfo "Untagging: ${SUPPORTFILE}"
+ sed s@\<INSTALLTIMECOMBOPACKAGEID\>@${PACKAGEID}@g ${SUPPORTFILE} > ${SUPPORTFILE}.abs
+ mv ${SUPPORTFILE}.abs ${SUPPORTFILE}
+ chmod 644 ${SUPPORTFILE}
+ fi
+
+ # These should not be executable
+ find "${S}/opt/intel/cc*/9.0/"{doc,man,include} -type f -exec chmod -x "{}" ";"
+ find "${S}/opt/intel/cc*/9.0/lib" -name \*.a -exec chmod -x "{}" ";"
+ find "${S}/opt/intel/idb*/9.0/"{doc,man} -type f -exec chmod -x "{}" ";"
+}
+
+src_install () {
+ instdir=/opt/intel/compiler90
+ dodoc ${S}/lgpltext
+ dodoc ${S}/clicense
+ dodir ${instdir}
+ cp -a opt/intel/cc*/9.0/* ${D}/${instdir}
+ cp -a opt/intel/idb*/9.0/* ${D}/${instdir}
+ insinto /etc/env.d
+ doins ${FILESDIR}/${PVR}/05icc-ifc || die
+ exeinto ${instdir}/bin
+ doexe ${FILESDIR}/${PVR}/icc || die
+ doexe ${FILESDIR}/${PVR}/icpc || die
+}
+
+pkg_postinst () {
+ instdir=/opt/intel/compiler90
+
+ einfo "http://www.intel.com/software/products/compilers/clin/noncom.htm"
+ einfo "From the above url you can get a free, non-commercial"
+ einfo "license to use the Intel C++ Compiler emailed to you."
+ einfo "You cannot run icc without this license file."
+ einfo "Read the website for more information on this license."
+ einfo
+ einfo "Documentation can be found in ${instdir}/doc/"
+ einfo
+ einfo "You will need to place your license in ${instdir}/licenses/"
+ einfo
+
+ ewarn
+ ewarn "Packages compiled with versions of icc older than 8.0 will need"
+ ewarn "to be recompiled. Until you do that, old packages will"
+ ewarn "work if you edit /etc/ld.so.conf and change '${instdir}'"
+ ewarn "to '/opt/intel/compiler70' and run 'ldconfig.' Note that this edit"
+ ewarn "won't persist and will require you to re-edit after each"
+ ewarn "package you re-install."
+ ewarn "BEFORE COMPILING IMPORTANT APPLICATIONS THAT YOUR"
+ ewarn "SYSTEM DEPENDS ON, READ THE WARNING ABOVE."
+ ewarn "THIS COULD RENDER YOUR SYSTEM UNUSABLE."
+ ewarn "THIS IS A PROBLEM WITH INTEL'S SOFTWARE, _NOT_"
+ ewarn "WITH GENTOO."
+
+ ewarn "If 'icc' breaks, use 'iccbin' instead and report a bug."
+ ewarn "Please use 'source /etc/profile' prior to merging any icc-enabled"
+ ewarn "ebuilds."
+}