summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrey Kislyuk <weaver@gentoo.org>2009-08-19 07:53:54 +0000
committerAndrey Kislyuk <weaver@gentoo.org>2009-08-19 07:53:54 +0000
commitd96b4b409383ca5d41f7543809588ad1061ccb7c (patch)
treeb4192a4fdf0167784b35b031fbfa90e190a7429a /dev-lang/icc
parentUpdate lzma deps to allow xz-utils too, bug #279871 (diff)
downloadgentoo-2-d96b4b409383ca5d41f7543809588ad1061ccb7c.tar.gz
gentoo-2-d96b4b409383ca5d41f7543809588ad1061ccb7c.tar.bz2
gentoo-2-d96b4b409383ca5d41f7543809588ad1061ccb7c.zip
Version bump, bug 246516
(Portage version: 2.2_rc30/cvs/Linux x86_64)
Diffstat (limited to 'dev-lang/icc')
-rw-r--r--dev-lang/icc/ChangeLog9
-rw-r--r--dev-lang/icc/icc-11.1.046.ebuild88
-rw-r--r--dev-lang/icc/metadata.xml4
3 files changed, 99 insertions, 2 deletions
diff --git a/dev-lang/icc/ChangeLog b/dev-lang/icc/ChangeLog
index c6074857acc3..5c3298f91a5a 100644
--- a/dev-lang/icc/ChangeLog
+++ b/dev-lang/icc/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-lang/icc
-# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/icc/ChangeLog,v 1.66 2008/10/07 09:13:13 bicatali Exp $
+# Copyright 2002-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/icc/ChangeLog,v 1.67 2009/08/19 07:53:54 weaver Exp $
+
+*icc-11.1.046 (19 Aug 2009)
+
+ 19 Aug 2009; Andrey Kislyuk <weaver@gentoo.org> +icc-11.1.046.ebuild:
+ Version bump, bug 246516. Adding myself to maintainers.
07 Oct 2008; Sébastien Fabbro <bicatali@gentoo.org> icc-10.1.018.ebuild:
Fixed for limits.h inclusion on amd64, bug #239313
diff --git a/dev-lang/icc/icc-11.1.046.ebuild b/dev-lang/icc/icc-11.1.046.ebuild
new file mode 100644
index 000000000000..867908c29480
--- /dev/null
+++ b/dev-lang/icc/icc-11.1.046.ebuild
@@ -0,0 +1,88 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/icc/icc-11.1.046.ebuild,v 1.1 2009/08/19 07:53:54 weaver Exp $
+
+EAPI="2"
+
+PID=1536
+PB=cproc
+PEXEC="icc icpc"
+DESCRIPTION="Intel C/C++ optimized compiler for Linux"
+HOMEPAGE="http://www.intel.com/software/products/compilers/clin/"
+
+###
+# everything below common to ifc and icc
+# no eclass: very likely to change for next versions
+###
+PACKAGEID="l_${PB}_p_${PV}"
+RELEASE="${PV:0:4}"
+BUILD="${PV:5:8}"
+SRC_URI="http://registrationcenter-download.intel.com/irc_nas/${PID}/${PACKAGEID}.tgz"
+#SRC_URI="amd64? ( http://registrationcenter-download.intel.com/irc_nas/${PID}/${PACKAGEID}_intel64.tgz )
+# ia64? ( http://registrationcenter-download.intel.com/irc_nas/${PID}/${PACKAGEID}_ia64.tgz )
+# x86? ( http://registrationcenter-download.intel.com/irc_nas/${PID}/${PACKAGEID}_ia32.tgz )"
+
+LICENSE="Intel-SDP"
+SLOT="0"
+IUSE=""
+KEYWORDS="~amd64 ~x86"
+
+RESTRICT="mirror strip binchecks"
+
+INSTALL_DIR="opt/intel/Compiler/${RELEASE}/${BUILD}"
+# these don't work, not sure why
+#QA_TEXTRELS="${INSTALL_DIR}"
+#QA_WX_LOAD="${INSTALL_DIR}"
+#QA_PRESTRIPPED="${INSTALL_DIR}"
+
+DEPEND="app-arch/rpm"
+RDEPEND="virtual/libstdc++
+ amd64? ( app-emulation/emul-linux-x86-compat )"
+
+S="${WORKDIR}/${PACKAGEID}"
+
+src_prepare() {
+ use amd64 || rm -f rpm/*x86_64.rpm
+ # debugger installed with dev-lang/idb
+ rm -f rpm/intel*idb*.rpm
+ # performance primitives installed with sci-libs/ipp
+ rm -f rpm/intel*ipp*.rpm
+ # math library installed with sci-libs/mkl
+ rm -f rpm/intel*mkl*.rpm
+}
+
+src_install() {
+ mkdir "${WORKDIR}/rpmdb"
+ # rpm open_wr's / but doesn't seem to do anything with it
+ addpredict /
+ rpm --install --nodeps --dbpath "${WORKDIR}/rpmdb" --prefix "${D}/${INSTALL_DIR}" rpm/*.rpm || die
+
+ find "${D}/${INSTALL_DIR}" -name '*.csh' | xargs sed -i "s|${D}|${ROOT}|" || die
+ find "${D}/${INSTALL_DIR}" -name '*.sh' | xargs sed -i "s|${D}|${ROOT}|" || die
+
+ ENV_FILE=${PN}.sh
+ MYARCH=""
+ if use amd64; then MYARCH=intel64; fi
+ if use ia64; then MYARCH=ia64; fi
+ if use x86; then MYARCH=ia32; fi
+
+ echo "source ${ROOT}${INSTALL_DIR}/bin/iccvars.sh ${MYARCH}" >> ${ENV_FILE}
+
+ exeinto /etc/profile.d
+ doexe ${ENV_FILE} || die
+
+ mkdir -p "${D}/opt/intel/licenses"
+}
+
+pkg_postinst() {
+ elog "${PN} requires a license file in order to run."
+ elog "To receive a restrictive non-commercial license, please register at:"
+ elog "http://www.intel.com/cd/software/products/asmo-na/eng/download/download/219771.htm"
+ elog "Read the website for more information on this license."
+ elog "Install the license file into ${ROOT}opt/intel/licenses"
+ elog
+ elog "The following packages provide components bundled with icc:"
+ elog "\t dev-lang/idb"
+ elog "\t sci-libs/ipp"
+ elog "\t sci-libs/mkl"
+}
diff --git a/dev-lang/icc/metadata.xml b/dev-lang/icc/metadata.xml
index 878bf1f668f9..cc987bd3982b 100644
--- a/dev-lang/icc/metadata.xml
+++ b/dev-lang/icc/metadata.xml
@@ -6,6 +6,10 @@
<maintainer>
<email>bicatali@gentoo.org</email>
</maintainer>
+<maintainer>
+ <email>weaver@gentoo.org</email>
+ <name>Andrey Kislyuk</name>
+</maintainer>
<longdescription lang="en">
The Intel® C++ Compiler is a full featured C/C++ compiler for Intel
based architectures. The compiler supports multi-threading, automatic