summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Hubbs <williamh@gentoo.org>2015-01-20 03:39:35 +0000
committerWilliam Hubbs <williamh@gentoo.org>2015-01-20 03:39:35 +0000
commitf71aeb0d1fbac8f1bae575c10f3b6942b370d9a3 (patch)
treebd126b7c9f17ccff1a7aefb02fb462c871338f78 /dev-lang/go-bootstrap
parentadded better systemd support, backported from vdr-2.1.7, based on patch by Lu... (diff)
downloadgentoo-2-f71aeb0d1fbac8f1bae575c10f3b6942b370d9a3.tar.gz
gentoo-2-f71aeb0d1fbac8f1bae575c10f3b6942b370d9a3.tar.bz2
gentoo-2-f71aeb0d1fbac8f1bae575c10f3b6942b370d9a3.zip
Initial commit of go-bootstrap for bug #536960.
go-bootstrap is intended only as a build time dependency used to build newer versions of go. See https://golang.org/s/go15bootstrap for how this works. (Portage version: 2.2.15/cvs/Linux x86_64, signed Manifest commit with key 0x30C46538)
Diffstat (limited to 'dev-lang/go-bootstrap')
-rw-r--r--dev-lang/go-bootstrap/ChangeLog13
-rw-r--r--dev-lang/go-bootstrap/go-bootstrap-1.4.1.ebuild83
-rw-r--r--dev-lang/go-bootstrap/metadata.xml13
3 files changed, 109 insertions, 0 deletions
diff --git a/dev-lang/go-bootstrap/ChangeLog b/dev-lang/go-bootstrap/ChangeLog
new file mode 100644
index 000000000000..cc212d7e3c6a
--- /dev/null
+++ b/dev-lang/go-bootstrap/ChangeLog
@@ -0,0 +1,13 @@
+# ChangeLog for dev-lang/go-bootstrap
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/go-bootstrap/ChangeLog,v 1.1 2015/01/20 03:39:35 williamh Exp $
+
+*go-bootstrap-1.4.1 (20 Jan 2015)
+
+ 20 Jan 2015; William Hubbs <williamh@gentoo.org> +go-bootstrap-1.4.1.ebuild,
+ +metadata.xml:
+ Initial commit of go-bootstrap for bug #536960.
+ go-bootstrap is intended only as a build time dependency used to build
+ newer versions of go.
+ See https://golang.org/s/go15bootstrap for how this works.
+
diff --git a/dev-lang/go-bootstrap/go-bootstrap-1.4.1.ebuild b/dev-lang/go-bootstrap/go-bootstrap-1.4.1.ebuild
new file mode 100644
index 000000000000..bf0c3e1a7a90
--- /dev/null
+++ b/dev-lang/go-bootstrap/go-bootstrap-1.4.1.ebuild
@@ -0,0 +1,83 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/go-bootstrap/go-bootstrap-1.4.1.ebuild,v 1.1 2015/01/20 03:39:35 williamh Exp $
+
+EAPI=5
+
+export CTARGET=${CTARGET:-${CHOST}}
+
+inherit eutils toolchain-funcs
+
+SRC_URI="https://storage.googleapis.com/golang/go${PV}.src.tar.gz"
+# Upstream only supports go on amd64, arm and x86 architectures.
+KEYWORDS="-* ~amd64 ~arm ~x86 ~amd64-fbsd ~x86-fbsd ~x64-macos ~x86-macos"
+
+DESCRIPTION="Version of go compiler used for bootstrapping"
+HOMEPAGE="http://www.golang.org"
+
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+DEPEND=""
+RDEPEND=""
+
+# The go tools should not cause the multilib-strict check to fail.
+QA_MULTILIB_PATHS="usr/lib/go1.4/pkg/tool/.*/.*"
+
+# The go language uses *.a files which are _NOT_ libraries and should not be
+# stripped.
+STRIP_MASK="/usr/lib/go1.4/pkg/linux*/*.a
+ /usr/lib/go1.4/pkg/freebsd*/*.a /usr/lib/go1.4/pkg/darwin*/*.a"
+
+S="${WORKDIR}"/go
+
+src_prepare()
+{
+ sed -i -e 's/"-Werror",//g' src/cmd/dist/build.c
+}
+
+src_compile()
+{
+ export GOROOT_FINAL="${EPREFIX}"/usr/lib/go1.4
+ export GOROOT="$(pwd)"
+ export GOBIN="${GOROOT}/bin"
+ if [[ $CTARGET = armv5* ]]
+ then
+ export GOARM=5
+ fi
+ tc-export CC
+
+ cd src
+ ./make.bash || die "build failed"
+}
+
+src_test()
+{
+ cd src
+ PATH="${GOBIN}:${PATH}" \
+ ./run.bash --no-rebuild --banner || die "tests failed"
+}
+
+src_install()
+{
+ dodir /usr/lib/go1.4
+ exeinto /usr/lib/go1.4/bin
+doexe bin/*
+ insinto /usr/lib/go1.4
+ doins -r lib pkg src
+ fperms -R +x /usr/lib/go1.4/pkg/tool
+}
+
+pkg_postinst()
+{
+ # If the go tool sees a package file timestamped older than a dependancy it
+ # will rebuild that file. So, in order to stop go from rebuilding lots of
+ # packages for every build we need to fix the timestamps. The compiler and
+ # linker are also checked - so we need to fix them too.
+ ebegin "fixing timestamps to avoid unnecessary rebuilds"
+ tref="usr/lib/go1.4/pkg/*/runtime.a"
+ find "${EROOT}"usr/lib/go1.4 -type f \
+ -exec touch -r "${EROOT}"${tref} {} \;
+ eend $?
+}
diff --git a/dev-lang/go-bootstrap/metadata.xml b/dev-lang/go-bootstrap/metadata.xml
new file mode 100644
index 000000000000..afdfdb99076b
--- /dev/null
+++ b/dev-lang/go-bootstrap/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>williamh@gentoo.org</email>
+ <name>William Hubbs</name>
+ </maintainer>
+ <longdescription lang="en">
+ This package is only necessary until gccgo supports go-1.4. It
+ will be removed as soon as stable gcc supports this.
+ It is here so that >=dev-lang/go 1.5 can use it to bootstrap.
+ </longdescription>
+</pkgmetadata>