summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Hubbs <williamh@gentoo.org>2015-06-16 17:08:42 +0000
committerWilliam Hubbs <williamh@gentoo.org>2015-06-16 17:08:42 +0000
commit268dc85876baadf338f7f5d018c5ca20a056464d (patch)
tree6f265c7380e72b20651bec973bb6824210a4ac00 /dev-lang/go-bootstrap
parentStable for x86, wrt bug #552254 (diff)
downloadgentoo-2-268dc85876baadf338f7f5d018c5ca20a056464d.tar.gz
gentoo-2-268dc85876baadf338f7f5d018c5ca20a056464d.tar.bz2
gentoo-2-268dc85876baadf338f7f5d018c5ca20a056464d.zip
remove old version
(Portage version: 2.2.18/cvs/Linux x86_64, signed Manifest commit with key 0x30C46538)
Diffstat (limited to 'dev-lang/go-bootstrap')
-rw-r--r--dev-lang/go-bootstrap/ChangeLog5
-rw-r--r--dev-lang/go-bootstrap/go-bootstrap-1.4.1.ebuild83
2 files changed, 4 insertions, 84 deletions
diff --git a/dev-lang/go-bootstrap/ChangeLog b/dev-lang/go-bootstrap/ChangeLog
index 6e69f814a4f9..92d7d72f3968 100644
--- a/dev-lang/go-bootstrap/ChangeLog
+++ b/dev-lang/go-bootstrap/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-lang/go-bootstrap
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/go-bootstrap/ChangeLog,v 1.2 2015/03/18 00:51:29 williamh Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/go-bootstrap/ChangeLog,v 1.3 2015/06/16 17:08:42 williamh Exp $
+
+ 16 Jun 2015; William Hubbs <williamh@gentoo.org> -go-bootstrap-1.4.1.ebuild:
+ remove old version
*go-bootstrap-1.4.2 (18 Mar 2015)
diff --git a/dev-lang/go-bootstrap/go-bootstrap-1.4.1.ebuild b/dev-lang/go-bootstrap/go-bootstrap-1.4.1.ebuild
deleted file mode 100644
index bf0c3e1a7a90..000000000000
--- a/dev-lang/go-bootstrap/go-bootstrap-1.4.1.ebuild
+++ /dev/null
@@ -1,83 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/go-bootstrap/go-bootstrap-1.4.1.ebuild,v 1.1 2015/01/20 03:39:35 williamh Exp $
-
-EAPI=5
-
-export CTARGET=${CTARGET:-${CHOST}}
-
-inherit eutils toolchain-funcs
-
-SRC_URI="https://storage.googleapis.com/golang/go${PV}.src.tar.gz"
-# Upstream only supports go on amd64, arm and x86 architectures.
-KEYWORDS="-* ~amd64 ~arm ~x86 ~amd64-fbsd ~x86-fbsd ~x64-macos ~x86-macos"
-
-DESCRIPTION="Version of go compiler used for bootstrapping"
-HOMEPAGE="http://www.golang.org"
-
-LICENSE="BSD"
-SLOT="0"
-IUSE=""
-
-DEPEND=""
-RDEPEND=""
-
-# The go tools should not cause the multilib-strict check to fail.
-QA_MULTILIB_PATHS="usr/lib/go1.4/pkg/tool/.*/.*"
-
-# The go language uses *.a files which are _NOT_ libraries and should not be
-# stripped.
-STRIP_MASK="/usr/lib/go1.4/pkg/linux*/*.a
- /usr/lib/go1.4/pkg/freebsd*/*.a /usr/lib/go1.4/pkg/darwin*/*.a"
-
-S="${WORKDIR}"/go
-
-src_prepare()
-{
- sed -i -e 's/"-Werror",//g' src/cmd/dist/build.c
-}
-
-src_compile()
-{
- export GOROOT_FINAL="${EPREFIX}"/usr/lib/go1.4
- export GOROOT="$(pwd)"
- export GOBIN="${GOROOT}/bin"
- if [[ $CTARGET = armv5* ]]
- then
- export GOARM=5
- fi
- tc-export CC
-
- cd src
- ./make.bash || die "build failed"
-}
-
-src_test()
-{
- cd src
- PATH="${GOBIN}:${PATH}" \
- ./run.bash --no-rebuild --banner || die "tests failed"
-}
-
-src_install()
-{
- dodir /usr/lib/go1.4
- exeinto /usr/lib/go1.4/bin
-doexe bin/*
- insinto /usr/lib/go1.4
- doins -r lib pkg src
- fperms -R +x /usr/lib/go1.4/pkg/tool
-}
-
-pkg_postinst()
-{
- # If the go tool sees a package file timestamped older than a dependancy it
- # will rebuild that file. So, in order to stop go from rebuilding lots of
- # packages for every build we need to fix the timestamps. The compiler and
- # linker are also checked - so we need to fix them too.
- ebegin "fixing timestamps to avoid unnecessary rebuilds"
- tref="usr/lib/go1.4/pkg/*/runtime.a"
- find "${EROOT}"usr/lib/go1.4 -type f \
- -exec touch -r "${EROOT}"${tref} {} \;
- eend $?
-}