summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGeorge Shapovalov <george@gentoo.org>2011-03-10 19:59:39 +0000
committerGeorge Shapovalov <george@gentoo.org>2011-03-10 19:59:39 +0000
commit38cb11e7856b3027b60d3e83f7b3ad9769a3baea (patch)
treece66c582bc1f282b750bc7031fb43dc3fa31c7ef /dev-lang/gnat-gcc/gnat-gcc-4.4.3.ebuild
parentStable on amd64 wrt bug #358085 (diff)
downloadgentoo-2-38cb11e7856b3027b60d3e83f7b3ad9769a3baea.tar.gz
gentoo-2-38cb11e7856b3027b60d3e83f7b3ad9769a3baea.tar.bz2
gentoo-2-38cb11e7856b3027b60d3e83f7b3ad9769a3baea.zip
an overdue major bump. Finally got 4.4 working. Homefully more to follow soon..
(Portage version: 2.1.9.25/cvs/Linux x86_64)
Diffstat (limited to 'dev-lang/gnat-gcc/gnat-gcc-4.4.3.ebuild')
-rw-r--r--dev-lang/gnat-gcc/gnat-gcc-4.4.3.ebuild72
1 files changed, 72 insertions, 0 deletions
diff --git a/dev-lang/gnat-gcc/gnat-gcc-4.4.3.ebuild b/dev-lang/gnat-gcc/gnat-gcc-4.4.3.ebuild
new file mode 100644
index 000000000000..cf7d042c5a0a
--- /dev/null
+++ b/dev-lang/gnat-gcc/gnat-gcc-4.4.3.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/gnat-gcc/gnat-gcc-4.4.3.ebuild,v 1.1 2011/03/10 19:59:39 george Exp $
+
+# Need to let configure know where to find stddef.h
+#EXTRA_CONFGCC="${WORKDIR}/usr/lib/include/"
+
+inherit gnatbuild autotools
+
+DESCRIPTION="GNAT Ada Compiler - gcc version"
+HOMEPAGE="http://gcc.gnu.org/"
+LICENSE="GMGPL"
+
+IUSE=""
+
+# using new bootstrap
+BOOT_SLOT="4.3"
+
+# SLOT is set in gnatbuild.eclass, depends only on PV (basically SLOT=GCCBRANCH)
+# so the URI's are static.
+SRC_URI="ftp://gcc.gnu.org/pub/gcc/releases/gcc-${PV}/gcc-core-${PV}.tar.bz2
+ ftp://gcc.gnu.org/pub/gcc/releases/gcc-${PV}/gcc-ada-${PV}.tar.bz2
+ amd64? ( http://dev.gentoo.org/~george/src/gnatboot-${BOOT_SLOT}-amd64.tar.bz2 )
+ sparc? ( http://dev.gentoo.org/~george/src/gnatboot-${BOOT_SLOT}-sparc.tar.bz2 )
+ x86? ( http://dev.gentoo.org/~george/src/gnatboot-${BOOT_SLOT}-i686.tar.bz2 )"
+# ppc? ( mirror://gentoo/gnatboot-${BOOT_SLOT}-ppc.tar.bz2 )
+
+KEYWORDS="~amd64 ~x86 ~sparc"
+
+# starting with 4.3.0 gnat needs these libs
+RDEPEND=">=dev-libs/mpfr-2.3.1
+ >=dev-libs/gmp-4.2.2
+ >=sys-libs/zlib-1.1.4
+ >=sys-libs/ncurses-5.2-r2"
+
+DEPEND="${RDEPEND}
+ >=sys-devel/bison-1.875
+ >=sys-libs/glibc-2.8
+ >=sys-devel/binutils-2.15.94"
+
+#QA_EXECSTACK="${BINPATH:1}/gnatls ${BINPATH:1}/gnatbind ${BINPATH:1}/gnatmake
+# ${LIBEXECPATH:1}/gnat1 ${LIBPATH:1}/adalib/libgnat-${SLOT}.so"
+
+src_unpack() {
+ gnatbuild_src_unpack
+
+ #fixup some hardwired flags
+ cd "${S}"/gcc/ada
+
+ # universal gcc -> gnatgcc substitution occasionally produces lines too long
+ # and then build halts on the style check.
+ #
+ sed -i -e 's:and Nam is "gnatgcc":and Nam is "gcc":' osint.ads ||
+ die "reversing [gnat]gcc substitution in comments failed"
+
+ # gcc pretty much ignores --with-system-zlib. At least it still descends
+ # into zlib and does configure and build there (gcc bug@7125?). For whatever
+ # reason this conflicts with multilib in gcc-4.4..
+ sed -i -e "s:libgui zlib:libgui:" "${S}"/configure
+
+ # looks like wrapper has problems with all the quotation
+ sed -i -e "/-DREVISION/d" -e "/-DDEVPHASE/d" \
+ -e "s: -DDATESTAMP=\$(DATESTAMP_s)::" "${S}"/gcc/Makefile.in
+ sed -i -e "s: DATESTAMP DEVPHASE REVISION::" \
+ -e "s:PKGVERSION:\"\":" "${S}"/gcc/version.c
+}
+
+src_compile() {
+ # looks like gnatlib_and_tools and gnatlib_shared have become part of
+ # bootstrap
+ gnatbuild_src_compile configure make-tools bootstrap
+}