summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2010-07-21 21:49:34 +0000
committerSergei Trofimovich <slyfox@gentoo.org>2010-07-21 21:49:34 +0000
commit5c356257dd13b2e89848586553724f150b2b2ea1 (patch)
tree0355645b284c286147e596801f0c35ed70b8eff7 /dev-lang/ghc
parentUse -fno-strict-aliasing to avoid breaking strict-aliasing rules. (diff)
downloadgentoo-2-5c356257dd13b2e89848586553724f150b2b2ea1.tar.gz
gentoo-2-5c356257dd13b2e89848586553724f150b2b2ea1.tar.bz2
gentoo-2-5c356257dd13b2e89848586553724f150b2b2ea1.zip
Fixed build faiures on 'es' locale (bug #202212). Fixed f.i.w on ppc this time.
(Portage version: 2.1.8.3/cvs/Linux x86_64)
Diffstat (limited to 'dev-lang/ghc')
-rw-r--r--dev-lang/ghc/ChangeLog12
-rw-r--r--dev-lang/ghc/files/ghc-6.12.3-ppc-use-libffi-for-foreign-import-wrapper.patch13
-rw-r--r--dev-lang/ghc/ghc-6.10.4-r1.ebuild6
-rw-r--r--dev-lang/ghc/ghc-6.12.1.ebuild6
-rw-r--r--dev-lang/ghc/ghc-6.12.3.ebuild9
-rw-r--r--dev-lang/ghc/ghc-6.2.2.ebuild6
-rw-r--r--dev-lang/ghc/ghc-6.4.2.ebuild6
-rw-r--r--dev-lang/ghc/ghc-6.6.1.ebuild6
-rw-r--r--dev-lang/ghc/ghc-6.6.ebuild6
-rw-r--r--dev-lang/ghc/ghc-6.8.2-r1.ebuild6
-rw-r--r--dev-lang/ghc/ghc-6.8.2.ebuild6
11 files changed, 63 insertions, 19 deletions
diff --git a/dev-lang/ghc/ChangeLog b/dev-lang/ghc/ChangeLog
index 9fc30ccfdbe7..6ddc3c0898d1 100644
--- a/dev-lang/ghc/ChangeLog
+++ b/dev-lang/ghc/ChangeLog
@@ -1,6 +1,16 @@
# ChangeLog for dev-lang/ghc
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/ghc/ChangeLog,v 1.187 2010/07/20 13:28:06 josejx Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/ghc/ChangeLog,v 1.188 2010/07/21 21:49:33 slyfox Exp $
+
+ 21 Jul 2010; Sergei Trofimovich <slyfox@gentoo.org> ghc-6.2.2.ebuild,
+ ghc-6.4.2.ebuild, ghc-6.6.ebuild, ghc-6.6.1.ebuild, ghc-6.8.2.ebuild,
+ ghc-6.8.2-r1.ebuild, ghc-6.10.4-r1.ebuild, ghc-6.12.1.ebuild,
+ ghc-6.12.3.ebuild,
+ +files/ghc-6.12.3-ppc-use-libffi-for-foreign-import-wrapper.patch:
+ Fixed build faiures on 'es' locale (bug #202212). Thanks to Jesús
+ Guerrero <i92guboj@gentoo.org> and Francisco Lloret <fcolloret@terra.es>
+ for the report. Fixed f.i.w on ppc this time. Thanks to Joseph Jezak
+ <josejx@gentoo.org> for the failure report.
20 Jul 2010; Joseph Jezak <josejx@gentoo.org> ghc-6.12.3.ebuild:
Added ppc build for 6.12.3. Marked ~ppc.
diff --git a/dev-lang/ghc/files/ghc-6.12.3-ppc-use-libffi-for-foreign-import-wrapper.patch b/dev-lang/ghc/files/ghc-6.12.3-ppc-use-libffi-for-foreign-import-wrapper.patch
new file mode 100644
index 000000000000..bd712e3b5563
--- /dev/null
+++ b/dev-lang/ghc/files/ghc-6.12.3-ppc-use-libffi-for-foreign-import-wrapper.patch
@@ -0,0 +1,13 @@
+diff --git a/mk/config.mk.in b/mk/config.mk.in
+index 3fcc0f0..496a6f7 100644
+--- a/mk/config.mk.in
++++ b/mk/config.mk.in
+@@ -176,7 +176,7 @@ endif
+ # Whether to use libffi for adjustors (foreign import "wrapper") or
+ # not. If we have built-in support (rts/Adjustor.c) then we use that,
+ # otherwise we fall back on libffi, which is slightly slower.
+-ArchHasAdjustorSupport=$(strip $(if $(findstring $(HostArch_CPP),i386 x86_64 powerpc,),YES,NO))
++ArchHasAdjustorSupport=$(strip $(if $(findstring $(HostArch_CPP),i386 x86_64,),YES,NO))
+ ifeq "$(ArchHasAdjustorSupport)" "YES"
+ UseLibFFIForAdjustors=NO
+ else
diff --git a/dev-lang/ghc/ghc-6.10.4-r1.ebuild b/dev-lang/ghc/ghc-6.10.4-r1.ebuild
index 5ddeddaa9fb8..5b80455147f6 100644
--- a/dev-lang/ghc/ghc-6.10.4-r1.ebuild
+++ b/dev-lang/ghc/ghc-6.10.4-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/ghc/ghc-6.10.4-r1.ebuild,v 1.9 2010/07/16 20:23:27 slyfox Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/ghc/ghc-6.10.4-r1.ebuild,v 1.10 2010/07/21 21:49:33 slyfox Exp $
# Brief explanation of the bootstrap logic:
#
@@ -269,7 +269,9 @@ src_compile() {
econf || die "econf failed"
- emake all || die "make failed"
+ # LC_ALL needs to workaround ghc's ParseCmm failure on some (es) locales
+ # bug #202212 / http://hackage.haskell.org/trac/ghc/ticket/4207
+ LC_ALL=C emake all || die "make failed"
fi # ! use binary
}
diff --git a/dev-lang/ghc/ghc-6.12.1.ebuild b/dev-lang/ghc/ghc-6.12.1.ebuild
index 2a86404dd3c5..9e7fe4519aed 100644
--- a/dev-lang/ghc/ghc-6.12.1.ebuild
+++ b/dev-lang/ghc/ghc-6.12.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/ghc/ghc-6.12.1.ebuild,v 1.5 2010/07/14 09:02:35 slyfox Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/ghc/ghc-6.12.1.ebuild,v 1.6 2010/07/21 21:49:33 slyfox Exp $
# Brief explanation of the bootstrap logic:
#
@@ -257,7 +257,9 @@ src_compile() {
econf || die "econf failed"
- emake all || die "make failed"
+ # LC_ALL needs to workaround ghc's ParseCmm failure on some (es) locales
+ # bug #202212 / http://hackage.haskell.org/trac/ghc/ticket/4207
+ LC_ALL=C emake all || die "make failed"
fi # ! use binary
}
diff --git a/dev-lang/ghc/ghc-6.12.3.ebuild b/dev-lang/ghc/ghc-6.12.3.ebuild
index 354ed6e199f4..f8cdf76cd4a2 100644
--- a/dev-lang/ghc/ghc-6.12.3.ebuild
+++ b/dev-lang/ghc/ghc-6.12.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/ghc/ghc-6.12.3.ebuild,v 1.9 2010/07/20 13:28:06 josejx Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/ghc/ghc-6.12.3.ebuild,v 1.10 2010/07/21 21:49:33 slyfox Exp $
# Brief explanation of the bootstrap logic:
#
@@ -216,6 +216,9 @@ src_unpack() {
# native adjustor (NA) code is broken: interactive darcs-2.4 coredumps on NA
epatch "${FILESDIR}/ghc-6.12.3-ia64-use-libffi-for-foreign-import-wrapper.patch"
+ # same with NA on ppc
+ epatch "${FILESDIR}/ghc-6.12.3-ppc-use-libffi-for-foreign-import-wrapper.patch"
+
# as we have changed the build system
eautoreconf
fi
@@ -284,7 +287,9 @@ src_compile() {
econf || die "econf failed"
- emake all || die "make failed"
+ # LC_ALL needs to workaround ghc's ParseCmm failure on some (es) locales
+ # bug #202212 / http://hackage.haskell.org/trac/ghc/ticket/4207
+ LC_ALL=C emake all || die "make failed"
fi # ! use binary
}
diff --git a/dev-lang/ghc/ghc-6.2.2.ebuild b/dev-lang/ghc/ghc-6.2.2.ebuild
index 249f4a167c3d..c9bfc4633f1f 100644
--- a/dev-lang/ghc/ghc-6.2.2.ebuild
+++ b/dev-lang/ghc/ghc-6.2.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/ghc/ghc-6.2.2.ebuild,v 1.28 2010/07/14 09:02:35 slyfox Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/ghc/ghc-6.2.2.ebuild,v 1.29 2010/07/21 21:49:33 slyfox Exp $
# Brief explanation of the bootstrap logic:
#
@@ -232,8 +232,10 @@ src_compile() {
$(use opengl && echo "--enable-hopengl") \
|| die "econf failed"
+ # LC_ALL needs to workaround ghc's ParseCmm failure on some (es) locales
+ # bug #202212 / http://hackage.haskell.org/trac/ghc/ticket/4207
# ghc-6.2.x build system does not support parallel make
- emake -j1 datadir="/usr/share/doc/${P}" || die "make failed"
+ LC_ALL=C emake -j1 datadir="/usr/share/doc/${P}" || die "make failed"
# the explicit datadir is required to make the haddock entries
# in the package.conf file point to the right place ...
diff --git a/dev-lang/ghc/ghc-6.4.2.ebuild b/dev-lang/ghc/ghc-6.4.2.ebuild
index bae0d5a2929a..2246dfadcba0 100644
--- a/dev-lang/ghc/ghc-6.4.2.ebuild
+++ b/dev-lang/ghc/ghc-6.4.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/ghc/ghc-6.4.2.ebuild,v 1.29 2010/07/14 09:02:35 slyfox Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/ghc/ghc-6.4.2.ebuild,v 1.30 2010/07/21 21:49:33 slyfox Exp $
# Brief explanation of the bootstrap logic:
#
@@ -300,7 +300,9 @@ src_compile() {
$(use_enable X hgl) \
|| die "econf failed"
- emake all datadir="/usr/share/doc/${P}" || die "make failed"
+ # LC_ALL needs to workaround ghc's ParseCmm failure on some (es) locales
+ # bug #202212 / http://hackage.haskell.org/trac/ghc/ticket/4207
+ LC_ALL=C emake all datadir="/usr/share/doc/${P}" || die "make failed"
# the explicit datadir is required to make the haddock entries
# in the package.conf file point to the right place ...
diff --git a/dev-lang/ghc/ghc-6.6.1.ebuild b/dev-lang/ghc/ghc-6.6.1.ebuild
index 2a6d3bababb0..6114b1abceb1 100644
--- a/dev-lang/ghc/ghc-6.6.1.ebuild
+++ b/dev-lang/ghc/ghc-6.6.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/ghc/ghc-6.6.1.ebuild,v 1.20 2010/07/14 09:02:35 slyfox Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/ghc/ghc-6.6.1.ebuild,v 1.21 2010/07/21 21:49:33 slyfox Exp $
# Brief explanation of the bootstrap logic:
#
@@ -270,7 +270,9 @@ src_compile() {
econf || die "econf failed"
- emake all datadir="/usr/share/doc/${P}" || die "make failed"
+ # LC_ALL needs to workaround ghc's ParseCmm failure on some (es) locales
+ # bug #202212 / http://hackage.haskell.org/trac/ghc/ticket/4207
+ LC_ALL=C emake all datadir="/usr/share/doc/${P}" || die "make failed"
# the explicit datadir is required to make the haddock entries
# in the package.conf file point to the right place ...
diff --git a/dev-lang/ghc/ghc-6.6.ebuild b/dev-lang/ghc/ghc-6.6.ebuild
index 605282b5a81b..0c3db64e1f3d 100644
--- a/dev-lang/ghc/ghc-6.6.ebuild
+++ b/dev-lang/ghc/ghc-6.6.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/ghc/ghc-6.6.ebuild,v 1.17 2010/07/14 09:02:35 slyfox Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/ghc/ghc-6.6.ebuild,v 1.18 2010/07/21 21:49:33 slyfox Exp $
# Brief explanation of the bootstrap logic:
#
@@ -250,7 +250,9 @@ src_compile() {
econf || die "econf failed"
- emake all datadir="/usr/share/doc/${P}" || die "make failed"
+ # LC_ALL needs to workaround ghc's ParseCmm failure on some (es) locales
+ # bug #202212 / http://hackage.haskell.org/trac/ghc/ticket/4207
+ LC_ALL=C emake all datadir="/usr/share/doc/${P}" || die "make failed"
# the explicit datadir is required to make the haddock entries
# in the package.conf file point to the right place ...
diff --git a/dev-lang/ghc/ghc-6.8.2-r1.ebuild b/dev-lang/ghc/ghc-6.8.2-r1.ebuild
index d6f6bdbe92fe..ac257a4e5030 100644
--- a/dev-lang/ghc/ghc-6.8.2-r1.ebuild
+++ b/dev-lang/ghc/ghc-6.8.2-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/ghc/ghc-6.8.2-r1.ebuild,v 1.4 2010/07/14 09:02:35 slyfox Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/ghc/ghc-6.8.2-r1.ebuild,v 1.5 2010/07/21 21:49:33 slyfox Exp $
# Brief explanation of the bootstrap logic:
#
@@ -218,7 +218,9 @@ src_compile() {
econf || die "econf failed"
- emake all || die "make failed"
+ # LC_ALL needs to workaround ghc's ParseCmm failure on some (es) locales
+ # bug #202212 / http://hackage.haskell.org/trac/ghc/ticket/4207
+ LC_ALL=C emake all || die "make failed"
}
src_install() {
diff --git a/dev-lang/ghc/ghc-6.8.2.ebuild b/dev-lang/ghc/ghc-6.8.2.ebuild
index a58693b4d276..52114a3646af 100644
--- a/dev-lang/ghc/ghc-6.8.2.ebuild
+++ b/dev-lang/ghc/ghc-6.8.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/ghc/ghc-6.8.2.ebuild,v 1.15 2010/07/14 09:02:35 slyfox Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/ghc/ghc-6.8.2.ebuild,v 1.16 2010/07/21 21:49:33 slyfox Exp $
# Brief explanation of the bootstrap logic:
#
@@ -212,7 +212,9 @@ src_compile() {
econf || die "econf failed"
- emake all || die "make failed"
+ # LC_ALL needs to workaround ghc's ParseCmm failure on some (es) locales
+ # bug #202212 / http://hackage.haskell.org/trac/ghc/ticket/4207
+ LC_ALL=C emake all || die "make failed"
fi # ! use binary
}