summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndres Loeh <kosmikus@gentoo.org>2004-10-18 22:54:07 +0000
committerAndres Loeh <kosmikus@gentoo.org>2004-10-18 22:54:07 +0000
commit9fdcdb61057070aaec7cb2ea47f73aa1b842576d (patch)
treed1dc8f74f417c878f89a0cd32a7f253118973fc5 /dev-lang/ghc-bin
parentVersion bump #68059 by Jacob Joseph. (Manifest recommit) (diff)
downloadgentoo-2-9fdcdb61057070aaec7cb2ea47f73aa1b842576d.tar.gz
gentoo-2-9fdcdb61057070aaec7cb2ea47f73aa1b842576d.tar.bz2
gentoo-2-9fdcdb61057070aaec7cb2ea47f73aa1b842576d.zip
fix environment settings
Diffstat (limited to 'dev-lang/ghc-bin')
-rw-r--r--dev-lang/ghc-bin/ChangeLog5
-rw-r--r--dev-lang/ghc-bin/ghc-bin-6.2.1.ebuild27
2 files changed, 23 insertions, 9 deletions
diff --git a/dev-lang/ghc-bin/ChangeLog b/dev-lang/ghc-bin/ChangeLog
index 582966120424..db4124cdcd38 100644
--- a/dev-lang/ghc-bin/ChangeLog
+++ b/dev-lang/ghc-bin/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-lang/ghc-bin
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/ghc-bin/ChangeLog,v 1.18 2004/10/18 17:03:04 kosmikus Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/ghc-bin/ChangeLog,v 1.19 2004/10/18 22:54:07 kosmikus Exp $
+
+ 19 Oct 2004; Andres Loeh <kosmikus@gentoo.org> ghc-bin-6.2.1.ebuild:
+ Fix amd64 version to properly install environment file.
*ghc-bin-6.2.2 (18 Oct 2004)
diff --git a/dev-lang/ghc-bin/ghc-bin-6.2.1.ebuild b/dev-lang/ghc-bin/ghc-bin-6.2.1.ebuild
index cb0e3b8486f0..d66b69683c79 100644
--- a/dev-lang/ghc-bin/ghc-bin-6.2.1.ebuild
+++ b/dev-lang/ghc-bin/ghc-bin-6.2.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/ghc-bin/ghc-bin-6.2.1.ebuild,v 1.1 2004/10/17 09:05:32 absinthe Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/ghc-bin/ghc-bin-6.2.1.ebuild,v 1.2 2004/10/18 22:54:07 kosmikus Exp $
IUSE=""
@@ -8,13 +8,16 @@ S="${WORKDIR}"
DESCRIPTION="Glasgow Haskell Compiler (binary-only version for amd64)"
SRC_URI="http://debian-amd64.alioth.debian.org/pure64/pool/unstable/main/amd64/g/ghc6/ghc6_6.2.1-5_amd64.deb"
HOMEPAGE="http://www.haskell.org"
+
LICENSE="as-is"
KEYWORDS="-* ~amd64"
SLOT="0"
+
DEPEND="app-arch/dpkg"
RDEPEND=">=dev-lang/perl-5.6.1
>=sys-devel/gcc-2.95.3
>=dev-libs/gmp-4.1"
+
PROVIDE="virtual/ghc"
src_unpack() {
@@ -38,16 +41,24 @@ src_install () {
# Generate symlinks in ${D}/opt/ghc/bin
mkdir -p ${D}/opt/ghc/bin
pushd ${D}/opt/ghc/bin
- ln -s ../lib/bin/ghc ghc6
- ln -s ../lib/bin/ghci ghci6
- ln -s ghc6 ghc
- ln -s ghci6 ghci
+ ln -s ../lib/bin/ghc ghc-${PV}
+ ln -s ../lib/bin/ghci ghci-${PV}
+ ln -s ghc-${PV} ghc
+ ln -s ghci-${PV} ghci
popd
+ # TODO: what about documentation
+ # TODO: can clean_wrappers be reused from the other ghc-bin
+ # ebuilds; isn't RDEPEND perl needed if we call perl here?
+
# Adjust paths in ${D}/opt/ghc/lib/bin
pushd ${D}/opt/ghc/lib/bin
- perl -i -ne 's#/usr/lib/ghc-6.2.1#/opt/ghc/lib#g;
- s#/usr/share/ghc-6.2.1#/opt/ghc/share#g;print' \
- ghc-6.2.1 ghci-6.2.1 ghcprof hsc2hs ghc-pkg-6.2.1
+ perl -i -ne "s:/usr/lib/ghc-${PV}:/opt/ghc/lib:g;
+ s:/usr/share/ghc-${PV}:/opt/ghc/share:g;print" \
+ ghc-${PV} ghci-${PV} ghcprof hsc2hs ghc-pkg-${PV}
popd
+
+ insinto /etc/env.d
+ doins ${FILESDIR}/10ghc
+
}