summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2009-01-08 23:52:30 +0000
committerPatrick Lauer <patrick@gentoo.org>2009-01-08 23:52:30 +0000
commit144c038c3837d17d1f73bdfa4c0621306f701372 (patch)
tree85060b7e48477ad7b7101eab00021b29333c3bdb /dev-lang/gforth
parentBump to 2.24.1. (diff)
downloadgentoo-2-144c038c3837d17d1f73bdfa4c0621306f701372.tar.gz
gentoo-2-144c038c3837d17d1f73bdfa4c0621306f701372.tar.bz2
gentoo-2-144c038c3837d17d1f73bdfa4c0621306f701372.zip
Readding accidentally dropped arches
(Portage version: 2.2_rc20/cvs/Linux 2.6.28 x86_64)
Diffstat (limited to 'dev-lang/gforth')
-rw-r--r--dev-lang/gforth/ChangeLog5
-rw-r--r--dev-lang/gforth/gforth-0.7.0.ebuild41
2 files changed, 24 insertions, 22 deletions
diff --git a/dev-lang/gforth/ChangeLog b/dev-lang/gforth/ChangeLog
index 20c0326cc9c3..75c5f4fd299c 100644
--- a/dev-lang/gforth/ChangeLog
+++ b/dev-lang/gforth/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-lang/gforth
# Copyright 2002-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/gforth/ChangeLog,v 1.27 2009/01/04 22:47:42 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/gforth/ChangeLog,v 1.28 2009/01/08 23:52:30 patrick Exp $
+
+ 08 Jan 2009; Patrick Lauer <patrick@gentoo.org> gforth-0.7.0.ebuild:
+ Readding arches that were accidentally dropped
*gforth-0.7.0 (04 Jan 2009)
diff --git a/dev-lang/gforth/gforth-0.7.0.ebuild b/dev-lang/gforth/gforth-0.7.0.ebuild
index 70ac2598ed2d..86aeb9d989b8 100644
--- a/dev-lang/gforth/gforth-0.7.0.ebuild
+++ b/dev-lang/gforth/gforth-0.7.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/gforth/gforth-0.7.0.ebuild,v 1.2 2009/01/05 01:18:38 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/gforth/gforth-0.7.0.ebuild,v 1.3 2009/01/08 23:52:30 patrick Exp $
inherit elisp-common eutils toolchain-funcs flag-o-matic
@@ -10,7 +10,7 @@ SRC_URI="ftp://ftp.gnu.org/pub/gnu/gforth/${P}.tar.gz"
LICENSE="GPL-3"
SLOT="0"
-KEYWORDS="~amd64 ~x86"
+KEYWORDS="~amd64 ~ppc ~x86 ~x86-fbsd"
IUSE="emacs"
DEPEND="virtual/libc
@@ -26,38 +26,37 @@ src_unpack() {
}
src_compile() {
- local myconf
+ local myconf
- # May want to add a USE flag for --enable-force-cdiv, if necessary
- # At this point I do not know when that is appropriate, and I don't
- # want to add an ebuild-specific USE flag without understanding.
+ # May want to add a USE flag for --enable-force-cdiv, if necessary
+ # At this point I do not know when that is appropriate, and I don't
+ # want to add an ebuild-specific USE flag without understanding.
- if ! use emacs; then
- myconf="--without-lispdir"
- fi
+ if ! use emacs; then
+ myconf="--without-lispdir"
+ fi
- econf ${myconf} || die "econf failed"
-
- # Parallel make breaks here
- emake -j1 || die "emake failed"
+ econf ${myconf} || die "econf failed"
+ # Parallel make breaks here
+ emake -j1 || die "emake failed"
}
src_install() {
- emake DESTDIR="${D}" install || die "emake install failed"
+ emake DESTDIR="${D}" install || die "emake install failed"
- dodoc AUTHORS BUGS ChangeLog NEWS* README* ToDo doc/glossaries.doc doc/*.ps
+ dodoc AUTHORS BUGS ChangeLog NEWS* README* ToDo doc/glossaries.doc doc/*.ps
- if use emacs; then
- elisp-install ${PN} gforth.el gforth.elc || die "elisp-install failed"
- elisp-site-file-install "${FILESDIR}/${SITEFILE}" || die
- fi
+ if use emacs; then
+ elisp-install ${PN} gforth.el gforth.elc || die "elisp-install failed"
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}" || die
+ fi
}
pkg_postinst() {
- use emacs && elisp-site-regen
+ use emacs && elisp-site-regen
}
pkg_postrm() {
- use emacs && elisp-site-regen
+ use emacs && elisp-site-regen
}