summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2013-02-19 12:31:48 +0000
committerJustin Lecher <jlec@gentoo.org>2013-02-19 12:31:48 +0000
commitbd73a61b175898394228ba7250aee006da047bcb (patch)
treed62559535852a799ea273717ab55cce2bce6e456 /dev-lang/R
parentVersion bump (diff)
downloadgentoo-2-bd73a61b175898394228ba7250aee006da047bcb.tar.gz
gentoo-2-bd73a61b175898394228ba7250aee006da047bcb.tar.bz2
gentoo-2-bd73a61b175898394228ba7250aee006da047bcb.zip
dev-lang/R: Use tc-getPKG_CONFIG from toolchain-funcs.eclass instead of plain pkg-config
(Portage version: 2.2.0_alpha163/cvs/Linux x86_64, signed Manifest commit with key 70EB7916)
Diffstat (limited to 'dev-lang/R')
-rw-r--r--dev-lang/R/ChangeLog6
-rw-r--r--dev-lang/R/R-2.10.1.ebuild8
-rw-r--r--dev-lang/R/R-2.15.2.ebuild8
-rw-r--r--dev-lang/R/metadata.xml12
4 files changed, 19 insertions, 15 deletions
diff --git a/dev-lang/R/ChangeLog b/dev-lang/R/ChangeLog
index 8f512ac481fa..a4493e518605 100644
--- a/dev-lang/R/ChangeLog
+++ b/dev-lang/R/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-lang/R
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/R/ChangeLog,v 1.211 2013/02/18 19:45:15 calchan Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/R/ChangeLog,v 1.212 2013/02/19 12:31:48 jlec Exp $
+
+ 19 Feb 2013; Justin Lecher <jlec@gentoo.org> R-2.10.1.ebuild,
+ R-2.15.2.ebuild, metadata.xml:
+ Use tc-getPKG_CONFIG from toolchain-funcs.eclass instead of plain pkg-config
18 Feb 2013; Denis Dupeyron <calchan@gentoo.org> R-2.15.2-r2.ebuild:
Fix ar being called directly (bug #457758).
diff --git a/dev-lang/R/R-2.10.1.ebuild b/dev-lang/R/R-2.10.1.ebuild
index af350ef38f13..4e522a36ec26 100644
--- a/dev-lang/R/R-2.10.1.ebuild
+++ b/dev-lang/R/R-2.10.1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/R/R-2.10.1.ebuild,v 1.18 2012/10/07 13:35:21 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/R/R-2.10.1.ebuild,v 1.19 2013/02/19 12:31:48 jlec Exp $
EAPI=2
@@ -88,7 +88,7 @@ src_prepare() {
sed -i -e 's:png_ptr->jmpbuf:png_jmpbuf(png_ptr):' src/modules/X11/rbitmap.c || die
use lapack && \
- export LAPACK_LIBS="$(pkg-config --libs lapack)"
+ export LAPACK_LIBS="$($(tc-getPKG_CONFIG) --libs lapack)"
if use X; then
export R_BROWSER="$(type -p xdg-open)"
@@ -108,7 +108,7 @@ src_configure() {
--with-system-zlib \
--with-system-bzlib \
--with-system-pcre \
- --with-blas="$(pkg-config --libs blas)" \
+ --with-blas="$($(tc-getPKG_CONFIG) --libs blas)" \
--docdir=/usr/share/doc/${PF} \
rdocdir=/usr/share/doc/${PF} \
$(use_enable nls) \
diff --git a/dev-lang/R/R-2.15.2.ebuild b/dev-lang/R/R-2.15.2.ebuild
index fd85fc5f9fa6..70c5c337b0ea 100644
--- a/dev-lang/R/R-2.15.2.ebuild
+++ b/dev-lang/R/R-2.15.2.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/R/R-2.15.2.ebuild,v 1.1 2012/10/26 21:44:05 calchan Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/R/R-2.15.2.ebuild,v 1.2 2013/02/19 12:31:48 jlec Exp $
EAPI=4
@@ -96,7 +96,7 @@ src_prepare() {
$(grep -Flr ../manual/ doc) || die "sed for HTML links failed"
use lapack && \
- export LAPACK_LIBS="$(pkg-config --libs lapack)"
+ export LAPACK_LIBS="$($(tc-getPKG_CONFIG) --libs lapack)"
if use X; then
export R_BROWSER="$(type -p xdg-open)"
@@ -133,7 +133,7 @@ src_configure() {
--with-system-bzlib \
--with-system-pcre \
--with-system-xz \
- --with-blas="$(pkg-config --libs blas)" \
+ --with-blas="$($(tc-getPKG_CONFIG) --libs blas)" \
--docdir="${EPREFIX}/usr/share/doc/${PF}" \
rdocdir="${EPREFIX}/usr/share/doc/${PF}" \
$(use_enable nls) \
diff --git a/dev-lang/R/metadata.xml b/dev-lang/R/metadata.xml
index 5d205a8da7fb..1deadcbddd09 100644
--- a/dev-lang/R/metadata.xml
+++ b/dev-lang/R/metadata.xml
@@ -1,12 +1,12 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
-<herd>sci-mathematics</herd>
-<maintainer>
- <email>calchan@gentoo.org</email>
- <name>Denis Dupeyron</name>
-</maintainer>
-<longdescription lang="en">
+ <herd>sci-mathematics</herd>
+ <maintainer>
+ <email>calchan@gentoo.org</email>
+ <name>Denis Dupeyron</name>
+ </maintainer>
+ <longdescription lang="en">
R is GNU S, a system for statistical computation and graphics. It
consists of a language plus a run-time environment with graphics, a
debugger, access to certain system functions, and the ability to run