summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKarl Trygve Kalleberg <karltk@gentoo.org>2004-03-31 22:59:52 +0000
committerKarl Trygve Kalleberg <karltk@gentoo.org>2004-03-31 22:59:52 +0000
commitfbe9e6cc640d1872d666f669dcf5a25ebc3fc8cd (patch)
tree94bb6457da447b6d8737e999fd50f09114d22c4d /dev-java
parentStable on x86. (Manifest recommit) (diff)
downloadgentoo-2-fbe9e6cc640d1872d666f669dcf5a25ebc3fc8cd.tar.gz
gentoo-2-fbe9e6cc640d1872d666f669dcf5a25ebc3fc8cd.tar.bz2
gentoo-2-fbe9e6cc640d1872d666f669dcf5a25ebc3fc8cd.zip
Initial import. Submitted by the allmighty Gonzo the Balladplayer.
Diffstat (limited to 'dev-java')
-rw-r--r--dev-java/activation/ChangeLog9
-rw-r--r--dev-java/activation/Manifest5
-rw-r--r--dev-java/activation/activation-20040331.ebuild31
-rw-r--r--dev-java/activation/files/digest-activation-200403311
-rw-r--r--dev-java/activation/metadata.xml23
5 files changed, 69 insertions, 0 deletions
diff --git a/dev-java/activation/ChangeLog b/dev-java/activation/ChangeLog
new file mode 100644
index 000000000000..43b0aeb3b579
--- /dev/null
+++ b/dev-java/activation/ChangeLog
@@ -0,0 +1,9 @@
+# ChangeLog for dev-java/activation
+# Copyright 2000-2004 Gentoo Technologies, Inc.; Distributed unde the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/activation/ChangeLog,v 1.1 2004/03/31 22:59:52 karltk Exp $
+
+*activation-20040331 (01 Apr 2004)
+
+ 01 Apr 2004; Karl Trygve Kalleberg <karltk@gentoo.org>
+ activation-20040331.ebuild: Initial import. Ebuild submitted by
+ myself. No joke.
diff --git a/dev-java/activation/Manifest b/dev-java/activation/Manifest
new file mode 100644
index 000000000000..5f3fec6694ad
--- /dev/null
+++ b/dev-java/activation/Manifest
@@ -0,0 +1,5 @@
+MD5 1916299f27ee443c90c2ac63c0a67d12 activation-20040331.ebuild 372
+MD5 27a6c5c7c566f5136ce1925bb936315d ChangeLog 294
+MD5 0637a933ecb6e8cedfc4ddfcf3491728 metadata.xml 310
+MD5 80440aacff6c5b65c5b42a58cf466be7 activation-20040331.ebuild~ 338
+MD5 db9ee8703853fa0d290d274c3555673d files/digest-activation-20040331 78
diff --git a/dev-java/activation/activation-20040331.ebuild b/dev-java/activation/activation-20040331.ebuild
new file mode 100644
index 000000000000..50ad443d6aaf
--- /dev/null
+++ b/dev-java/activation/activation-20040331.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/activation/activation-20040331.ebuild,v 1.1 2004/03/31 22:59:52 karltk Exp $
+
+inherit java-pkg
+
+DESCRIPTION="GNU implementation of the Java Activation Framework"
+HOMEPAGE="http://www.gnu.org/software/classpathx/jaf/"
+SRC_URI="http://www.gentoo.org/~karltk/java/distfiles/activation-20040331-gentoo.tar.bz2"
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE="doc"
+RDEPEND=">=virtual/jre-1.4"
+DEPEND=">=virtual/jdk-1.4"
+
+src_compile() {
+ econf || die
+ emake || die
+ if $(use doc) ; then
+ emake javadoc || die
+ fi
+}
+
+src_install() {
+ java-pkg_dojar activation.jar
+
+ dodoc AUTHORS COPYING ChangeLog INSTALL NEWS README
+ use doc && dohtml -r docs/*
+}
+
diff --git a/dev-java/activation/files/digest-activation-20040331 b/dev-java/activation/files/digest-activation-20040331
new file mode 100644
index 000000000000..e37e0ea2e0a2
--- /dev/null
+++ b/dev-java/activation/files/digest-activation-20040331
@@ -0,0 +1 @@
+MD5 2a26cff9f2b2e8bae0be8e876377e2cd activation-20040331-gentoo.tar.bz2 80708
diff --git a/dev-java/activation/metadata.xml b/dev-java/activation/metadata.xml
new file mode 100644
index 000000000000..8826ab18fa5c
--- /dev/null
+++ b/dev-java/activation/metadata.xml
@@ -0,0 +1,23 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+
+<pkgmetadata>
+<herd>java</herd>
+
+<longdescription>
+GNU JAF is a framework for declaring what beans operate on what MIME
+type data. Content handler beans can be defined to handle particular
+MIME content. The JAF unites internet standards for declaring content
+with JavaBeans(tm).
+
+The JAF defines two mechanisms within the framework. The first, the file
+type map, specifies the MIME content type for a given file. The default
+implementation of this uses the UNIX mime.types format to map filename
+extensions to MIME types. The second mechanism, the command map,
+specifies the actions that can be applied to a given MIME content type.
+The default implementation of this uses the standard mailcap format to
+map actions to JavaBean(tm) classes. These beans can then view,
+edit, print, or perform whatever other action is required on the
+underlying resource.
+</longdescription>
+</pkgmetadata>