summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJan Brinkmann <luckyduck@gentoo.org>2005-06-16 16:59:57 +0000
committerJan Brinkmann <luckyduck@gentoo.org>2005-06-16 16:59:57 +0000
commitf9a9428dd35bd5b9e07cfaa2162f12b7f0d3a117 (patch)
tree6ff3dbca5dbd4dd2b1137a480954abb6882c0afb /dev-java
parentAdded proper CFLAGS support. (diff)
downloadgentoo-2-f9a9428dd35bd5b9e07cfaa2162f12b7f0d3a117.tar.gz
gentoo-2-f9a9428dd35bd5b9e07cfaa2162f12b7f0d3a117.tar.bz2
gentoo-2-f9a9428dd35bd5b9e07cfaa2162f12b7f0d3a117.zip
Removed vulnerable version wrt security bug #96092.
(Portage version: 2.0.51.22-r1)
Diffstat (limited to 'dev-java')
-rw-r--r--dev-java/sun-jdk/ChangeLog6
-rw-r--r--dev-java/sun-jdk/files/digest-sun-jdk-1.4.2.07-r12
-rw-r--r--dev-java/sun-jdk/files/sun-jdk-1.4.2.0712
-rw-r--r--dev-java/sun-jdk/sun-jdk-1.4.2.07-r1.ebuild192
4 files changed, 5 insertions, 207 deletions
diff --git a/dev-java/sun-jdk/ChangeLog b/dev-java/sun-jdk/ChangeLog
index f259b126b56b..981519e48dfc 100644
--- a/dev-java/sun-jdk/ChangeLog
+++ b/dev-java/sun-jdk/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-java/sun-jdk
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/sun-jdk/ChangeLog,v 1.112 2005/05/18 15:48:35 axxo Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/sun-jdk/ChangeLog,v 1.113 2005/06/16 16:59:57 luckyduck Exp $
+
+ 16 Jun 2005; Jan Brinkmann <luckyduck@gentoo.org> -files/sun-jdk-1.4.2.07,
+ -sun-jdk-1.4.2.07-r1.ebuild:
+ Removed vulnerable version wrt security bug #96092.
18 May 2005; Thomas Matthijs <axxo@gentoo.org> sun-jdk-1.2.2.017.ebuild,
sun-jdk-1.3.1.13.ebuild, sun-jdk-1.4.2.07-r1.ebuild,
diff --git a/dev-java/sun-jdk/files/digest-sun-jdk-1.4.2.07-r1 b/dev-java/sun-jdk/files/digest-sun-jdk-1.4.2.07-r1
deleted file mode 100644
index b576a1bd322a..000000000000
--- a/dev-java/sun-jdk/files/digest-sun-jdk-1.4.2.07-r1
+++ /dev/null
@@ -1,2 +0,0 @@
-MD5 a55a9150977de7d5c7f78d29593a8b8c j2sdk-1_4_2_07-linux-i586.bin 36406456
-MD5 ff961c5f5326191c5ac2e4624d756f7e jce_policy-1_4_2.zip 12195
diff --git a/dev-java/sun-jdk/files/sun-jdk-1.4.2.07 b/dev-java/sun-jdk/files/sun-jdk-1.4.2.07
deleted file mode 100644
index b644c9d3f6a3..000000000000
--- a/dev-java/sun-jdk/files/sun-jdk-1.4.2.07
+++ /dev/null
@@ -1,12 +0,0 @@
-# Copyright 1999-2004 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/sun-jdk/files/sun-jdk-1.4.2.07,v 1.1 2005/01/27 19:03:37 compnerd Exp $
-
-VERSION="Sun JDK @PV@"
-JAVA_HOME=/opt/@P@
-JDK_HOME=/opt/@P@
-JAVAC=${JAVA_HOME}/bin/javac
-ADDPATH="${JAVA_HOME}/bin:${JAVA_HOME}/jre/bin:${JAVA_HOME}/jre/javaws"
-ADDLDPATH="/opt/@P@/jre/lib"
-MANPATH="/opt/@P@/man"
-ENV_VARS="JAVA_HOME JDK_HOME JAVAC ADDPATH ADDLDPATH MANPATH"
diff --git a/dev-java/sun-jdk/sun-jdk-1.4.2.07-r1.ebuild b/dev-java/sun-jdk/sun-jdk-1.4.2.07-r1.ebuild
deleted file mode 100644
index 3332fa71ede5..000000000000
--- a/dev-java/sun-jdk/sun-jdk-1.4.2.07-r1.ebuild
+++ /dev/null
@@ -1,192 +0,0 @@
-# Copyright 1999-2005 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/sun-jdk/sun-jdk-1.4.2.07-r1.ebuild,v 1.5 2005/05/18 15:48:35 axxo Exp $
-
-inherit java eutils
-
-MY_PV=${PV%.*}_${PV##*.}
-MY_P=j2sdk${MY_PV}
-MY_PVB=${PV%.*}
-
-At="j2sdk-${PV//./_}-linux-i586.bin"
-jce_policy="jce_policy-${MY_PVB//./_}.zip"
-
-S="${WORKDIR}/${MY_P}"
-DESCRIPTION="Sun's J2SE Development Kit"
-HOMEPAGE="http://java.sun.com/j2se/1.4.2/"
-SRC_URI="${At}
- jce? ( ${jce_policy} )"
-SLOT="1.4"
-LICENSE="sun-bcla-java-vm"
-KEYWORDS="x86 -*"
-RESTRICT="fetch"
-IUSE="doc mozilla jce"
-
-DEPEND=">=dev-java/java-config-1.1.5
- sys-apps/sed
- app-arch/unzip
- doc? ( =dev-java/java-sdk-docs-1.4.2* )"
-
-RDEPEND="sys-libs/lib-compat"
-
-PROVIDE="virtual/jre
- virtual/jdk"
-
-PACKED_JARS="lib/tools.jar jre/lib/rt.jar jre/lib/jsse.jar jre/lib/charsets.jar
-jre/lib/ext/localedata.jar jre/lib/plugin.jar jre/javaws/javaws.jar"
-
-# this is needed for proper operating under a PaX kernel without activated grsecurity acl
-CHPAX_CONSERVATIVE_FLAGS="pemrsv"
-
-DOWNLOAD_URL="http://javashoplm.sun.com/ECom/docs/Welcome.jsp?StoreId=22&PartDetailId=j2sdk-${MY_PV}-oth-JPR&SiteId=JSC&TransactionId=noreg"
-DOWNLOAD_URL_JCE="http://javashoplm.sun.com/ECom/docs/Welcome.jsp?StoreId=22&PartDetailId=7503-jce-${MY_PVB}-oth-JPR&SiteId=JSC&TransactionId=noreg"
-
-pkg_nofetch() {
- einfo "Please download ${At} from:"
- einfo ${DOWNLOAD_URL}
- einfo "(SDK 32-bit/64-bit for Windows/Linux/Solaris SPARC 32-bit for Solaris x86, then select download Linux Self-extracting."
- einfo "and move it to ${DISTDIR}"
- if use jce; then
- echo
- einfo "Also download ${jce_policy} from:"
- einfo ${DOWNLOAD_URL_JCE}
- einfo "Java(TM) Cryptography Extension (JCE) Unlimited Strength Jurisdiction Policy Files"
- einfo "and move it to ${DISTDIR}"
- fi
-}
-
-src_unpack() {
- if [ ! -r ${DISTDIR}/${At} ]; then
- die "cannot read ${MY_PV}.bin. Please check the permission and try again."
- fi
- if use jce; then
- if [ ! -r ${DISTDIR}/${jce_policy} ]; then
- die "cannot read ${jce_policy}. Please check the permission and try again."
- fi
- fi
- #Search for the ELF Header
- testExp=`echo -e "\177\105\114\106\001\001\001"`
- startAt=`grep -aonm 1 ${testExp} ${DISTDIR}/${At} | cut -d: -f1`
- tail -n +${startAt} ${DISTDIR}/${At} > install.sfx
- chmod +x install.sfx
- ./install.sfx || die
- rm install.sfx
-
- if [ -f ${S}/lib/unpack ]; then
- UNPACK_CMD=${S}/lib/unpack
- chmod +x $UNPACK_CMD
- sed -i 's#/tmp/unpack.log#/dev/null\x00\x00\x00\x00\x00\x00#g' $UNPACK_CMD
- for i in $PACKED_JARS; do
- PACK_FILE=${S}/`dirname $i`/`basename $i .jar`.pack
- if [ -f ${PACK_FILE} ]; then
- echo " unpacking: $i"
- $UNPACK_CMD ${PACK_FILE} ${S}/$i
- rm -f ${PACK_FILE}
- fi
- done
- fi
-}
-
-src_install() {
- local dirs="bin include jre lib man"
- dodir /opt/${P}
-
- for i in $dirs ; do
- cp -dPR $i ${D}/opt/${P}/
- done
-
- dodoc COPYRIGHT README LICENSE THIRDPARTYLICENSEREADME.txt
- dohtml README.html
- dodir /opt/${P}/share/
- cp -a demo src.zip ${D}/opt/${P}/share/
-
- if use jce ; then
- # Using unlimited jce while still retaining the strong jce
- # May have repercussions when you find you cannot symlink libraries
- # in classpaths.
- cd ${D}/opt/${P}/jre/lib/security
- unzip ${DISTDIR}/${jce_policy}
- mv jce unlimited-jce
- dodir /opt/${P}/jre/lib/security/strong-jce
- mv ${D}/opt/${P}/jre/lib/security/US_export_policy.jar ${D}/opt/${P}/jre/lib/security/strong-jce
- mv ${D}/opt/${P}/jre/lib/security/local_policy.jar ${D}/opt/${P}/jre/lib/security/strong-jce
- dosym /opt/${P}/jre/lib/security/unlimited-jce/US_export_policy.jar /opt/${P}/jre/lib/security/
- dosym /opt/${P}/jre/lib/security/unlimited-jce/local_policy.jar /opt/${P}/jre/lib/security/
- fi
-
- if use mozilla; then
- local plugin_dir="ns610"
- if has_version '>=gcc-3.2*' ; then
- plugin_dir="ns610-gcc32"
- fi
-
- install_mozilla_plugin /opt/${P}/jre/plugin/i386/${plugin_dir}/libjavaplugin_oji.so
- fi
-
- # create dir for system preferences
- dodir /opt/${P}/.systemPrefs
-
- # install control panel for Gnome/KDE
- sed -e "s/INSTALL_DIR\/JRE_NAME_VERSION/\/opt\/${P}\/jre/" \
- -e "s/\(Name=Java\)/\1 Control Panel/" \
- ${D}/opt/${P}/jre/plugin/desktop/sun_java.desktop > \
- ${T}/sun_java.desktop
-
- domenu ${T}/sun_java.desktop
-
- set_java_env ${FILESDIR}/${VMHANDLE}
-
- # TODO prepman "fixes" symlink ja -> ja__JP.eucJP in 'man' directory,
- # creating ja.gz -> ja_JP.eucJP.gz. This is broken as ja_JP.eucJP
- # is a directory and will not be gzipped ;)
-}
-
-pkg_postinst() {
- # Create files used as storage for system preferences.
- touch /opt/${P}/.systemPrefs/.system.lock
- chmod 644 /opt/${P}/.systemPrefs/.system.lock
- touch /opt/${P}/.systemPrefs/.systemRootModFile
- chmod 644 /opt/${P}/.systemPrefs/.systemRootModFile
-
- # Set as default VM if none exists
- java_pkg_postinst
-
- #Show info about netscape
- if has_version '>=netscape-navigator-4.79-r1' || has_version '>=netscape-communicator-4.79-r1' ; then
- echo
- einfo "If you want to install the plugin for Netscape 4.x, type"
- einfo
- einfo " cd /usr/lib/nsbrowser/plugins/"
- einfo " ln -sf /opt/${P}/jre/plugin/i386/ns4/libjavaplugin.so"
- fi
-
- # if chpax is on the target system, set the appropriate PaX flags
- # this will not hurt the binary, it modifies only unused ELF bits
- # but may confuse things like AV scanners and automatic tripwire
- if has_version "sys-apps/chpax"
- then
- echo
- einfo "setting up conservative PaX flags for jar, javac and java"
-
- for paxkills in "jar" "javac" "java" "javah" "javadoc"
- do
- chpax -${CHPAX_CONSERVATIVE_FLAGS} /opt/${PN}-${PV}/bin/$paxkills
- done
-
- # /opt/sun-jdk-1.4.2.03/jre/bin/java_vm
- chpax -${CHPAX_CONSERVATIVE_FLAGS} /opt/${PN}-${PV}/jre/bin/java_vm
-
- einfo "you should have seen lots of chpax output above now"
- ewarn "make sure the grsec ACL contains those entries also"
- ewarn "because enabling it will override the chpax setting"
- ewarn "on the physical files - help for PaX and grsecurity"
- ewarn "can be given by #gentoo-hardened + pappy@gentoo.org"
- fi
-
- echo
- eerror "Some parts of Sun's JDK require virtual/x11 to be installed."
- eerror "Be careful which Java libraries you attempt to use."
-
- ebeep 5
- epause 8
-}